JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   WK Grand Cherokee & XK Commander Forum (http://www.jeepforum.com/forum/f67/)
-   -   A raft of starting problems... (http://www.jeepforum.com/forum/f67/raft-starting-problems-1309869/)

CanadaLaredo 01-04-2012 05:11 PM

A raft of starting problems...
 
In the past month i've had two specific kinds of starting problems with my 2007 Grand Cherokee Laredo 4x4.

About a month ago, i turned the key in the ignition, and heard just one 'click' sound -- the dash lights all came on, but the starter didn't engage at all. However, after several attempts the vehicle started twenty minutes later and i was driving again with no problems.

Three weeks later, the same thing happened, however, the car did not start and I eventually had to have it towed to a dealer, who replaced the starter.

Now, two weeks after having the starter replaced, my wife tried to start the Jeep this morning and a new problem has occurred -- all of the lights on the dash flash madly, while a constant click-click-click sound comes from the dash. Moreover, the CD player starts to shuffle through the changer; the dash indicates I should get the 4x4 serviced; and finally, after all of this, the malfunction light flashes.

I'll need to take it to the dealer, but I'm hesitant to do so without the benefit of previous knowledge, if any exists out there. Has anyone else experienced something like this?

robpp 01-04-2012 05:14 PM

i would try the search button. these symptoms ALL have been documented here for 5-6 years.,

t3kmitch 01-04-2012 05:16 PM

Sounds like ignition switch.


The time now is 09:27 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.