Radio install has me crying - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Radio install has me crying

TeraFlex TJ 4" Lift Kit!! WANT A DEAL?!Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineNew! JK/U skid plate system.

Reply
Unread 04-20-2014, 07:43 PM   #1
lkrides
Registered User
1996 FSJ Cherokee 
 
Join Date: Aug 2007
Location: Maryland, U.S.A.
Posts: 6
Radio install has me crying

Hi all, I am trying to replace the RAQ radio in my wife’s 2007 Commander. This vehicle has the Boston Acoustic speakers and does not have NAV.

I purchased a Kenwood BT758HD radio and XSVI-6502 harness from Best Buy. I realized after connecting everything and not getting any sound that I blew it because I did not know this vehicle has an amp when I bought this stuff. So I guess the XSVI-6502 is just the wrong harness.

Next goof is that I purchased a Schosce CR4000 from Walmart. It provided sound but the speakers buzzed when the head unit was turned off while the key was still on. Additionally the fade function would not work.

So now after researching it seems that a PAC C2R-CHY (I’ve seen this for $80 or so on Sonix) or Metra CHT0-013BB (don’t know where to buy this) is the correct harness. Can anyone please confirm this or advise me?

Thanks very much.
Lee

lkrides is offline   Reply With Quote Quick reply to this message
Unread 04-21-2014, 12:08 PM   #2
Just_Josh
Member
2004 LJ Wrangler 
 
Join Date: Jan 2014
Location: Denver, CO
Posts: 110
PAC C2R-CHY4 is the one that worked for my 05 WK with factory amp. Got it on amazon for about $55 plus shipping. For the wiring, I had to wire front speakers on the HU to rear speakers on harness. It sounds fishy but it works and it sounds really good with the power of my Kenwood HU compared to factory HU. There was another harness that works but a person would have had to run it from amp in trunk area all the way to front dash.
Just_Josh is online now   Reply With Quote Quick reply to this message
Unread 04-21-2014, 01:06 PM   #3
XKAudioGuy
Registered User
 
Join Date: Jun 2013
Posts: 15
Use the pac or run all new speaker wire with new 4 channel amp. The stock speaker wire may be 20 gauge. I installed 8 inch mids in front doors with Orion HCCA silk tweeters on colums with 4 in Infinitys in dash. Sounds beautiful.
XKAudioGuy is offline   Reply With Quote Quick reply to this message
Unread 04-05-2015, 11:44 AM   #4
Samuell06WK
Registered User
 
Join Date: Mar 2015
Posts: 2
Quote:
Originally Posted by Just_Josh View Post
PAC C2R-CHY4 is the one that worked for my 05 WK with factory amp. Got it on amazon for about $55 plus shipping. For the wiring, I had to wire front speakers on the HU to rear speakers on harness. It sounds fishy but it works and it sounds really good with the power of my Kenwood HU compared to factory HU. There was another harness that works but a person would have had to run it from amp in trunk area all the way to front dash.
I am looking to install a new stereo amp subwoofer in my 06 WK. So with the PAC C2R-CHY4 will I be able to put in a sub and amp?
Samuell06WK is offline   Reply With Quote Quick reply to this message
Unread 04-08-2015, 03:12 PM   #5
Mattc123456
Registered User
 
Join Date: Jan 2015
Location: williamsport, md
Posts: 17
the aftermarket harness from the radio to the jeep should have a blue amp wire on both ends. connect them together. should work
Mattc123456 is offline   Reply With Quote Quick reply to this message
Unread 04-08-2015, 06:51 PM   #6
XKAudioGuy
Registered User
 
Join Date: Jun 2013
Posts: 15
If you are running new radio with no steering wheel controlls eliminate Pac and run new speaker wires to the speakers.
forumrunner_20150408_205045.jpg   forumrunner_20150408_205101.jpg  
XKAudioGuy is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.