Problems with '07 Commander - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 07-03-2013, 12:45 PM Thread Starter
somsjeep
Registered User
 
Join Date: Jul 2013
Location: Anderson
Posts: 5
Problems with '07 Commander

My commander keeps reving up on it's own and I need to know where I should begin to look at it myself to try and avoid spending alot of money. Also, I don't know if this will help, but I've also had problems with my AC turning off on it's own. I don't know if the two are somehow related. I took it to the shop and they charged me $150 for some new switch and it's still not working. Now, they are saying it is the control panel for the AC and it's at least $1000 to replace. My main concern is the jeep reving up on it's own. It's like I'm hitting the gas when I'm not.

somsjeep is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-03-2013, 02:58 PM
overland-wk
Registered User
2006 WK 
 
Join Date: Apr 2013
Location: Joliet
Posts: 213
What engine do you have 3.7 - 4.7 - 5.7?

06 ROR lifted wk (mine)
07 RC lifted xk (wife's)
Youtube channel
Bumsmodified98xj
overland-wk is offline  
post #3 of 9 Old 07-03-2013, 03:00 PM Thread Starter
somsjeep
Registered User
 
Join Date: Jul 2013
Location: Anderson
Posts: 5
4.7
somsjeep is offline  
post #4 of 9 Old 07-03-2013, 03:07 PM
overland-wk
Registered User
2006 WK 
 
Join Date: Apr 2013
Location: Joliet
Posts: 213
How long have u had your commander ? Im asking you this cause the previous owner might of ported the throttle body and from my past experience a ported throttle body on my wifes commander caused all sort of problems so you might want to start there.

06 ROR lifted wk (mine)
07 RC lifted xk (wife's)
Youtube channel
Bumsmodified98xj
overland-wk is offline  
post #5 of 9 Old 07-03-2013, 03:48 PM Thread Starter
somsjeep
Registered User
 
Join Date: Jul 2013
Location: Anderson
Posts: 5
Bought it off the lot in 08 brand new with only 300 or so miles on it. So, I've had for 5 years. Warranty was only good for 3.
somsjeep is offline  
post #6 of 9 Old 07-04-2013, 09:05 AM
trax95008
Registered User
2006 XK Commander 
 
Join Date: Dec 2005
Posts: 1,255
Start by cleaning your throttle body
trax95008 is offline  
post #7 of 9 Old 07-06-2013, 02:02 PM Thread Starter
somsjeep
Registered User
 
Join Date: Jul 2013
Location: Anderson
Posts: 5
I changed out the IAC thinking that would matter but it didn't. Guess I'll try to clean the throttle body next like y'all suggested. I'll have to Google how in the world to do that...seeing as how I'm a girl and all
somsjeep is offline  
post #8 of 9 Old 07-07-2013, 12:05 AM
trax95008
Registered User
2006 XK Commander 
 
Join Date: Dec 2005
Posts: 1,255
You can find a write up on this forum
trax95008 is offline  
post #9 of 9 Old 08-02-2013, 07:19 PM Thread Starter
somsjeep
Registered User
 
Join Date: Jul 2013
Location: Anderson
Posts: 5
Thanks for the advice guys. The mechanic thought cleaning the throttle body was it but it was the shifter sensor. Just thought I'd let ya know. Thanks again!
somsjeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome