post #1 of Old 04-18-2014, 09:21 PM Thread Starter
borderpatrol420
Registered User
2005 WK 
 
Join Date: Apr 2014
Location: overland park
Posts: 10
Problem with C/T button

Hey everyone,

I recently purchased a 2005 Jeep Grand Cherokee Limited and I've been messing with some of the buttons. I was changing a few of the settings like turning off the horn when I press the lock button and so on, but I noticed when I push the C/T button, nothing happens. I know this is supposed to cycle options between my compass, thermometer and such, but it's not working. Any suggestions? Should I just take the console apart and see if there's a loose wire or is there another spot I should check first? The button also doesn't feel like the others when I push it. There's a little resistance from the other buttons, but there seems to be a bit more when I push my C/T button. Any thoughts are greatly appreciated. Thanks.

borderpatrol420 is offline  
post #2 of Old 04-18-2014, 09:36 PM
joshmantesso13
Registered User
2007 XK Commander 
 
Join Date: Dec 2013
Location: Niagara Falls
Posts: 43
you mentioned that the button feels different, your best bet would be to take the switch panel apart to get a look inside.

possibly the rubber dome under the button is worn out? it has a small contact inside it and when depressed it contacts the circuit board, which should bring up the compass/temp.

thats just my guess
joshmantesso13 is offline  
post #3 of Old 04-18-2014, 10:19 PM
Pyroman_28
Registered User
2006 WK 
 
Join Date: Feb 2012
Location: Scranton-ish
Posts: 115
I'd lean towards the button as well seeing as the screen will display all the other information without issue.

'06 WK 4.7 Limited - OME, Bilsteins, AFE, Magnaflow, Superchips, 32's
Pyroman_28 is offline  
post #4 of Old 04-18-2014, 10:26 PM
Jtav2012
Registered User
2005 WK 
 
Join Date: Oct 2012
Location: Baltimore
Posts: 312
Quote:
Originally Posted by borderpatrol420 View Post
I know this is supposed to cycle options between my compass, thermometer and such.
Just throwing this out there, when I press my C/T button (in my 2005) it JUST goes back to the Compass/Temp display. I can hit it all I want, it won't do anything else. It doesn't cycle through anything.
Jtav2012 is offline  
post #5 of Old 04-18-2014, 10:57 PM
zeds_dead
Registered User
2005 WK 
 
Join Date: Sep 2011
Posts: 375
Quote:
Originally Posted by jtav2012 View Post

just throwing this out there, when i press my c/t button (in my 2005) it just goes back to the compass/temp display. I can hit it all i want, it won't do anything else. It doesn't cycle through anything.
x2

Everyday, something new you want to do. Disease of Jeeps.
zeds_dead is offline  
post #6 of Old 04-18-2014, 11:06 PM
Mitkch
Registered User
2007 WK 
 
Join Date: Mar 2014
Location: American Fork
Posts: 205
Quote:
Originally Posted by Jtav2012 View Post
Just throwing this out there, when I press my C/T button (in my 2005) it JUST goes back to the Compass/Temp display. I can hit it all I want, it won't do anything else. It doesn't cycle through anything.
x3

Black WK Club #138
Mitkch is offline  
post #7 of Old 04-19-2014, 07:40 AM
Shafer57
Registered User
2006 WK 
 
Join Date: Sep 2011
Location: delran
Posts: 686
Quote:
Originally Posted by Jtav2012 View Post
Just throwing this out there, when I press my C/T button (in my 2005) it JUST goes back to the Compass/Temp display. I can hit it all I want, it won't do anything else. It doesn't cycle through anything.
x3.5

Dodge Dakota R/T 360ci Small-block _sold_
Jeep GC 5.7L Hemi- Magnaflow Cat-Back, BT Catch Can, 20" Gloss black SRT Reps
275/45R20 Nexen Roadian, Blacked out, 180 Stat _SOLD_
2008 335i Twin-Turbo
Shafer57 is offline  
post #8 of Old 04-19-2014, 11:20 AM
colinzj
Registered User
2006 WK 
 
Join Date: Mar 2005
Location: Chandler, AZ
Posts: 1,676
x4.25. C/T does one thing: displays the Compass and Temperature screen.

2006 WK Laredo 4x4 4.7L
1993 ZJ Laredo 4x4 4.0L Dead, sold, and rolling again
colinzj is offline  
post #9 of Old 04-19-2014, 04:59 PM
CavallinoRed
Registered User
2006 WK 
 
Join Date: Oct 2013
Location: Arvada
Posts: 709
x5

If you are in the "Step" or "Menu" mode, the C/T button will change display to Compass and Temp. If you are already in CT mode..it does nothing. That is unless you are in park and hold for 5 seconds, then will put you in Compass calibration mode. This is used to correct the difference between magnetic north and geographic north.
CavallinoRed is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome