possible electrical issue with 06' hemi - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > possible electrical issue with 06' hemi

THE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great valueEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 12-18-2011, 05:27 PM   #1
Shafer57
Registered User
2006 WK 
 
Join Date: Sep 2011
Location: delran, nj
Posts: 667
possible electrical issue with 06' hemi

For no apparent reason dash and gauges lights flicker. Theres a few different light bulbs behind the faceplate with climate controls and the knobs and buttons next to that. Half of them work and half dont. I've pulled the panel and the only way they work is if i smack the back of it and then they go back to no power.

But what's weird is it's doing it to the temp and mileage displays on my gauge cluster. So i know it's not just a bad connection is the center console.

Any ideas/solutions are greatly appreciated

__________________
Dodge Dakota R/T 360ci Small-block _sold_
Jeep GC 5.7L Hemi- Magnaflow Cat-Back, BT Catch Can, 20" Gloss black SRT Reps
275/45R20 Nexen Roadian, Blacked out, 180 Stat _SOLD_
2008 335i Twin-Turbo
Shafer57 is online now   Reply With Quote
Reply

Tags
electrical
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.