Please help - Left Taillight problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Please help - Left Taillight problem

Steering and more from Ruffstuff!Ruffstuff 3 Link Kit!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome Effect

Reply
Unread 09-30-2013, 01:16 PM   #1
rightcoastnj
Registered User
2008 WK 
 
Join Date: Sep 2013
Location: manalapan, NJ
Posts: 1
Please help - Left Taillight problem

Hi all, glad i found this place..I searched but didn't seem to find something matching my exact issue..

I have a 2008 Grand Cherokee Limited 4x4.. love it, great truck.
Lately I have been experiencing a problem with my left (drivers side) tail light.. when the lights are in the "off" position, it seems to work just fine, but when i turn the lights to "on" or "auto", the left taillight stops working completely. When I use my turn signal, it blinks very quickly on my dashboard, and there is no sign of life whatsoever from the taillight itself. If I turn the lights back to "off", the problem persists, BUT if I turn the truck off, turn the lights to "off" and turn it back on, the taillight works again until I turn the lights back on.

I've already replaced the bulb 3 separate times.. It can't be the bulbs, but I have no idea what it could be.

Any help would be great. I don't want to get a ticket for my tail light being out

rightcoastnj is offline   Reply With Quote Quick reply to this message
Unread 10-04-2013, 09:50 AM   #2
GregK340
Registered User
2007 WK 
 
Join Date: Oct 2011
Location: Liverpool, NY
Posts: 75
Not sure if the 08's have a circuit board in tail light housing like other years, but they have corrosion issues, and may need to be cleaned, or replaced. Use the search feature on this forum. " tail light problems wk"
http://www.jeepforum.com/forum/f67/2...oblem-1271727/
GregK340 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.