Play in the Rear End - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 07-02-2013, 12:47 PM Thread Starter
00RedWJ
Registered User
2006 WK 
 
Join Date: Dec 2007
Location: Long Island, NY
Posts: 519
Play in the Rear End

I had my leaky Pinion Seal in the rear replaced about a year ago and no problems since. I do notice a fair amount of play in the rear if I hit the gas and let go abruptly it feels like theres more axle play then I'd expect. Is that normal or are these rears usually tight. It's a basic laredo with a 3.7 liter


2000 Red Laredo WJ
4.0 with Selec-trac - Sold
2006 Black Laredo WK
3.7 with 95,000 Miles
00RedWJ is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-02-2013, 03:29 PM
TonyIce05
Registered User
2005 WK 
 
Join Date: Apr 2012
Location: Tug Hill
Posts: 21
I also have the same issue with my 2005 WK Laredo 3.7L. When you let off and coast and get back on the gas there's a small... not clunk, not chugging, but like jerk in the drivetrain.

It would be good to hear from someone who knows if this is eventually going to cause damage...

| 2014 GC White Overland |
TonyIce05 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome