P0730 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > P0730

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueSteering Stabilizer Brackets...

Reply
Unread 02-04-2013, 09:06 AM   #1
Nookie
Registered User
2015 WK 
 
Join Date: Feb 2013
Location: London, Ontario
Posts: 122
P0730

Hi Guys, thanks for the great forum. Learned a lot about my WK CRD looking around here.

Well, 1st breakdown. Pulled the Code P0730, learned from here it can be just about anything in the transmission.
Did not get any further codes past that with my own reader. so figured off to dealer we go.

I put my experience on here for future readers.

Was stuck in gear(assume 1st or 2nd) and had few hard shifts prior to things going south, then engine light, no DTC on car display. ODB II said P0730.

Dealer says 68049181AA input sensor kaput. $1200+ tax for that job.
Thoughts or input appreciated.

Doing filter, fluid same time 80K Milkes on odometer.

-Gab

Nookie is offline   Reply With Quote Quick reply to this message
Unread 02-05-2013, 06:42 AM   #2
LJS8510
Web Wheeler
 
LJS8510's Avatar
2015 WK 
 
Join Date: Oct 2007
Location: Chicago Il, IL
Posts: 1,397
How is the transmission doing?
__________________

2015 WK II Overland, V8, Offroad Group II,- 2008 WK Limited 3.0 CRD, - 2003 WJ Laredo 4.7, - 2001 WJ Laredo 4.0, - 1999 WJ Limited 4.7-
LJS8510 is offline   Reply With Quote Quick reply to this message
Unread 02-05-2013, 06:52 AM   #3
Nookie
Registered User
2015 WK 
 
Join Date: Feb 2013
Location: London, Ontario
Posts: 122
Final diagnosis:
Error p2767

68049181aa $ 624.00 connector
52108325 $ 53.35 (optional filter replacement)
fluid $ 32.73
labor $ 360.00

$1070+tax

Part was in stock so was out the door in 4hrs, which was excellent service.
If weather was good I would take a crack at it myself but it's about 0F here this week so - coooooold.
Seem like this connector can be had for around $125 online, guess I'll order a spare...from reading problably the "o" ring that failed.
I have an Innova 3100 Scanner, which did not read the P2767 Transmission code. Appearantly the 3120 model would have.

Gab

Last edited by Nookie; 02-05-2013 at 08:47 AM..
Nookie is offline   Reply With Quote Quick reply to this message
Unread 11-19-2013, 09:11 AM   #4
greendiezel
Registered User
2008 WK 
 
Join Date: Jul 2012
Posts: 13
Yeah.. me too..

Hi

Yeah, I am in the exact same predicament. 2008 Jeep CRD kept going into limp mode with no immediate DTC's. brought it in and said it was code P2767 and that I needed to replace the conductor board inside the transmission (which houses the two speed sensors) for $800 + $300 or so for labour and a recommended fluid flush.

I opted to do the job myself and bought the replacement part from ebay for $265 + new fluid, filter and gaskets. Spent 4 hours in my shop and no problems in the replacement, but I'm still getting the same code and limp mode. Although its not the same code the dealership gave me. I keep getting the P0730 Incorrect Gear Ratio, which i'm assuming is a generic code and that my scanner isn't really good enough to pick up the specific P2767 speed sensor code.

Maybe my scan tool isn't good enough to really 'clear' the codes out of my computer either? This is my first time really using scan tools to help diagnose my problem. What a learning curve hah.
greendiezel is offline   Reply With Quote Quick reply to this message
Unread 05-03-2015, 06:33 PM   #5
06cumminspower
Registered User
 
Join Date: Apr 2015
Location: brown summit, nc
Posts: 9
I'm having same issue with my 08 crd with 115k and Trans doesn't seem to slip but occasionally has hard shifts and goes into a limp mode to where it hangs in 3rd? Gear or so and has single p0730 incorrect gear ratio. But I can cut care off and restart and will work properly for a while. What ended up being your fail isues? And if I need sensors is there a good link or write up on how to change them and part numbers to find them cheaper on ebay?
06cumminspower is offline   Reply With Quote Quick reply to this message
Unread 05-03-2015, 07:13 PM   #6
johnniebravo
Registered User
2008 WK 
 
Join Date: Sep 2002
Location: Bristow, VA
Posts: 860
Its probably the conductor plate on top of the valve body I'm the transmission. I replaced mine at approx 105k miles.

Part is cheap! Watch this YouTube video before dropping a fortune at a dealer.

http://www.youtube.com/watch?v=pl55H5sxmUc
__________________
2008 CRD GC
johnniebravo is offline   Reply With Quote Quick reply to this message
Unread 05-08-2015, 08:15 PM   #7
06cumminspower
Registered User
 
Join Date: Apr 2015
Location: brown summit, nc
Posts: 9
My local trans guy made a stupid simple good point, check trans fluid and level first. So where can I buy a dipstick for this thing? He had one for a Mercedes but it was different.
06cumminspower is offline   Reply With Quote Quick reply to this message
Unread 05-09-2015, 04:12 PM   #8
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake, OH
Posts: 676
ebay has the ones where you have to test the trans temp and use it to measure the level.
__________________
Tom
tchristopher1@wowway.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline   Reply With Quote Quick reply to this message
Unread 05-10-2015, 05:35 AM   #9
johnniebravo
Registered User
2008 WK 
 
Join Date: Sep 2002
Location: Bristow, VA
Posts: 860
Doorman 917-327 from amazon.
__________________
2008 CRD GC
johnniebravo is offline   Reply With Quote Quick reply to this message
Unread 05-11-2015, 10:35 AM   #10
06cumminspower
Registered User
 
Join Date: Apr 2015
Location: brown summit, nc
Posts: 9
Found a dipstick and on the way but for an update Saturday night the jeep went into limp mode again but this time did not clear out with restart so I limped it to where I was going (5mi) and when I got there I smelt trans fluid and sure enough it leaked some out but had it towed home and I'll keep you guys updated
06cumminspower is offline   Reply With Quote Quick reply to this message
Unread 05-15-2015, 08:17 PM   #11
06cumminspower
Registered User
 
Join Date: Apr 2015
Location: brown summit, nc
Posts: 9
Pulled pan and fluid looked ok with no materials in it so I guess we'll change the plate and see what happens, rock auto has doorman for 121$ and dealer wants $515! Also, there is two different ones listed from doorman so I called dealer with vin and got part number to cross it.
06cumminspower is offline   Reply With Quote Quick reply to this message
Unread 06-22-2015, 03:19 PM   #12
06cumminspower
Registered User
 
Join Date: Apr 2015
Location: brown summit, nc
Posts: 9
Changed plate and still not working but then had a relearn and went back to normal so a Dorman products conductor plate and a relearn got me all fixed up.
06cumminspower is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.