P0340 camshaft position sensor - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > P0340 camshaft position sensor

Premium LED Lighting by VISION X, Proudly sold at ROCKRIDGFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD

Reply
Unread 09-18-2013, 04:14 PM   #1
polpilot
Registered User
2005 WK 
 
Join Date: Jul 2011
Location: Ramstein, Germany
Posts: 185
P0340 camshaft position sensor

So about a year ago I replaced the camshaft and crankshaft position sensors to help with a stalling problem. Now I'm throwing a P0340 code (camshaft position sensor circuit bank 1 sensor 1). And she will die or just won't start randomly, some times she will fire right back up, sometimes I'll let in sit an hour and she's fine. Time for another sensor, or a bigger issue?

__________________
Anyone in Germany here is my Off Road page.[URL="http://www.facebook.com/groups/361858243837337/"]http://www.facebook.com/groups/361858243837337/[/URL]
polpilot is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.