P0300 and P0339; Crankshaft position sensor? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > P0300 and P0339; Crankshaft position sensor?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineHalloween Savings to die for!We have Engo 10k Synthetic IN STOCK!!! Hurry while supplie

Reply
Unread 04-20-2011, 03:29 PM   #1
I8AHUMR
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Location: Dayton, OH
Posts: 528
P0300 and P0339; Crankshaft position sensor?

Got some misfiring and DTC throws P0300 and P0339. Anyone have this problem in the past? I'm assuming a new CPS is in order since P0339 is something about an intermittent CPS? Anyone know where this is located? Thanks in advance.

I installed a Billet catch can about 2 weeks ago and a new EGR valve about 3 weeks ago. I seriously doubt it's related but any thoughts on any connection?

__________________
93 YJ, 4.0, 4.5" suspension, 33x13.5 Pitbull Rockers, Custom scratch and dent job...

05 WK, 5.7 Hemi, Quadra-Drive II
I8AHUMR is offline   Reply With Quote Quick reply to this message
Unread 04-20-2011, 03:44 PM   #2
I8AHUMR
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Location: Dayton, OH
Posts: 528
Ok, found the cps in the service manual. It's on page 8i-19. Is that (right next to)/underneath the alternator? Looks simple from what I can tell. One connector and one bolt it looks like? 9 ft/lbs on the Hemi from what I can tell.
__________________
93 YJ, 4.0, 4.5" suspension, 33x13.5 Pitbull Rockers, Custom scratch and dent job...

05 WK, 5.7 Hemi, Quadra-Drive II
I8AHUMR is offline   Reply With Quote Quick reply to this message
Unread 04-20-2011, 04:26 PM   #3
WK-916
Registered User
 
Join Date: Jan 2011
Location: Sacramento, California
Posts: 531
I had this Problem!

The CKP ensor is about $45 from the Dealer

Located on the botton of the block, on pass side, infront of the Starter; held on by 1 10mm bolt and obviously an electrical connector. Took me about 10 mins to fix, hardest part is getting under vehicle....

Hope this helps...

The one under the Alternator is the 4.7L
WK-916 is offline   Reply With Quote Quick reply to this message
Unread 04-20-2011, 04:27 PM   #4
WK-916
Registered User
 
Join Date: Jan 2011
Location: Sacramento, California
Posts: 531
Correction: "CKP ensor" = Sensor
WK-916 is offline   Reply With Quote Quick reply to this message
Unread 04-20-2011, 05:08 PM   #5
I8AHUMR
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Location: Dayton, OH
Posts: 528
Gotcha... Good to know someone had the same issue and that's it's an easy fix like I thought. Thanks for the information. It wouldn't surprise me if the pictures are swapped in the SM??? I'll crawl under there and find it.
__________________
93 YJ, 4.0, 4.5" suspension, 33x13.5 Pitbull Rockers, Custom scratch and dent job...

05 WK, 5.7 Hemi, Quadra-Drive II
I8AHUMR is offline   Reply With Quote Quick reply to this message
Unread 04-20-2011, 05:23 PM   #6
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland, MI
Posts: 1,527
Quote:
Originally Posted by I8AHUMR View Post
Gotcha... Good to know someone had the same issue and that's it's an easy fix like I thought. Thanks for the information. It wouldn't surprise me if the pictures are swapped in the SM??? I'll crawl under there and find it.
Crankshaft position sensor is RHS rear, by flywheel. Camshaft position sensor is RHS front, by alternator.

Look in Section 14 of the FSM.
__________________
HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline   Reply With Quote Quick reply to this message
Unread 04-20-2011, 10:56 PM   #7
mailforjon
Registered User
2005 WK 
 
Join Date: Oct 2005
Location: Boston, MA
Posts: 998
had same code p0339 on my hemi. took 10 min max to replace the sensor. very easy job.
__________________

-2005 WK 5.7 Limited [DD]
-1999 WJ 4.7 Limited [SOLD]
-1998 ZJ 5.9 Limited [SOLD]
-1996 ZJ 5.2 Laredo [SOLD]
-1994 ZJ 4.0 Laredo [SOLD]
-1993 XJ 2.5 [SOLD]
mailforjon is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.