o2 sensor on a CRD - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 16 Old 04-25-2012, 04:59 PM Thread Starter
K5_Guy
Registered User
2008 WK 
 
Join Date: Apr 2012
Location: Austin
Posts: 3
o2 sensor on a CRD

I have a 2008 WK CRD and I am throwing 3 codes:

P2243 o2 sensor reference voltage circuit open bank 1 sensor 1,
P0131 o2 sensor circuit low voltage bank 1 sensor 1,
P0135 o2 sensor heater circuit bank 1 sensor 1

Questions are:

A) didn't know diesels had o2 sensors
B) Replaced plenty of o2 sensors before but cant seem to find this one
c) what is the correct part number as I am getting mixed results on parts searches.

Thanks in advance!
Dave

K5_Guy is offline  
Sponsored Links
Advertisement
 
post #2 of 16 Old 04-25-2012, 06:09 PM
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,929
Yup definitely a sensor there

My dashhawk shows the afr, the parts catalog i have does not show a part for the o2 sensor though. You should be able to find the sensor behind the cat perhaps the wires are damaged.

2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline  
post #3 of 16 Old 04-26-2012, 12:53 AM
fatfreddy
Registered User
2008 WK 
 
Join Date: Nov 2006
Location: canada
Posts: 452
Quote:
Originally Posted by K5_Guy View Post
I have a 2008 WK CRD and I am throwing 3 codes:

P2243 o2 sensor reference voltage circuit open bank 1 sensor 1,
P0131 o2 sensor circuit low voltage bank 1 sensor 1,
P0135 o2 sensor heater circuit bank 1 sensor 1

Questions are:

A) didn't know diesels had o2 sensors
B) Replaced plenty of o2 sensors before but cant seem to find this one
c) what is the correct part number as I am getting mixed results on parts searches.

Thanks in advance!
Dave
The O2 sensor is on the top side of the CAT.You can see it if you look down at the rear of the engine bay passenger side.It is kinda hiding behind the 2 steel lines the come up from the DPF.
Attached Thumbnails
20mm Jeep stuff 017.jpg  
fatfreddy is offline  
 
post #4 of 16 Old 04-26-2012, 05:34 PM
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,929
Good photo, that would be it.
I would've expected 2 O2 sensors, 1 before the CAT and 1 after the CAT.

2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline  
post #5 of 16 Old 04-26-2012, 09:11 PM
tnadanzig
Senior Member
 
tnadanzig's Avatar
2007 WK 
 
Join Date: Oct 2011
Location: Iowa City
Posts: 601
You are correct. See picture of exhaust components.

CB Engineering
CB-engineer.com
2014 WK2 EcoDiesel - CBE Parts
2008 3.0L CRD WK LTD - GDE Tune 3.07 gears
2007 3.0L CRD WK LTD - Go Fast Parts

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2005 KJ CRD - GDE Tune
tnadanzig is offline  
post #6 of 16 Old 04-26-2012, 11:40 PM
fatfreddy
Registered User
2008 WK 
 
Join Date: Nov 2006
Location: canada
Posts: 452
Quote:
Originally Posted by suzieque View Post
Good photo, that would be it.
I would've expected 2 O2 sensors, 1 before the CAT and 1 after the CAT.
There isn't a down-stream O2 on my 2008.There is only 1 on mine on the top side of the cat.
fatfreddy is offline  
post #7 of 16 Old 04-27-2012, 10:33 AM Thread Starter
K5_Guy
Registered User
2008 WK 
 
Join Date: Apr 2012
Location: Austin
Posts: 3
Thanks for the info! That looks fun to get too!
K5_Guy is offline  
post #8 of 16 Old 04-27-2012, 06:35 PM
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,929
now I'm curious, I need to have a closer look at my 2008 setup.

2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline  
post #9 of 16 Old 05-13-2013, 11:55 AM
denniscdunbar
Registered User
2008 WK 
 
Join Date: May 2013
Location: Surrey
Posts: 52
Did you fix this??

I have the exact same issue for my 2008 3.0L Grand Cherokee. What did you do to resolve this?
denniscdunbar is offline  
post #10 of 16 Old 05-13-2013, 01:49 PM Thread Starter
K5_Guy
Registered User
2008 WK 
 
Join Date: Apr 2012
Location: Austin
Posts: 3
I had the sensor replaced. I ordered the sensor from mopar and was going to replace it myself, but it looked like I couldn't do it without dropping part of the exhaust and I didn't have that sort of time as i needed an inspection so I just let my local off-road shop do it.

sorry i wasn't more helpful, but it is now throwing the same codes so looks like I get to do it again!

Yay!
K5_Guy is offline  
post #11 of 16 Old 12-09-2014, 11:00 PM
denniscdunbar
Registered User
2008 WK 
 
Join Date: May 2013
Location: Surrey
Posts: 52
Quote:
Originally Posted by fatfreddy View Post
The O2 sensor is on the top side of the CAT.You can see it if you look down at the rear of the engine bay passenger side.It is kinda hiding behind the 2 steel lines the come up from the DPF.

Was it difficult to remove the Oxygen sensor. I have the same error codes and would like to do it myself. Looks like I can get the sensor for $112.

http://www.factorychryslerparts.com/products/SENSOR-Oxygen--[Upstream]/4303711/05149012AA.html


Dennis
denniscdunbar is offline  
post #12 of 16 Old 12-10-2014, 09:56 AM
caddydaddy
Registered User
2007 WK 
 
Join Date: Dec 2013
Location: Connecticut
Posts: 1,449
Quote:
Originally Posted by denniscdunbar View Post
It's on RockAuto.com for $100.79 and thier shipping charges are most likely less as well.

2007 CRD Limited w/QDII
GDE HOT Tune, Turbo Resonator Delete
2" RC lift
200,000+ miles!
caddydaddy is offline  
post #13 of 16 Old 12-10-2014, 08:19 PM
ggrassmid
Registered User
2008 WK 
 
Join Date: Apr 2014
Location: Grand Rapids
Posts: 950
I was getting similar codes this summer. Unplugged, cleaned the connectors, and plugged back in. No codes since.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ggrassmid is offline  
post #14 of 16 Old 12-13-2014, 09:28 PM
Tango.
Registered User
2008  
 
Join Date: Oct 2011
Posts: 2,847
you may want to check your air filter first (for too little), and the air system for too much or too little air (leaks).

Life is hard-John Wayne
Tango. is offline  
post #15 of 16 Old 02-18-2015, 10:13 AM
brew1
Registered User
2008  
 
Join Date: Dec 2009
Location: Wisconsin
Posts: 46
Quote:
Originally Posted by ggrassmid View Post
I was getting similar codes this summer. Unplugged, cleaned the connectors, and plugged back in. No codes since.
I now have the O2 Sensor code(s). I'm curious about your procedure. Did you simply disconnect each O2 sensor (assuming 1 pre-cat and 1 post-cat per the diagram) hose down the electrical connectors with electronic contact cleaner spray, lube up each connector with dielectric grease, reconnect and clear codes? Did the codes stay cleared for more than a week?

Does anyone know if the pre and post cat O2 sensors are identical?

Another question a bit off-topic but I'm curious if the cat was replaced by a bypass pipe, is there still a need for the O2 sensors. I previously contacted GDE and they acknowledged they could adjust my programming if I eliminated the cat.

Thanks,

Mark

08 GC CRD, GDE, CBE
04 Audi A4 Avant 3.0, JHM, Revmax TC
15 Audi A3
16 Audi A3 S-Line
brew1 is offline  
Reply

Tags
crd , o2 , oxygen , sensor

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
high voltage o2 sensor/bad coolant sensor Jh24k WK Grand Cherokee & XK Commander Forum 1 07-19-2013 11:22 AM
hogh voltage 02 sensor/bad cool sensor Jh24k ZJ Grand Cherokee Forum 0 01-24-2010 11:33 AM
Sensor Reads Throttle/Pedal Position Sensor/Switch A Circuit Low Input Vincent2for2 ZJ Grand Cherokee Forum 3 11-01-2009 01:01 AM
Bank 1 Sensor 2 '01 Grd Cher o2 sensor location mgrean ZJ Grand Cherokee Forum 15 02-06-2009 01:41 PM
Crankshaft position sensor & coolant temperature sensor getting replaced in my 95 GC Keith1975 ZJ Grand Cherokee Forum 3 12-14-2006 04:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome