o2 sensor on a CRD - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > o2 sensor on a CRD

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 04-25-2012, 03:59 PM   #1
K5_Guy
Registered User
2008 WK 
 
Join Date: Apr 2012
Location: Austin, TX
Posts: 3
o2 sensor on a CRD

I have a 2008 WK CRD and I am throwing 3 codes:

P2243 o2 sensor reference voltage circuit open bank 1 sensor 1,
P0131 o2 sensor circuit low voltage bank 1 sensor 1,
P0135 o2 sensor heater circuit bank 1 sensor 1

Questions are:

A) didn't know diesels had o2 sensors
B) Replaced plenty of o2 sensors before but cant seem to find this one
c) what is the correct part number as I am getting mixed results on parts searches.

Thanks in advance!
Dave

K5_Guy is offline   Reply With Quote Quick reply to this message
Unread 04-25-2012, 05:09 PM   #2
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,809
Yup definitely a sensor there

My dashhawk shows the afr, the parts catalog i have does not show a part for the o2 sensor though. You should be able to find the sensor behind the cat perhaps the wires are damaged.
__________________
2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline   Reply With Quote Quick reply to this message
Unread 04-25-2012, 11:53 PM   #3
fatfreddy
Registered User
2008 WK 
 
Join Date: Nov 2006
Location: canada
Posts: 420
Quote:
Originally Posted by K5_Guy View Post
I have a 2008 WK CRD and I am throwing 3 codes:

P2243 o2 sensor reference voltage circuit open bank 1 sensor 1,
P0131 o2 sensor circuit low voltage bank 1 sensor 1,
P0135 o2 sensor heater circuit bank 1 sensor 1

Questions are:

A) didn't know diesels had o2 sensors
B) Replaced plenty of o2 sensors before but cant seem to find this one
c) what is the correct part number as I am getting mixed results on parts searches.

Thanks in advance!
Dave
The O2 sensor is on the top side of the CAT.You can see it if you look down at the rear of the engine bay passenger side.It is kinda hiding behind the 2 steel lines the come up from the DPF.
20mm-jeep-stuff-017.jpg  
fatfreddy is offline   Reply With Quote Quick reply to this message
Unread 04-26-2012, 04:34 PM   #4
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,809
Good photo, that would be it.
I would've expected 2 O2 sensors, 1 before the CAT and 1 after the CAT.
__________________
2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline   Reply With Quote Quick reply to this message
Unread 04-26-2012, 08:11 PM   #5
tnadanzig
Senior Member
 
tnadanzig's Avatar
2007 WK 
 
Join Date: Oct 2011
Location: Iowa City, Iowa
Posts: 594
You are correct. See picture of exhaust components.
__________________
CB Engineering
CB-engineer.com
2008 3.0L CRD WK LTD - Wifes, GDE DPF Delete Tune, Turbo Resonator Delete, 3" Intercooler, Addcoo Rear Sway Bar, 3.07 gears
2007 3.0L CRD WK LTD - Stage 2 Custom Spooling Tune, Go Fast Parts
Pro-lite Build
2003 F250 6.0L CCLB - Gearhead Tunes
tnadanzig is offline   Reply With Quote Quick reply to this message
Unread 04-26-2012, 10:40 PM   #6
fatfreddy
Registered User
2008 WK 
 
Join Date: Nov 2006
Location: canada
Posts: 420
Quote:
Originally Posted by suzieque View Post
Good photo, that would be it.
I would've expected 2 O2 sensors, 1 before the CAT and 1 after the CAT.
There isn't a down-stream O2 on my 2008.There is only 1 on mine on the top side of the cat.
fatfreddy is offline   Reply With Quote Quick reply to this message
Unread 04-27-2012, 09:33 AM   #7
K5_Guy
Registered User
2008 WK 
 
Join Date: Apr 2012
Location: Austin, TX
Posts: 3
Thanks for the info! That looks fun to get too!
K5_Guy is offline   Reply With Quote Quick reply to this message
Unread 04-27-2012, 05:35 PM   #8
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,809
now I'm curious, I need to have a closer look at my 2008 setup.
__________________
2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline   Reply With Quote Quick reply to this message
Unread 05-13-2013, 10:55 AM   #9
denniscdunbar
Registered User
 
Join Date: May 2013
Location: Surrey, BC
Posts: 1
Did you fix this??

I have the exact same issue for my 2008 3.0L Grand Cherokee. What did you do to resolve this?
denniscdunbar is offline   Reply With Quote Quick reply to this message
Unread 05-13-2013, 12:49 PM   #10
K5_Guy
Registered User
2008 WK 
 
Join Date: Apr 2012
Location: Austin, TX
Posts: 3
I had the sensor replaced. I ordered the sensor from mopar and was going to replace it myself, but it looked like I couldn't do it without dropping part of the exhaust and I didn't have that sort of time as i needed an inspection so I just let my local off-road shop do it.

sorry i wasn't more helpful, but it is now throwing the same codes so looks like I get to do it again!

Yay!
K5_Guy is offline   Reply With Quote Quick reply to this message
Reply

Tags
crd , o2 , oxygen , sensor

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.