New to the site , what upp?! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > New to the site , what upp?!

SPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!ROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail ANOTHER Rockridge4wd Creation!! Spare Tire Carrier Delete

Reply
Unread 01-23-2013, 10:10 AM   #1
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 27
New to the site , what upp?!

I got a 05 grand cherokee 5.7 limited n i got issues

cold start....
Reverse the rpm hops a lil when put in gear then almost stalls
drive same thing but will satll sometimes
drive up to a stop light n stop she stalls
stops after some driving n warms up

kinda sounds like shes hiccpuing/slight jerking when cruzing say at 50 and low rpm ....let her down **** then power theru the low rpms shes fine

someone told me it could be my throttle body or etc?
Hoping not the tranny or transfer case
anything will help
thanx

SILV05HEMI is offline   Reply With Quote
Unread 01-23-2013, 10:13 AM   #2
cheftrail
Registered User
2005 TJ Wrangler 
 
Join Date: Oct 2010
Location: kodak, tennessee
Posts: 317
Welcome! try the Position sensor on the bell housing.
__________________
[SIZE="4"][I]Last words are for fools who haven't said enough![/I][/SIZE]
cheftrail is offline   Reply With Quote
Unread 01-23-2013, 12:38 PM   #3
bigphil76
Registered User
2005 WK 
 
Join Date: Jan 2010
Location: Asheville NC
Posts: 111
I have a 05 wk hemi also.. and mine kinda studders at low rpm pulling a slight hill and sometimes flat land.. but when you give it more then a inch of throttle she purrs just fine.. I did some research and some people said EGR valve.. I got one just haven't replaced it yet. because I don't have anything to cut the wedged bolt off. and I also read that 87 octane can cause that to..
bigphil76 is offline   Reply With Quote
Unread 01-23-2013, 07:50 PM   #4
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 27
Thanx

my gc dose the same thing also stalls at stops when first started

thanx for the info ...when i get money n time ill try it all out

any more info will be greatly apprecitaed

also info about ome hd lift, rola rack , 4xgaurd bush guard , tail light gaurds , rubican wheel n tire and where the best palce to buy

and trails in va i wanna get her dirty lol
SILV05HEMI is offline   Reply With Quote
Unread 01-23-2013, 10:17 PM   #5
trax95008
Web Wheeler
2006 XK Commander 
 
Join Date: Dec 2005
Location: , California
Posts: 1,200
The gas is a good point. Are you using 87, or 89 like the owners manual says to use?
trax95008 is offline   Reply With Quote
Unread 01-23-2013, 11:31 PM   #6
ca07wk
Crawl-Offroad.com
2007 WK 
 
Join Date: Aug 2012
Location: San Diego, CA
Posts: 943
Quote:
Originally Posted by SILV05HEMI View Post

also info about ome hd lift, rola rack , 4xgaurd bush guard , tail light gaurds , rubican wheel n tire and where the best palce to buy
Look up member Kolak, not sure if he carries all of those but he has the best price on the OME.
__________________
Crawl-Offroad.com-Boycott Paved Roads
2006 WK Limited Modified QT2
OME HD/HM UCA/Toyo AT2 on Moabs/JKS Rear Discos/Steel Armadillo Skids, Sliders,Front Shackles,Antenna Mount/Crawl Rear Skid
ca07wk is offline   Reply With Quote
Unread 01-24-2013, 11:43 AM   #7
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 27
Im using the highest grade gas from local gas station 89 or 93 octane or watever it is
SILV05HEMI is offline   Reply With Quote
Unread 01-24-2013, 11:44 AM   #8
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 27
Good looks , thank you
SILV05HEMI is offline   Reply With Quote
Unread 01-24-2013, 02:38 PM   #9
RagtagGuy
Registered User
2005 WK 
 
Join Date: May 2010
Location: Deep South, Alabama
Posts: 186
The Hemi doesnt take 93. Stick to 89 or 87
RagtagGuy is offline   Reply With Quote
Unread 01-24-2013, 04:09 PM   #10
Skrimps
Registered User
 
Join Date: Dec 2009
Location: VA
Posts: 16
welcome!
Skrimps is offline   Reply With Quote
Unread 01-25-2013, 10:29 AM   #11
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 27
Roger that , greatly appreciate it
SILV05HEMI is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.