New to the site , what upp?! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > New to the site , what upp?!

Savvy/Currie Aluminum Control ArmsRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 01-23-2013, 11:10 AM   #1
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 30
New to the site , what upp?!

I got a 05 grand cherokee 5.7 limited n i got issues

cold start....
Reverse the rpm hops a lil when put in gear then almost stalls
drive same thing but will satll sometimes
drive up to a stop light n stop she stalls
stops after some driving n warms up

kinda sounds like shes hiccpuing/slight jerking when cruzing say at 50 and low rpm ....let her down **** then power theru the low rpms shes fine

someone told me it could be my throttle body or etc?
Hoping not the tranny or transfer case
anything will help
thanx

SILV05HEMI is offline   Reply With Quote Quick reply to this message
Unread 01-23-2013, 11:13 AM   #2
cheftrail
Registered User
2005 TJ Wrangler 
 
Join Date: Oct 2010
Location: kodak, tennessee
Posts: 321
Welcome! try the Position sensor on the bell housing.
__________________
[SIZE="4"][I]Last words are for fools who haven't said enough![/I][/SIZE]
cheftrail is offline   Reply With Quote Quick reply to this message
Unread 01-23-2013, 01:38 PM   #3
bigphil76
Registered User
2005 WK 
 
Join Date: Jan 2010
Location: Asheville NC
Posts: 111
I have a 05 wk hemi also.. and mine kinda studders at low rpm pulling a slight hill and sometimes flat land.. but when you give it more then a inch of throttle she purrs just fine.. I did some research and some people said EGR valve.. I got one just haven't replaced it yet. because I don't have anything to cut the wedged bolt off. and I also read that 87 octane can cause that to..
bigphil76 is offline   Reply With Quote Quick reply to this message
Unread 01-23-2013, 08:50 PM   #4
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 30
Thanx

my gc dose the same thing also stalls at stops when first started

thanx for the info ...when i get money n time ill try it all out

any more info will be greatly apprecitaed

also info about ome hd lift, rola rack , 4xgaurd bush guard , tail light gaurds , rubican wheel n tire and where the best palce to buy

and trails in va i wanna get her dirty lol
SILV05HEMI is offline   Reply With Quote Quick reply to this message
Unread 01-23-2013, 11:17 PM   #5
trax95008
Registered User
2006 XK Commander 
 
Join Date: Dec 2005
Location: , California
Posts: 1,208
The gas is a good point. Are you using 87, or 89 like the owners manual says to use?
trax95008 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2013, 12:31 AM   #6
ca07wk
Crawl-Offroad.com
2007 WK 
 
Join Date: Aug 2012
Location: San Diego, CA
Posts: 1,053
Quote:
Originally Posted by SILV05HEMI View Post

also info about ome hd lift, rola rack , 4xgaurd bush guard , tail light gaurds , rubican wheel n tire and where the best palce to buy
Look up member Kolak, not sure if he carries all of those but he has the best price on the OME.
__________________
Crawl-Offroad.com-Boycott Paved Roads
2006 WK Limited Modified QT2
OME HD/RRO UCA/Wrangler MTRs on Moabs/JKS Rear Discos/Steel Armadillo Skids, Sliders,Front Shackles,Antenna Mount/Crawl Rear Skid
ca07wk is offline   Reply With Quote Quick reply to this message
Unread 01-24-2013, 12:43 PM   #7
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 30
Im using the highest grade gas from local gas station 89 or 93 octane or watever it is
SILV05HEMI is offline   Reply With Quote Quick reply to this message
Unread 01-24-2013, 12:44 PM   #8
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 30
Good looks , thank you
SILV05HEMI is offline   Reply With Quote Quick reply to this message
Unread 01-24-2013, 03:38 PM   #9
RagtagGuy
Registered User
2005 WK 
 
Join Date: May 2010
Location: Deep South, Alabama
Posts: 186
The Hemi doesnt take 93. Stick to 89 or 87
RagtagGuy is offline   Reply With Quote Quick reply to this message
Unread 01-24-2013, 05:09 PM   #10
Skrimps
Registered User
 
Join Date: Dec 2009
Location: VA
Posts: 16
welcome!
Skrimps is offline   Reply With Quote Quick reply to this message
Unread 01-25-2013, 11:29 AM   #11
SILV05HEMI
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: SPRINGFIELD, VA
Posts: 30
Roger that , greatly appreciate it
SILV05HEMI is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.