New to forum and jeep. Need help please! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > New to forum and jeep. Need help please!

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 01-03-2014, 10:09 AM   #1
Mgk1987
Registered User
2005  
 
Join Date: Jan 2014
Location: Cherry, Illinois
Posts: 1
New to forum and jeep. Need help please!

2005 grand cherokee leredo
Heat only blows through defrost and floor. I have checked everywhere for a vacuum leak with no luck. Even sprayed starting fluid on just about every vacuum line I knew of with no changes to motor while running.
Fan speed only works on high a lot of the time. As I turn fan from off to high,the door behind the glove box opens and closes like I'm guessing it should.
As I turn the temperature control, I can see a shaft rotating (operating the temp control door or something) behind the climate control unit in the dash. I could also hear what sounds like an electic actuator moving as I changed the vent selector behind the climate control in the dash, but nothing moves that I can see. Also, the backlight for the climate control unit is not working. Whä is goin on??
I am stumped. Any help would be appreciated.

Mgk1987 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.