Need Help: 5.9 Limited Starting Issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Need Help: 5.9 Limited Starting Issue

Want to be able to SEE? DOT Approved Headlights for under We have FLASHLIGHTS! Great for your Emergency bag!Flowmaster Overstock: Special Holiday Pricing!!!!

Reply
Unread 04-14-2010, 07:00 PM   #1
bradtabor
Registered User
1988 YJ Wrangler 
 
Join Date: Apr 2010
Location: boise idaho
Posts: 12
Need Help: 5.9 Limited Starting Issue

My Jeep was driving fine and just died on me. Then when ever it would warm up it would die again.. I noticed I had no fuel pressure with I checked it at the rail.

I originally figured Crank Sensor, until it wouldn't even start when it was cold. Then I figured Fuel Pump.

So I replaced the fuel pump. Still no fuel pressure and it doesn't even kick on.. However the Relay is still good in the fuse box and even tried a known working one..

Also there is power going to the hot leads of the relay connection in the fuse box when the relay is removed and has the full 12 volts plus just like it should.

I also cleared the computer as well..

Can a bad Crank Positioning Sensor cause a fuel pump not to turn on???
Any Ideas??

bradtabor is offline   Reply With Quote Quick reply to this message
Unread 04-14-2010, 08:13 PM   #2
bobs68bird
Registered User
1979 CJ7 
 
Join Date: Sep 2009
Location: Warner Robins
Posts: 39
A few years ago I fuel issue with a chevy had power ,good pump ,and relay mine turned out to be a oil pressure switch wire shorted. try looking in a wire diagram. Also if your pump is in the tank check the tank harness. I had a bad plug on my pump on my truck. Just some ideas. Good luck.
bobs68bird is offline   Reply With Quote Quick reply to this message
Unread 04-14-2010, 10:48 PM   #3
Texas WJ
Web Wheeler
 
Texas WJ's Avatar
2005 WK 
 
Join Date: Mar 2006
Location: San Antonio
Posts: 2,055
Try the ZJ/WJ section, you're currently in the WK ('05- ) forum.
__________________
255/75-17 BF Goodrich Mud Terrain TA KMs, 2" lift, JK Wrangler Moab wheels, Spidertrax Spacers, Rola Roof Rack.
Texas WJ is offline   Reply With Quote Quick reply to this message
Reply

Tags
cps , crank positioning sensor , fuel pump , starting

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.