Nav system needs to be replaced - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 02-21-2008, 05:23 PM Thread Starter
Crazypilotgal
Registered User
2008 XK Commander 
 
Join Date: Aug 2006
Location: Central IN
Posts: 50
Nav system needs to be replaced

I took my 08 Commander to the dealer today b/c the Nav system quit working 3 weeks ago. They finally got the cd in from the manufacturer and tried installing it today. Nothing so they're ording a new radio component.

Crazypilotgal is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-21-2008, 09:28 PM
verdugan
Registered User
2012 JK Wrangler 
 
Join Date: Aug 2007
Location: Sacramento, CA
Posts: 188
Quote:
Originally Posted by Crazypilotgal View Post
I took my 08 Commander to the dealer today b/c the Nav system quit working 3 weeks ago. They finally got the cd in from the manufacturer and tried installing it today. Nothing so they're ording a new radio component.
Mine needed to be replaced as well. The radio arrived a few days ago, but the CD finally arrived today. I'm getting the new radio put in tomorrow.

I'm curious, what were the symptoms you experienced? Mine were:

- Navigation stuck on "Navigation is being activated"
- Couldn't access any songs on the hard drive
- Siruis Traffic not working
- Voice Reconigtion not working (Uconnect was working fine)

Last edited by verdugan; 02-21-2008 at 10:34 PM.
verdugan is offline  
post #3 of 6 Old 02-22-2008, 09:11 AM Thread Starter
Crazypilotgal
Registered User
2008 XK Commander 
 
Join Date: Aug 2006
Location: Central IN
Posts: 50
These were the same symptoms I had. My Nav. only worked for 2 weeks after I bought this Commander then died.
Crazypilotgal is offline  
post #4 of 6 Old 02-22-2008, 11:48 AM
verdugan
Registered User
2012 JK Wrangler 
 
Join Date: Aug 2007
Location: Sacramento, CA
Posts: 188
Quote:
Originally Posted by Crazypilotgal View Post
These were the same symptoms I had. My Nav. only worked for 2 weeks after I bought this Commander then died.
I guess it's kind of comforting to know I'm not the only out there with the problem. My WK was built on 9/2007, and it worked fine until mid Jan.

When was yours built? Hope your dealership receives your radio soon.
verdugan is offline  
post #5 of 6 Old 02-22-2008, 03:32 PM Thread Starter
Crazypilotgal
Registered User
2008 XK Commander 
 
Join Date: Aug 2006
Location: Central IN
Posts: 50
August 07. Guess it was a VERY new 08! What a pain. I got rid of my Kia Sedona van and got my 06 Commander because my van ended up being a lemon. Now I bought this 08 when my 06 lease ended and it's a PITB too. In addition to this I have to have 3 doors realligned, and one stationary window on the rear passenger's side replaced because the weather stripping is on wrong. Urg!
Crazypilotgal is offline  
post #6 of 6 Old 02-22-2008, 08:06 PM
verdugan
Registered User
2012 JK Wrangler 
 
Join Date: Aug 2007
Location: Sacramento, CA
Posts: 188
Quote:
Originally Posted by Crazypilotgal View Post
August 07. Guess it was a VERY new 08! What a pain. I got rid of my Kia Sedona van and got my 06 Commander because my van ended up being a lemon. Now I bought this 08 when my 06 lease ended and it's a PITB too. In addition to this I have to have 3 doors realligned, and one stationary window on the rear passenger's side replaced because the weather stripping is on wrong. Urg!
OUCH. I've had more luck. Knock on wood. I picked up my Jeep today. Everything is working just fine. Hopefully it'll stay that way.

Best of luck.
verdugan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
cooling system problems , water pump and thermostat replaced . no heat. natesxj ZJ Grand Cherokee Forum 4 10-25-2009 09:49 AM
this need replaced? TheAngus ZJ Grand Cherokee Forum 11 07-25-2006 11:46 AM
Replaced my VC! EGrier ZJ Grand Cherokee Forum 6 11-02-2005 11:05 AM
Do I need my TC replaced? Scribesoft ZJ Grand Cherokee Forum 8 10-05-2005 06:27 PM
How do I get Vehicle Entertainment System turned on in my Nav system? JeepSam ZJ Grand Cherokee Forum 10 06-03-2005 03:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome