my jeep is im afraid at its end - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 08-20-2013, 10:07 AM Thread Starter
southernbell
Registered User
 
Join Date: Aug 2013
Location: seabrook
Posts: 4
my jeep is im afraid at its end

My idiot ex put 6 quartz too many of oil in my jeep cherokee 2005. Ive been having problems ever since. First thing was as soon as we left after he did this it started over heating and blowing white smoke. Replaced the temp sensor and it fixed the problem. Then my passanger floor board started getiing puddles in it. Cracked heater core. Hadnt fixed it yet and continued to drive it very short distances and drove it maybe a mile and it started spuddering like crazy. Pulled over and it was just acting nuts and when I got home I started messing with it and you turn it on and it just rough idles my rpms bounce from a little below one to between one and two. Check engine light came on took it to auto zone to get the code read and it said missfire in cylinder two. Changed all sparkplugs which were burnt. Changed my coil pack to cylinder two and also changed my pcv valve and now when it runs the lights in my car flicker. Wth is going on.

southernbell is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 08-20-2013, 11:19 AM
BAH101
Registered User
2008 WK 
 
Join Date: Jan 2009
Location: Thunder Bay
Posts: 872
Did you remove the extra oil?

2008 CRD QDII, OME HD, Pintlers wheels with 265/70/17 Goodyear Silent Armour's, Jeepinbyal UCA's. 4XGuard Front guard, Side Guard, belly guard, Matrix HC. GDE ECO Tune w/ delete.
BAH101 is offline  
post #3 of 9 Old 08-20-2013, 11:38 AM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,689
probably should drain and refill the oil- otherwise all that oil will blow a gasket at some point

2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
post #4 of 9 Old 08-22-2013, 04:25 PM Thread Starter
southernbell
Registered User
 
Join Date: Aug 2013
Location: seabrook
Posts: 4
Did a full oil change and everything was fine other than the heater core
southernbell is offline  
post #5 of 9 Old 08-23-2013, 06:09 AM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,689
Quote:
Originally Posted by southernbell View Post
Did a full oil change and everything was fine other than the heater core
glad to hear it, make sure your next bf is a true jeep guy

2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
post #6 of 9 Old 08-23-2013, 11:16 AM
rsurran
Web Wheeler
2003 TJ Wrangler 
 
Join Date: Jun 2011
Location: Eastern Shore
Posts: 1,106
One quart over is one thing, but six? Its a wonder it didn't overflow out the fill tube.

2005 WK, 5.7L, Gold, Leather
2003 TJ 4.0L Freedom Edition, Flame Red, 5 spd., CAI, Warn, stinger, Hella/KC trail lights.

Dick Surran

"When you stop contributing you are just taking up space."
rsurran is online now  
post #7 of 9 Old 08-23-2013, 11:43 AM
90grandoneer
Registered User
2006 WK 
 
Join Date: Apr 2008
Location: City of Trees
Posts: 2,676
I can't see where the engine being overfilled would have anything to do with a cracked heater core. Probably just a coincidence, or did he do something with the cooling system since you've had two problems now?? What engine are we talking about here?

06 GCO, Dk Khaki, QDII, Flshing Hi 3rd Bk Lt, MDS "ON" Lt, Airtab Vortex Gens, Debadged, Fumoto Drain Valve, BT Catch Can, Chopped EGR Tube, SRT8 CAI, K&N Filter, Sonnax Trans Line Press Booster, SC Tuner W/Adv Trans Tune App, DS Tuner, Cust tubular hdrs w/3 in Magnaflow/Xlerator AP Exh Sys, Bilsteins, SRT Springs/Sways, Cust Eng Cvr, SRT8 frt/rear bumpers, FRI Sidewinder Cam/6.1 valvetrain, SLP 25% UD Pulley, BBK true 90mm T-Body, SOS Ign Coils w/.060 spark plug gaps, SRT Reps with 265/45&295/40X20's.
90grandoneer is offline  
post #8 of 9 Old 08-25-2013, 09:52 AM Thread Starter
southernbell
Registered User
 
Join Date: Aug 2013
Location: seabrook
Posts: 4
He checked my oil on a incline like the idiot he was. After the oil change and temp sensor change it was fine until it over heated and I turned it off. Tur ed it on and that's wheb I got the rough idle problem. I'm just at a loss for it at this point.
southernbell is offline  
post #9 of 9 Old 08-25-2013, 10:13 AM
Jeepforthewin
Registered User
2010 JK Wrangler 
 
Join Date: Jan 2013
Location: Jacksonville
Posts: 2,134
Quote:
Originally Posted by southernbell
He checked my oil on a incline like the idiot he was. After the oil change and temp sensor change it was fine until it over heated and I turned it off. Tur ed it on and that's wheb I got the rough idle problem. I'm just at a loss for it at this point.
If it overheated it may have blown a head gasket. A rough idle would make sense then. Any white smoke coming out the exhaust? I would take it to a shop and have them perform a block test. It'll test to see if you have a blown head gasket.

2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome