Loud Vibrating Noise from passenger side under hood - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 06-17-2013, 12:23 PM Thread Starter
StephanieLee
Registered User
 
Join Date: May 2013
Location: Houston
Posts: 2
Loud Vibrating Noise from passenger side under hood

I just spent a LOT of money to replace my evaporator/heater core. Right after I picked it up from mechanic, it began making a horrible loud vibrational kind of noise. The a/c cools great when idling and there's no noise, but when driven for over 15 minutes at 65 MPH, the cold air stops blowing. I've been to two different mechanics and they can't figure out what's causing the noise (as it's quiet while idling) NOR the reason it quits blowing cold air when driven over 65 MPH. Can someone please help?! Could it be the fan? The compressor clutch? Or both?

StephanieLee is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-17-2013, 03:28 PM
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 952
Sounds like the compressor.. Did they fill it with air compressor oil?.. If it didnt make the noise before, make them fix it..

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome