Loud clicking noise from dash - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 37 Old 01-11-2010, 05:07 PM Thread Starter
Waynoiam
Registered User
 
Join Date: Jan 2010
Location: Florida
Posts: 2
Loud clicking noise from dash

After starting my 2005 Cherokee there is a loud clicking sound that comes from the middle area of the dash. It last about 20-30 secs and then goes away. Any ideas???

Thanks
Wayne

Waynoiam is offline  
Sponsored Links
Advertisement
 
post #2 of 37 Old 01-12-2010, 12:26 PM
kiesha
Registered User
2006 WK 
 
Join Date: Jun 2008
Location: london
Posts: 302
did you try to switch your fan to 0 ??

WK 4.7 V8
kiesha is offline  
post #3 of 37 Old 01-12-2010, 03:13 PM Thread Starter
Waynoiam
Registered User
 
Join Date: Jan 2010
Location: Florida
Posts: 2
Yeah when I turn the fan switch to 0 it doesn't do it. As soon as I turn the fan on it makes an awful clicking sound then goes away after 20 secs give or take.
Waynoiam is offline  
post #4 of 37 Old 01-15-2010, 01:48 PM
YJZJWK13
Registered User
2005 WK 
 
Join Date: Jan 2010
Location: Charlotte
Posts: 4
I have had the same problem with mine for about a month now and have yet to dig in to it. Mine also is louder or quieter depending on the amount of temperature change on the cabin thermostat. If someone else knows exactly what it is please let me know, but I assume it is the flap change getting stuck between letting cool and warm air in. Just don't know exactly.
YJZJWK13 is offline  
post #5 of 37 Old 05-23-2010, 10:14 AM
fnckr
Registered User
 
Join Date: Jun 2007
Location: New Jersey
Posts: 29
Anyone have more info on this? I just bumped a post about an HVAC Box. Anyone know what components are behind the dash and an easy way to access them?
fnckr is offline  
post #6 of 37 Old 12-23-2010, 12:40 PM
NBS4555
Registered User
2005 WK 
 
Join Date: Jun 2004
Location: Wilmington, NC
Posts: 62
Anyone figure out what this issue is? Mine is starting to do it now everytime I start the Jeep - however if I turn off the fan or change the direction settings it will stop? Not sure what this issue is it's just started recently
NBS4555 is offline  
post #7 of 37 Old 01-11-2011, 12:10 PM
castortroy520
Registered User
2005 WK 
 
Join Date: Feb 2010
Location: Tampa
Posts: 3
I'm in the same boat with my 05 grand cherokee. The noise happens almost every time I start and lasts for 20-30 secs. I thought it had to do with the AC, but when I'm not using the fan or AC at all I still get the noise. Still no answers from anyone who's had the same problem?
castortroy520 is offline  
post #8 of 37 Old 01-11-2011, 01:44 PM
criket
Registered User
2005 WK 
 
Join Date: Jun 2010
Location: NC
Posts: 1,156
I have this same issue on my 05 but it's not too loud....yet. I just figure its the turbo kicking in, lol jk.

2005 | WK | Khaki | 3.7 | QT1 | OME HD Front Struts | Rusty's 2" lift in Rear w/ Monroe load levelers (F150 version) | 265/70 Nitto Terra Grapplers | 17" Moabs | 1.5" wheel spacers | Pinch weld mod Rear fender trim mod | 4xG Matrix w/ reciever hitch | 4xG Belly guard | SOLID Diff cover | Cobra CB radio | 4xG antenna mount | Rola roof
criket is offline  
post #9 of 37 Old 10-29-2011, 11:27 AM
agam
Registered User
2005 FSJ Cherokee 
 
Join Date: Oct 2011
Location: Rio Rancho
Posts: 2
I have a 2005 Jeep Grand Cherokee with the same problem. This just started after some 123,000 miles. I checked under the hood and did not find the location of the clicking. I hear it from behind the radio and near the head light sensor by the windshield. Please if someone knows what this is, it is driving me crazy.
agam is offline  
post #10 of 37 Old 10-30-2011, 12:45 PM
clbailey
Registered User
2005 WK 
 
Join Date: Jan 2011
Location: Lake Charles
Posts: 204
Its the door/actuator for your blower motor, untill it stops working completely dont worry about it, mine only does it in the winter and it still works.
clbailey is offline  
post #11 of 37 Old 10-30-2011, 01:08 PM
agam
Registered User
2005 FSJ Cherokee 
 
Join Date: Oct 2011
Location: Rio Rancho
Posts: 2
Thanks! It is not winter in New Mexico with temps in the upper 60s. I will check this part in the service manual.
agam is offline  
post #12 of 37 Old 12-20-2011, 07:14 AM
Z28Justin
Registered User
2005 WK 
 
Join Date: Jun 2008
Location: Toledo, OH
Posts: 61
My 05 WK has started making this noise. I have the manual temp system. I pulled the glove box and can see one of the actuators for the recirculate system. Are all of the actuator and doors on this one unit or are there more further in the dash?

2005 WK Laredo. 4.7L Quadratrac-II (K&N)
1995 Camaro Z28 (too many mods to list)
Z28Justin is offline  
post #13 of 37 Old 12-22-2011, 12:03 PM
Z28Justin
Registered User
2005 WK 
 
Join Date: Jun 2008
Location: Toledo, OH
Posts: 61
Looked into this a little further. I unplugged the recirculate actuator and the noise stopped, so I have narrowed it down to the recirculate actuator.

I pulled it off and let it free spin, it seemed to spin ok. Tried the doors, they were not bound at all. Put it back on and sure enough, click click click. At this point I tried the reset/learn cycle and it seems to have stopped, for now. Will report back when it comes back as I don't understand how it could just forget it's positioning programming

2005 WK Laredo. 4.7L Quadratrac-II (K&N)
1995 Camaro Z28 (too many mods to list)
Z28Justin is offline  
post #14 of 37 Old 01-09-2012, 01:12 AM
oyealiz
Registered User
2000 TJ Wrangler 
 
Join Date: Aug 2009
Location: DFW
Posts: 13
My daughter's 2005 Grand Cherokee is doing the exact same thing. Just started this past week. Boy is it LOUD!!!

How do you accomplish the "reset/learn cycle"?
oyealiz is offline  
post #15 of 37 Old 01-09-2012, 05:16 AM
Z28Justin
Registered User
2005 WK 
 
Join Date: Jun 2008
Location: Toledo, OH
Posts: 61
I think there is a thread here that gives instructions, but you utilize the a/c and rear defrost instead of the buttons listed.

My noise case back so I just unplugged the actuator because I'm cheap and don't really use the recirculate

2005 WK Laredo. 4.7L Quadratrac-II (K&N)
1995 Camaro Z28 (too many mods to list)
Z28Justin is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Loud clicking noise when looseing traction fugi ZJ Grand Cherokee Forum 13 10-14-2009 09:12 AM
Loud clicking noise when going 60...plz help 4x4jeepguy ZJ Grand Cherokee Forum 3 05-05-2009 10:36 AM
HELP...All of a sudden a loud clicking/ticking noise after filling up JeepMeNow ZJ Grand Cherokee Forum 11 05-04-2009 10:10 PM
HELP~~Engine started making a loud clicking/ticking/knocking noise yesterday... JeepMeNow ZJ Grand Cherokee Forum 4 05-04-2009 09:20 PM
Clicking Noise Behind Dash?? Dawggrl ZJ Grand Cherokee Forum 15 11-21-2006 09:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome