Lights keep flashing on and off on dash! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Lights keep flashing on and off on dash!

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsWant to be able to SEE? DOT Approved Headlights for under

Reply
Unread 07-22-2009, 05:15 PM   #1
machurtado
Registered User
 
Join Date: Jul 2009
Location: Arkasas
Posts: 1
Lights keep flashing on and off on dash!

Hello all I have just started having some problems with my 07 grand cherroke. It started about 2 months ago when the malfunction light came on and then went off one day. Now my lights on the dash have started flashing on and off and the air will shut off. Can anyone tell me what's wrong and how expensive is it going to be to fix it?

machurtado is offline   Reply With Quote Quick reply to this message
Unread 07-22-2009, 06:23 PM   #2
konarider94
Registered User
2005 WK 
 
Join Date: Sep 2008
Location: USA
Posts: 458
ive seen other threads about this and the consensus usually is that the ignition switch is bad.
__________________
1994 XJ 2 Door SOLD =(
3"AAL 31x10.5 BFG AT AX-15 NP231

2005 WK Limited 5.7L
245/75-17 goodyear silent armors
no lift, spacers, or cutting required
konarider94 is offline   Reply With Quote Quick reply to this message
Unread 08-14-2009, 11:03 AM   #3
Rwebber77
Registered User
2005 WK 
 
Join Date: Jan 2009
Location: Mankato, Mn
Posts: 116
So my girlfriend was driving my WK last night and all of a sudden the dash lights and exterior lights went off and then came back on a couple times. She pulled over thinking it was going to blow or something crazy, but then it was fine the rest of the way home. I think the ignition switch has been going bad for about a month now because once in a while I start it and the malfunction light comes on with the speedometer and RPM gauges both dark. When I shut it off and restart it everything is fine. I have tried pulling the malfunction code but always get an error message saying there is no code to read or clear.

My question is this. Is there just an ignition switch or do I need a whole new cylinder and re-key? I am going to the stealership today or tomorrow and I want to keep them honest.
__________________
5.7 Hemi, OME HD, 1.25" spacers, 265/70/17 Revo 2's, Volant CAI, Gibson Catback, SCT engine management, Superchips piggy back with trans app, 3/4" front shackles
Rwebber77 is offline   Reply With Quote Quick reply to this message
Unread 08-14-2009, 04:07 PM   #4
TonyVideo
Senior Member
 
TonyVideo's Avatar
2008 WK 
 
Join Date: Apr 2008
Location: Rushville, IN
Posts: 750
I would have the battery checked before I did anything. Has it been replaced since new?
__________________
Tony
2008 GC 3.0L CRD Limited, ProVent Installed, Clear Bra, Scangauge
1999 GC 4.0L Larado
1985 Jeep Larado 4.0L Sold
TonyVideo is offline   Reply With Quote Quick reply to this message
Unread 08-14-2009, 04:14 PM   #5
Rwebber77
Registered User
2005 WK 
 
Join Date: Jan 2009
Location: Mankato, Mn
Posts: 116
It has not. So a battery going bad can really create those types of issues? I will get it load tested right away, and I suppose while I'm at it I should test the alternator.
__________________
5.7 Hemi, OME HD, 1.25" spacers, 265/70/17 Revo 2's, Volant CAI, Gibson Catback, SCT engine management, Superchips piggy back with trans app, 3/4" front shackles
Rwebber77 is offline   Reply With Quote Quick reply to this message
Unread 08-15-2009, 08:37 PM   #6
TonyVideo
Senior Member
 
TonyVideo's Avatar
2008 WK 
 
Join Date: Apr 2008
Location: Rushville, IN
Posts: 750
Absolutely. I had my WJ go nuts with all the dials moving around and lights flashing. It was like the thing had a mind of its own. Replaced the battery which was only 3 years old and presto, no problems since. These computer controlled systems are real sensitive to fluctuating voltage. I had codes coming from everywhere. New battery, all fine. It is worth a shot to check it first, and if it is older than 4 years replace it anyway, so you won't have any issues down the road.
__________________
Tony
2008 GC 3.0L CRD Limited, ProVent Installed, Clear Bra, Scangauge
1999 GC 4.0L Larado
1985 Jeep Larado 4.0L Sold
TonyVideo is offline   Reply With Quote Quick reply to this message
Unread 08-15-2009, 09:20 PM   #7
bajafanatic
Registered User
2007 JK Wrangler 
 
Join Date: Jun 2007
Location: Cedar Falls, Iowa
Posts: 228
My wife's 2006 XK just had some crazy stuff happen.. she was driving with the air and cruise on... mid-day... and all of a sudden all the dash lights came on, then went off, the air cut back in power, but the cruise stayed as normal.. a few seconds later, the lights went out, the air and cruise were normal again but the engine light, ABS light and another warning light stayed on...
When I got home from work.. we took it to the dealer.. they had it for three days and found NOTHING...

We are waiting for it to happen again...
bajafanatic is offline   Reply With Quote Quick reply to this message
Unread 08-19-2009, 04:53 PM   #8
Rwebber77
Registered User
2005 WK 
 
Join Date: Jan 2009
Location: Mankato, Mn
Posts: 116
Well I had the battery load tested and it is a perfectly good battery. On to my next option, the ignition switch. Anyone have the improved part number as I don't want the original since they are known for failing!
__________________
5.7 Hemi, OME HD, 1.25" spacers, 265/70/17 Revo 2's, Volant CAI, Gibson Catback, SCT engine management, Superchips piggy back with trans app, 3/4" front shackles
Rwebber77 is offline   Reply With Quote Quick reply to this message
Unread 08-19-2009, 05:47 PM   #9
potamo
Registered User
2005 WK 
 
Join Date: Mar 2007
Location: Spain
Posts: 102
Quote:
Originally Posted by bajafanatic View Post
My wife's 2006 XK just had some crazy stuff happen.. she was driving with the air and cruise on... mid-day... and all of a sudden all the dash lights came on, then went off, the air cut back in power, but the cruise stayed as normal.. a few seconds later, the lights went out, the air and cruise were normal again but the engine light, ABS light and another warning light stayed on...
When I got home from work.. we took it to the dealer.. they had it for three days and found NOTHING...

We are waiting for it to happen again...
Just a me too here. It happened four times or so. Nothing found in the computer. These electrical problems are eery.

I think they flashed it and it has never happened again.

I have not changed the battery in the almost 4 years I own the GC.
potamo is offline   Reply With Quote Quick reply to this message
Unread 08-19-2009, 06:06 PM   #10
TonyVideo
Senior Member
 
TonyVideo's Avatar
2008 WK 
 
Join Date: Apr 2008
Location: Rushville, IN
Posts: 750
I still say it is the battery. These things like nice stable power with no fluctuations. My battery load tested fine on a heavy cranking load. Just put a light load on it and see if the voltage fluctuates up and down. I know it will slowly go down. I ran the radio and put a meter on it and it went up and down not just down. Replaced it and no problems. Check it with the engine running as well to see if the voltage fluctuates. Check to see if it is too high a voltage as well. I would certainly make sure it is not the battery and/or regulator when the engine is running. My two cents. If you battery is 4 years old you should probably replace it anyway. Why wait till it fails? It is a regular maintenance item just like changing oil. We don't wait until the oil turns to sludge before changing it. Computers hate voltage spikes up or down. It is a sure way to kill electrical components over the long run when all you need to do is regularly change the battery. Batteries take a beating in today's vehicles with everything they have to power, outside of hot weather and cold starts.
__________________
Tony
2008 GC 3.0L CRD Limited, ProVent Installed, Clear Bra, Scangauge
1999 GC 4.0L Larado
1985 Jeep Larado 4.0L Sold
TonyVideo is offline   Reply With Quote Quick reply to this message
Unread 08-19-2009, 10:11 PM   #11
bajafanatic
Registered User
2007 JK Wrangler 
 
Join Date: Jun 2007
Location: Cedar Falls, Iowa
Posts: 228
so.. i posted a few days ago about what happened to my wife's commander... well, yesterday sitting in the garage, I started it and turned on the fan for the air... the dash lights went out and stayed out....
I turned everything off and restarted the commander.... everything came back on along with the check engine light, abs, and a few other warning lights... the check engine light stayed lite...
after running the diagnostic the code showed.... the issue was the ignition switch... it will be replaced tomorrow...
i will keep you all posted...
bajafanatic is offline   Reply With Quote Quick reply to this message
Unread 08-20-2009, 02:39 AM   #12
potamo
Registered User
2005 WK 
 
Join Date: Mar 2007
Location: Spain
Posts: 102
Quote:
Originally Posted by TonyVideo View Post
I still say it is the battery. These things like nice stable power with no fluctuations. My battery load tested fine on a heavy cranking load. Just put a light load on it and see if the voltage fluctuates up and down. I know it will slowly go down. I ran the radio and put a meter on it and it went up and down not just down. Replaced it and no problems. Check it with the engine running as well to see if the voltage fluctuates. Check to see if it is too high a voltage as well. I would certainly make sure it is not the battery and/or regulator when the engine is running. My two cents. If you battery is 4 years old you should probably replace it anyway. Why wait till it fails? It is a regular maintenance item just like changing oil. We don't wait until the oil turns to sludge before changing it. Computers hate voltage spikes up or down. It is a sure way to kill electrical components over the long run when all you need to do is regularly change the battery. Batteries take a beating in today's vehicles with everything they have to power, outside of hot weather and cold starts.
There could be some different problems with the same symptoms.

Bad battery, ignition switch and the unknown

IF it is the battery and does weird things, it indicates that the alternator and subsequent electronic parts are either badly designed or quite sh*tty IMHO
potamo is offline   Reply With Quote Quick reply to this message
Unread 08-20-2009, 07:07 AM   #13
konarider94
Registered User
2005 WK 
 
Join Date: Sep 2008
Location: USA
Posts: 458
Quote:
Originally Posted by potamo View Post
There could be some different problems with the same symptoms.

Bad battery, ignition switch and the unknown

IF it is the battery and does weird things, it indicates that the alternator and subsequent electronic parts are either badly designed or quite sh*tty IMHO
given that the vehicle is so new i doubt its multiple problems that occurred at the same time.
__________________
1994 XJ 2 Door SOLD =(
3"AAL 31x10.5 BFG AT AX-15 NP231

2005 WK Limited 5.7L
245/75-17 goodyear silent armors
no lift, spacers, or cutting required
konarider94 is offline   Reply With Quote Quick reply to this message
Unread 08-20-2009, 07:27 AM   #14
BonesWK
Web Wheeler
 
BonesWK's Avatar
2006 WK 
 
Join Date: Apr 2008
Location: Wilmington, NC
Posts: 1,944
I was begining to worry I was the only one having this priblem... any update as to the ignition switch helped?
__________________
Ryan
2006 Black WK Limited 4.7 4x4 QD II -- RR 2.25" Lift - JK Moabs - 32" Wildpeaks - Rear OME Shocks - AFE Stage 2 Intake - Saguaro 4x Front Shackles - 1-1/2" Wheel Spacers - Tail Light Guards - CB - 4' Firestik - Rola Roof Rack - Exhaust
If you want to achieve greatness, stop asking for permission
Chive On
BonesWK is offline   Reply With Quote Quick reply to this message
Unread 08-20-2009, 07:53 AM   #15
potamo
Registered User
2005 WK 
 
Join Date: Mar 2007
Location: Spain
Posts: 102
Quote:
Originally Posted by konarider94 View Post
given that the vehicle is so new i doubt its multiple problems that occurred at the same time.
I meant that we all could be talking about different problems not that all the problems appeared in his/her car... although Murphy's law can have a say
potamo is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.