K@N 57 Whining Noise - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > K@N 57 Whining Noise

Oconee Off-Road Free Shipping Lifts Tires Bumpers Tops andUSA Standard Chromoly Front Axle Shaft Kits with Dana 30 4Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 11-11-2012, 06:40 AM   #1
rupp0003
Registered User
2006 WK 
 
Join Date: Sep 2012
Location: Ottawa, Ontario
Posts: 4
K@N 57 Whining Noise

I installed a K&N 57 FIPK on my 4.7 WK a few days ago. On cold startup I get a whining/sucking noise until the RPMs come down. In the instructions it shows a "T" fitting on the factory crankcase vent that is supposed to be attached to the K@N intake tube. My jeep had no "T" along the length of the tube. It was one solid air tube into the old stock air box. I ended up having to cut the stock hose and pipe it to the new intake tube. The intake sounds good and seems to work well. except the noise on cold start up. Has anyone with a K&N had this sucking/whining noise? I also used a Superchips Flashpaq 87 tune... not sure if that is relevant to my issue.

rupp0003 is offline   Reply With Quote
Unread 11-11-2012, 03:04 PM   #2
S10slayer
Registered User
 
Join Date: Oct 2010
Location: Newcastle
Posts: 34
I have the same thing going in my 4.7 just during the cold start up. after it warms up its good for the rest of the day, my k&n intake does that on my ranger with a 4.0 liter v6 too
S10slayer is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.