iPhone 5 ios7 7.0.3 Pairing Sound Delay Outbound Calls - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > iPhone 5 ios7 7.0.3 Pairing Sound Delay Outbound Calls

RIGID LED Light Blowout Sale - All Sizes, All Series, all ECGS Black Friday Sale!!6th Annual, Beat Your Wife to the Credit Card Sale!

Reply
Unread 11-02-2013, 08:24 PM   #1
jeremyAZ
Registered User
2006 WK 
 
Join Date: Aug 2012
Location: Scottsdale, AZ
Posts: 34
iPhone 5 ios7 7.0.3 Pairing Sound Delay Outbound Calls

Searched the forum and couldn't find the answer so I figured maybe a post would help me and possibly others out. Added amd paired my iPhone 5 (not 5S) using ios7.0.3 to my WK Jeep Overland 2006 with uConnect. It pairs and works but here is the issue: when dialing out and rings the radio still plays and the bluetooth connection only plays the call over the speakers once the person on the other end actually answers the phone (or when voicemail or auto attendant picks up).

In all my other cars and with all my other phones the bluetooth connection would play the ringing over the speakers so you can hear when they answer (or not). I tried my phone on my wife's vehicle and it works normally. I tried my wife's iPhone 5 on my car and she has the same problem I described above. So my guess is that it's something with ios7.0.03 and my version of uConnect and/or iPhone 5 (not 5S).

Anyone have a similar issue and maybe a solution? I've tried deleting the phones from uConnect, re-pairing the connection, different phones to no avail. BTW--my iPhone 4S on ios7.0.1 worked flawlessly on this same car a few weeks ago.

Thanks!

__________________
Silver 2006 WK 5.7l Hemi Overland ~70k miles
jeremyAZ is offline   Reply With Quote Quick reply to this message
Unread 11-02-2013, 09:07 PM   #2
OregonCarGuy
Registered User
2005  
 
Join Date: Dec 2012
Location: Eugene, OR
Posts: 27
It has always been this way for me with my iPhone 4 (pre-iOS7) and now 5s, so I'm not sure what to say. Really isn't a problem IMO.
__________________
-Nick from Orygun
'05 WK 5.7 Hemi Limited - "Big Red"
OME HD, Superchips 3870
OregonCarGuy is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 01:03 AM   #3
_Kyle_
Registered User
1996 ZJ 
 
Join Date: Oct 2005
Location: Abingdon, MD
Posts: 2,763
Is your software on the head unit the latest version? I have that updated and my iOS and I don't have any issues.

Sent from my iPhone using JeepForum
__________________
-Kyle

1996 Grand Cherokee

RIP Troy (bigbluezj94)

1996 ZJ FOR SALE
_Kyle_ is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 01:47 AM   #4
Billybcpt
Registered User
2005 WK 
 
Join Date: May 2011
Location: , MA
Posts: 462
Quote:
Originally Posted by _Kyle_
Is your software on the head unit the latest version? I have that updated and my iOS and I don't have any issues. Sent from my iPhone using JeepForum
Same as above dude^^^^^ what head unit do you have? I have the Mygig RHR retrofitted in my 2005 WK with the latest software update and the Mygig Lockpick it works flawlessly Absolutely no issues whatsoever. First try disconnecting the battery, negative first, positive last (then touch the positive and negative cables together for at least a minute to drain the capacitors) then leave both unconnected overnight. Also pull the fuse supplying the radio before you reconnect the battery (power surges can damage the radio). Next morning reconnect the battery then push the fuse back in for the radio. The system should reset itself but your phone will still be paired to it. If that doesn't work then you probably need to update the radio's software. Take note this happened to me too and the above worked and still is
Billybcpt is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 01:51 AM   #5
_Kyle_
Registered User
1996 ZJ 
 
Join Date: Oct 2005
Location: Abingdon, MD
Posts: 2,763
Quote:
Originally Posted by Billybcpt
Same as above dude^^^^^ what head unit do you have? I have the Mygig RHR retrofitted in my 2005 WK with the latest software update and the Mygig Lockpick it works flawlessly Absolutely no issues whatsoever. First try disconnecting the battery, negative first, positive last (then touch the positive and negative cables together for at least a minute to drain the capacitors) then leave both unconnected overnight. Also pull the fuse supplying the radio before you reconnect the battery (power surges can damage the radio). Next morning reconnect the battery then push the fuse back in for the radio. The system should reset itself but your phone will still be paired to it. If that doesn't work then you probably need to update the radio's software. Take note this happened to me too and the above worked and still is
My only issue is that I can't get music to stream at all but I just don't think it's supported at all. Which kinda sucks.

Sent from my iPhone using JeepForum
__________________
-Kyle

1996 Grand Cherokee

RIP Troy (bigbluezj94)

1996 ZJ FOR SALE
_Kyle_ is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 03:05 AM   #6
Billybcpt
Registered User
2005 WK 
 
Join Date: May 2011
Location: , MA
Posts: 462
Quote:
Originally Posted by _Kyle_
My only issue is that I can't get music to stream at all but I just don't think it's supported at all. Which kinda sucks. Sent from my iPhone using JeepForum
Do you have the RHR or the RER?
Billybcpt is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 07:58 AM   #7
jeremyAZ
Registered User
2006 WK 
 
Join Date: Aug 2012
Location: Scottsdale, AZ
Posts: 34
Can someone describe how to verify what software version my Uconnect/Head Unit is using? I went to the Uconnect website and put in my last 8 digits for VIN and it says there are no updates--but that doesn't seem right to me.

BTW--thanks for the battery disconnect suggestion I'll likely give that a go.
__________________
Silver 2006 WK 5.7l Hemi Overland ~70k miles
jeremyAZ is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 09:07 AM   #8
_Kyle_
Registered User
1996 ZJ 
 
Join Date: Oct 2005
Location: Abingdon, MD
Posts: 2,763
Quote:
Originally Posted by jeremyAZ
Can someone describe how to verify what software version my Uconnect/Head Unit is using? I went to the Uconnect website and put in my last 8 digits for VIN and it says there are no updates--but that doesn't seem right to me. BTW--thanks for the battery disconnect suggestion I'll likely give that a go.
Go into settings and system information to see what your version is. I think the newest is 2.4xx.

I'm not sure which one I have. I have navigation though but I need to find my build sheet information.

Sent from my iPhone using JeepForum
__________________
-Kyle

1996 Grand Cherokee

RIP Troy (bigbluezj94)

1996 ZJ FOR SALE
_Kyle_ is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 02:32 PM   #9
Billybcpt
Registered User
2005 WK 
 
Join Date: May 2011
Location: , MA
Posts: 462
Look in lower right corner of your head unit. What are the 3 letters?
Billybcpt is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 02:40 PM   #10
_Kyle_
Registered User
1996 ZJ 
 
Join Date: Oct 2005
Location: Abingdon, MD
Posts: 2,763
Quote:
Originally Posted by Billybcpt
Look in lower right corner of your head unit. What are the 3 letters?
Rer

Sent from my iPhone using JeepForum
__________________
-Kyle

1996 Grand Cherokee

RIP Troy (bigbluezj94)

1996 ZJ FOR SALE
_Kyle_ is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 02:50 PM   #11
Billybcpt
Registered User
2005 WK 
 
Join Date: May 2011
Location: , MA
Posts: 462
Quote:
Originally Posted by _Kyle_
Rer Sent from my iPhone using JeepForum
Then press menu, then go to system information. The software info should be there
Billybcpt is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 03:01 PM   #12
_Kyle_
Registered User
1996 ZJ 
 
Join Date: Oct 2005
Location: Abingdon, MD
Posts: 2,763
Quote:
Originally Posted by Billybcpt
Then press menu, then go to system information. The software info should be there
Nah mine is up to date. But I can't get Bluetooth audio to stream other than Siri or phone calls. I just don't think it's supported by my gig. Which I would think with the updates that it would because they enhanced things such as called id information being displayed and voice dial from your phone contacts directly with the latest version.

Sent from my iPhone using JeepForum
__________________
-Kyle

1996 Grand Cherokee

RIP Troy (bigbluezj94)

1996 ZJ FOR SALE
_Kyle_ is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 03:10 PM   #13
Billybcpt
Registered User
2005 WK 
 
Join Date: May 2011
Location: , MA
Posts: 462
Oh ya you have the RER lol my bad. You don't have the hardware capability for wireless audio BT streaming but I have the RHR and it does.
Billybcpt is offline   Reply With Quote Quick reply to this message
Unread 11-03-2013, 03:37 PM   #14
_Kyle_
Registered User
1996 ZJ 
 
Join Date: Oct 2005
Location: Abingdon, MD
Posts: 2,763
Quote:
Originally Posted by Billybcpt
Oh ya you have the RER lol my bad. You don't have the hardware capability for wireless audio BT streaming but I have the RHR and it does.
I kinda figured it wasn't supported. I thought it was more of a software thing than a hardware thing.

Sent from my iPhone using JeepForum
__________________
-Kyle

1996 Grand Cherokee

RIP Troy (bigbluezj94)

1996 ZJ FOR SALE
_Kyle_ is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.