Intermittent Severe Vibration 2005 JGC - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Intermittent Severe Vibration 2005 JGC

BDS 4-1/2" Suspension Lift Kit - Jeep Wrangler YJRough Country Lift Kits and Parts!FREE, FREE, FREE EVENT!! Save big on Lockers now till Apri

Reply
Unread 06-16-2013, 07:22 PM   #31
hduva
Registered User
 
Join Date: Jun 2013
Location: Tewksbury, MA
Posts: 3
Quote:
Originally Posted by mustgooverit View Post
I finally fixed the problem by replacing the transmission control module. The module itself is the shifter bezel that has park reverse nutral and drive on it.
Are you still having the issue after replacing this ? Was it covered under the warrantee?

Thanks!

hduva is offline   Reply With Quote Quick reply to this message
Unread 06-16-2013, 07:30 PM   #32
hduva
Registered User
 
Join Date: Jun 2013
Location: Tewksbury, MA
Posts: 3
I have the same problem with my 2007 Grand Cherokee (97k miles).
Happens at all speeds pulling out of my driveway at 20 MPH to on the highway at 65 MPH! FIrst repair as a new Caliper that froze on me, second was a break job, third time new tires. So frustrating! Now that i have new tires with maybe 1000 miles on them i am still experiencing the vibration/shudder. I can pull over, come to a complete stop and drive away with nothing. I left it with the dealer for two days, mechanic drove it home twice (150 miles) and of course NOTHING! Very interested in hearing what has worked. We are going away for a family vacation in a few weeks and we need the space in the Jeep.
Any advice or fixes that have worked?
Thanks!
hduva is offline   Reply With Quote Quick reply to this message
Unread 06-17-2013, 08:56 PM   #33
hduva
Registered User
 
Join Date: Jun 2013
Location: Tewksbury, MA
Posts: 3
Quote:
Originally Posted by Cally View Post
I have a 2005 Jeep Grand Cherokee WK with the 3.7L engine. I have an intermittent problem, where the entire vehicle vibrates severely while driving along, as though you are driving over slowdown bumps on the road, except there aren’t any bumps. It happens every few days, when cruising at 50 – 60 mph. The vibration continues even when the vehicle slows down, except once I have stopped and drive away again the vibration has gone. I am bit stumped as to the cause and have no warning lights. I calle Jeep and they told me unless the check engine light comes on don't bring it in as they won't be able to replicate it. I asked about the wheel bearings or hubs and was told 'it might be'.

I would appreciate any help you can offer.
I am having the same problem now... What was the problem and fix for you?
hduva is offline   Reply With Quote Quick reply to this message
Unread 08-29-2013, 08:58 AM   #34
mphinn
Registered User
 
Join Date: Aug 2013
Location: clayton, ny
Posts: 1
2006 Jeep Grand Cherokee with same problem

The problem in mine is extremely intermittent, and has only occurred a few times in the last 2000 miles. Sounds the same, extreme vibration, pull over stop and then drive away with no problem for 100's of miles after that.

Cally just wondering if you have solved anything?

zup28w are you still doing fine after the fluid changes?

Or does anyone else have any advice?
mphinn is offline   Reply With Quote Quick reply to this message
Unread 08-29-2013, 09:46 AM   #35
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
Happened on my WJ. Driveshaft was out of balance with the combination of my tires. Once I went around the right turn at the right speed, all of them were out of balance at the same time...HUGE vibrations. It was very random at time.
R32R1 is offline   Reply With Quote Quick reply to this message
Unread 08-29-2013, 01:12 PM   #36
zup28w
Registered User
2005 WK 
 
Join Date: Apr 2011
Location: Stoneham, MA
Posts: 76
Hi mphinn,

I have not had it happen since the fluid change. I've put over 40k miles on it since I originally had the problem.

Good luck getting it resolved.

Greg
zup28w is offline   Reply With Quote Quick reply to this message
Unread 08-29-2013, 04:21 PM   #37
AlKidd
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: caledon, Ontario
Posts: 13
I had similar experience with my 08. Ive diagnosed it as a stuck caliper pin. Seems the caliper brake would oscillate in the bracket. Stopping re-positions the caliper. Havent had it happen since the brake job but will advise if it shows up again.
AlKidd is offline   Reply With Quote Quick reply to this message
Unread 05-04-2014, 02:03 PM   #38
Mountain_1
Registered User
 
Join Date: May 2014
Location: Weare, NH
Posts: 1
minor and severe vibration

intermittent
Mountain_1 is offline   Reply With Quote Quick reply to this message
Unread 01-01-2016, 09:52 AM   #39
p1100
Registered User
2008 WK 
 
Join Date: Jul 2011
Location: Toronto, Ontario
Posts: 2
I may be on to something

I have been having the same issue on mine, tried just about everything listed on the forum and had the dealer check it out.

Changed all fluids. During driving: applied brakes (heavy), slaloming, downshifted, put in neutral, turned engine off, tuned DSC off, turned on tow/haul.

The vibration is random, every couple of months or longer, always starts minor then builds up to a noticeable shudder and the only way to get rid of it is to come to a complete stop. Then drive away and it's fine. Nothing I did made it go away while driving. The frequency of the vibration is connected to the speed of the car.

It happened again yesterday, this time I pulled the emergency brake on while doing about 50 mpg, the vibration got worse and more severe but was at the same frequency with a little more intensity. Released the brake and the shutter reduced again. Pulled it again but this time harder the released the break and the shutter was gone.

This is the first time I have been able to get rid of the shutter without pulling over. Pulled the brake again, shutter was there but not as intense.

Maybe debris/rust builds up in the emergency brake drum or the pads shift somehow.

Maybe I will pull the brake on once a month or so to keep it clean. Hopefully the vibration wont come back.

Last edited by p1100; 01-03-2016 at 02:40 PM..
p1100 is offline   Reply With Quote Quick reply to this message
Unread 01-01-2016, 10:35 AM   #40
ianrmz250
Registered User
2007 WK 
 
Join Date: Nov 2009
Location: Hertfordshire England UK
Posts: 208
You will most likely have to change the parking brake shoes I had the same random vibration . The parking brake shoes were covered in a thick lager of debris and corrusion .Changed the parking brake shoes and all is fine.
ianrmz250 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.