Idle Dips at the lights - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Idle Dips at the lights

Savvy/Currie Aluminum Control ArmsRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 04-12-2013, 08:46 AM   #1
matt777
Registered User
2005 WK 
 
Join Date: Nov 2012
Location: edmonton, alberta
Posts: 13
Idle Dips at the lights

My '05 GC runs great at 240km. However, when you come to a stop in gear the idle drops to 400 rpm and then recovers. The warmer the ambient gets the more it does it. It didn't seem to have this problem when I bought it early in the winter when the temps were cold but now that they are above freezing it does it more. When it was very cold it would occasionally stall when you stopped when the engine was cold. There are no codes and the dealer can't help. They said it might be transmission bump stop?? but I think that is something different. Any ideas?
It has new plugs, IAC and I cleaned the throttle body already .I might just start replacing sensors


Last edited by matt777; 04-12-2013 at 11:17 AM..
matt777 is offline   Reply With Quote Quick reply to this message
Unread 04-12-2013, 12:09 PM   #2
caulk04
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: Greenville, Pennsylvania
Posts: 997
4.7? I had that trouble with my Dakota years ago. Tried a new tps first, nothing. The iac did it. Seems hit or miss for which one fixes it, though usually one will.
__________________
Tint, Superchips, SRT intake tube, Gibson catback, catch can. One hardcore DD/kid hauler...yeah.
caulk04 is offline   Reply With Quote Quick reply to this message
Unread 04-12-2013, 08:43 PM   #3
matt777
Registered User
2005 WK 
 
Join Date: Nov 2012
Location: edmonton, alberta
Posts: 13
Yeah I'll either change the TPS, inlet air temp or MAP sensor next.
matt777 is offline   Reply With Quote Quick reply to this message
Unread 02-15-2014, 12:18 PM   #4
matt777
Registered User
2005 WK 
 
Join Date: Nov 2012
Location: edmonton, alberta
Posts: 13
The problem seems to be that it was almost 1 quart low.
matt777 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.