How to diagnose service 4WD message? - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > How to diagnose service 4WD message?

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitThe ALL NEW Factor 55 ProLink Winch Shackle Mounts availabFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 09-28-2009, 11:53 AM   #31
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
I have a front diff stripped at the moment shout what pictures you want if any. Must be tonight I plain on rebuilding it tomorrow.

__________________
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote
Unread 09-28-2009, 01:19 PM   #32
LJS8510
Web Wheeler
 
LJS8510's Avatar
2008 WK 
 
Join Date: Oct 2007
Location: Chicago Il, IL
Posts: 1,320
please take some,

thanks
__________________

08 CRD @ 163,000
OME HD Lift about 3"
4xGuard Rails
Stillens
AEV Wheels 5.75 BS
JBA UCA's
GSA 255/75/17 32.1" (no bolt cut/no pinch weld)
spare 265/70/17 stock location
Lockpic, 100,000 club
LJS8510 is offline   Reply With Quote
Unread 09-29-2009, 02:00 PM   #33
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Quote:
Originally Posted by LJS8510 View Post
please take some,

thanks
Well didn't know what you wanted and some good pics already posted so took these two for you.
102_2841.jpg   102_2842.jpg  
__________________
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote
Unread 09-29-2009, 03:41 PM   #34
LJS8510
Web Wheeler
 
LJS8510's Avatar
2008 WK 
 
Join Date: Oct 2007
Location: Chicago Il, IL
Posts: 1,320
Thanks Merlin Tec
__________________

08 CRD @ 163,000
OME HD Lift about 3"
4xGuard Rails
Stillens
AEV Wheels 5.75 BS
JBA UCA's
GSA 255/75/17 32.1" (no bolt cut/no pinch weld)
spare 265/70/17 stock location
Lockpic, 100,000 club
LJS8510 is offline   Reply With Quote
Unread 10-18-2009, 06:40 PM   #35
Podedwards
Registered User
2007 JK Wrangler 
 
Join Date: Sep 2006
Location: Grand Lake, CO
Posts: 150
Hold on

There is a service bulletin on wiring from the 4WD sensor to the computer. It is grounding out. Jeep will repair it.

The continuity has to be checked on that part of the wiring harness.
__________________
"An appeaser is one who feeds a crocodile, hoping it will eat him last" Winston Churchill
Podedwards is offline   Reply With Quote
Unread 07-05-2010, 08:14 PM   #36
crawbob
Registered User
 
Join Date: Dec 2009
Location: California
Posts: 9
Got rid of the message. Stopped on dirt road got rid of the message and put into 4wd and drove several miles. No more message. Apparently there is a sensor that needs to be used once in a while or it gives a false message. Have driven 300 miles and no more messages.
crawbob is offline   Reply With Quote
Unread 07-05-2010, 08:39 PM   #37
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,429
My warning went out for a month or so, but it is back again. I have the solenoids for replacement. I am just waiting for the fluid interval to do the solenoid swaps.

If it is a TSB, that means that Jeep will fix it on your dime, assuming that you are out of warranty. I would rather fix it myself.
__________________
'06 XK Limited, 5.7L, QD II, Black, 122K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 101K
kentman is offline   Reply With Quote
Unread 01-26-2012, 03:31 AM   #38
samowens44
Registered User
2005 WK 
 
Join Date: Jan 2012
Location: Gainesville, Fl
Posts: 2
Service 4wd System Quadra Drive II System

I had this light on for 5 years, took into the dealer 3 times with the same results. Reprogram FDCM, clear light and told me it was an error. I finally found out that I could keep the light out by just delaying the turning of the key to the second position by 2 sec. then turn to start, no light. Worked, no Service 4wd light. Then I started having a clunking noise in the front when slowing and making left or right hand turns. After going on the internet and finding information about the Quadra Drive II, I saw what was happening with the aid of a web cam under my front bumper with a view of my CV Drive Axle. My front axle bushing was bad. Now this was replaced and still had the clunk, but not as violent. I discovered that the clunking is really a term called "Crow Hop". This is because the Front Drive Axle ELSD was not going to slip and staying in full 4wd lock. This was further found out thru the dealer diagnostics that the Actuator Solenoid and Wiring Harness were faulty. They were replaced and now my Jeep has no clunk sound and I am getting better gas mileage.
samowens44 is offline   Reply With Quote
Unread 01-26-2012, 08:09 AM   #39
07greygoose
Registered User
2007 WK 
 
Join Date: Oct 2011
Location: Lexington, SC
Posts: 33
My wife's 05 Hemi did this right after we bought it back in 2008. It would flash the "service 4WD System" message for about ten seconds then go away at first. Then a few months later it would not shift into 4WD at all and the message was permanent on the display. Took in to the dealer under warranty and ended up having to have a computer flash update and replace a differential. All costs were covered thankfully but haven't had any problems since.
__________________
2007 Grand Cherokee Laredo 4X4 TrailRated / 4.7 V8
Blue WK Club #24
07greygoose is offline   Reply With Quote
Unread 07-19-2012, 04:16 PM   #40
Stevehunts
Registered User
2006 XJ Cherokee 
 
Join Date: Jul 2012
Location: Summit, MS
Posts: 1
service 4 wheel drive no codes

Quote:
Originally Posted by samowens44 View Post
I had this light on for 5 years, took into the dealer 3 times with the same results. Reprogram FDCM, clear light and told me it was an error. I finally found out that I could keep the light out by just delaying the turning of the key to the second position by 2 sec. then turn to start, no light. Worked, no Service 4wd light. Then I started having a clunking noise in the front when slowing and making left or right hand turns. After going on the internet and finding information about the Quadra Drive II, I saw what was happening with the aid of a web cam under my front bumper with a view of my CV Drive Axle. My front axle bushing was bad. Now this was replaced and still had the clunk, but not as violent. I discovered that the clunking is really a term called "Crow Hop". This is because the Front Drive Axle ELSD was not going to slip and staying in full 4wd lock. This was further found out thru the dealer diagnostics that the Actuator Solenoid and Wiring Harness were faulty. They were replaced and now my Jeep has no clunk sound and I am getting better gas mileage.
Same here, delay tirning the key, and no "service 4 wheel drive". Yep, I've had the flash update, and that resolved an earlier problem for 1 1/2 years. Following normal factory service on the transfere case, the service 4 wheel began coming on again. It has progress until now it will always come on unless waiting 2 seconds from on to start. Spent 2 days at the dealer checking wiring, modules, etc. Their final answer was to replace the rear ELSD solenoid. $50.00 for the part, $560.00 labor? with no gaurante this would solve anything. (they said they had a high ohms reading on the coil) From the pics I've seen, the coil looks like it can be changed just by pulling the cover? Is this true? Does anyone know what the coil should ohm out at?
Stevehunts is offline   Reply With Quote
Unread 07-26-2012, 03:53 PM   #41
denneyr
Registered User
2005 WK 
 
Join Date: Feb 2009
Location: AL
Posts: 1
I have the service 4wd system message. I took it to the dealer and they analyzed it and said it was the transfer case actuator motor. I obtained a rebuilt transfer case motor and installed it. The message is still there and it still won't go into 4low. Any advice from here?
denneyr is offline   Reply With Quote
Unread 07-27-2012, 05:29 AM   #42
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,429
Quote:
Originally Posted by Stevehunts View Post
Their final answer was to replace the rear ELSD solenoid. $50.00 for the part, $560.00 labor? with no gaurante this would solve anything.
$560 for labor. Ouch. That is crazy. Once the cover is off, it takes all of a couple minutes to swap out the sensor. I paid $23 for the part and did the labor myself on the next fluid swap.

I and others have found that the front ELSD solenoid is the problematic one. I bought two solenoids and figured that I would try the front first and see if that cured the problem. If not, then I was going to do the rear one. The front one cured the problem. I left the rear one alone and swapped the fluid in the rear only.
__________________
'06 XK Limited, 5.7L, QD II, Black, 122K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 101K
kentman is offline   Reply With Quote
Unread 07-27-2012, 08:02 AM   #43
longboy
Registered User
2006 WK 
 
Join Date: Nov 2006
Location: Longmont, Colorado
Posts: 892
How difficult is it to replace the front solenoid? Obviously doing the rear would be much easier since you can remove the diff cover easily. I also have the Service 4WD message and debating taking it to a shop vs. doing it myself.
__________________
2006 WK 5.7 Hemi
longboy is offline   Reply With Quote
Unread 07-27-2012, 08:19 AM   #44
IndyBlueWK
Registered User
2005 WK 
 
Join Date: Feb 2012
Location: Carmel, indiana
Posts: 1,135
mine has been on for two months... Thinking about taking it in to see what they say..
IndyBlueWK is offline   Reply With Quote
Unread 07-27-2012, 05:00 PM   #45
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,429
Quote:
Originally Posted by longboy
How difficult is it to replace the front solenoid?
On the XK, it was not bad at all. There is an extra mount on the cover that needs to be unmounted. Other than that, it is a normal front differential fluid swap in terms of work.
__________________
'06 XK Limited, 5.7L, QD II, Black, 122K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 101K
kentman is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.