Horn doesn't work when pressing steering wheel; horn does chirp when arming/panic - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Horn doesn't work when pressing steering wheel; horn does chirp when arming/panic

JK specific skid plates from Clayton Off Road Mfg.RCV Heavy Duty Axle Shafts Now Shipping at Baseline4x4.comStainless Steel Door Hinge Pins

Reply
Unread 09-10-2009, 10:31 AM   #1
cmassey_2006
Registered User
2006 WK 
 
Join Date: Apr 2006
Location: Georgia
Posts: 515
Horn doesn't work when pressing steering wheel; horn does chirp when arming/panic

Hey guys, I've searched the WK forums for "horn" and surprisingly got very few hits, of which none were relevant to my problem.

I have an '06 WK Limited, and when I press the steering wheel to sound the horn, nothing happens. Oddly enough, when I arm my factory alarm system or press the panic button on the keyfob the horn does sound. Is there a fuse for the horn? The cover for the fuse box located in the engine bay doesn't show a label for the horn. If a fuse was blown, would the alarm/panic features still sound the horn? What can I try first, before taking it to the dealership?

Any help would be much appreciated, as it is very annoying not being able to use your horn at clueless drivers!

__________________
2006 White Jeep WK Limited 4x4: (current) 67K miles, 5.7L HEMI, auto, Quadra-drive II, factory tow hooks, hitch, skids, and many "bells and whistles"...

2007 Silver Jeep WK Laredo 4x4: (Sold) 10K miles, 3.7L V6, auto...

1998 Blue Jeep XJ 4x4: (Sold) @ 156K miles, I6, AW4 tranny, several mods...
cmassey_2006 is offline   Reply With Quote
Unread 09-10-2009, 10:38 AM   #2
Texas WJ
Web Wheeler
 
Texas WJ's Avatar
2005 WK 
 
Join Date: Mar 2006
Location: San Antonio
Posts: 2,039
Does the steering wheel click when you're turning?
__________________
255/75-17 BF Goodrich Mud Terrain TA KMs, 2" lift, JK Wrangler Moab wheels, Spidertrax Spacers, Rola Roof Rack.
Texas WJ is offline   Reply With Quote
Unread 09-10-2009, 01:12 PM   #3
cmassey_2006
Registered User
2006 WK 
 
Join Date: Apr 2006
Location: Georgia
Posts: 515
Do you mean when I have the turn signal on? Yes. With no turn signal on; no.
__________________
2006 White Jeep WK Limited 4x4: (current) 67K miles, 5.7L HEMI, auto, Quadra-drive II, factory tow hooks, hitch, skids, and many "bells and whistles"...

2007 Silver Jeep WK Laredo 4x4: (Sold) 10K miles, 3.7L V6, auto...

1998 Blue Jeep XJ 4x4: (Sold) @ 156K miles, I6, AW4 tranny, several mods...
cmassey_2006 is offline   Reply With Quote
Unread 09-10-2009, 02:17 PM   #4
NDSU_Bison
Registered User
2014 WK 
 
Join Date: Feb 2008
Location: Oregon
Posts: 655
I've found the horn on my 2008 to be finicky. I'm used to tapping the the horn with a thumb on my old Dodge while keeping my fingers around the wheel, but I really have to press hard unless I push in on the center of the steering wheel.
NDSU_Bison is offline   Reply With Quote
Unread 09-10-2009, 02:40 PM   #5
cmassey_2006
Registered User
2006 WK 
 
Join Date: Apr 2006
Location: Georgia
Posts: 515
Yeah, I've tried pushing the center of the steering wheel as hard as I could, but nothing happens. I used to own a 2007 WK, so I am familiar with how finicky the horn can be, but mine just doesn't seem to work at all!
__________________
2006 White Jeep WK Limited 4x4: (current) 67K miles, 5.7L HEMI, auto, Quadra-drive II, factory tow hooks, hitch, skids, and many "bells and whistles"...

2007 Silver Jeep WK Laredo 4x4: (Sold) 10K miles, 3.7L V6, auto...

1998 Blue Jeep XJ 4x4: (Sold) @ 156K miles, I6, AW4 tranny, several mods...
cmassey_2006 is offline   Reply With Quote
Unread 09-10-2009, 04:30 PM   #6
cmassey_2006
Registered User
2006 WK 
 
Join Date: Apr 2006
Location: Georgia
Posts: 515
It worked! Hmm...

Uh, gee, I feel really silly right now. On my way home from work, the car next to me started to veer into my lane and was getting too close for comfort, so I hit the horn and it worked! I actually scared myself because I didn't expect it to work (my natural reaction was to hit the horn). So now I'm not sure if the horn ever did not work or if I'm just crazy. I guess that explains why I couldn't find someone else with the same problem on here.

Sorry guys for wasting your time. And thank you to those who tried to help me fix a problem that may have never existed in the first place (or I was the problem). Please ignore.

-Chris
__________________
2006 White Jeep WK Limited 4x4: (current) 67K miles, 5.7L HEMI, auto, Quadra-drive II, factory tow hooks, hitch, skids, and many "bells and whistles"...

2007 Silver Jeep WK Laredo 4x4: (Sold) 10K miles, 3.7L V6, auto...

1998 Blue Jeep XJ 4x4: (Sold) @ 156K miles, I6, AW4 tranny, several mods...
cmassey_2006 is offline   Reply With Quote
Unread 09-11-2009, 08:32 AM   #7
thewalrus
Registered User
2005 WK 
 
Join Date: Jun 2009
Location: NoVa
Posts: 94
For some reason, the 2005-2006 have really deep buttons for the horn which mean you really have to force the plastic down to engage the switch. I actually like this better than say my Rav4 which the entire airbag assy. moves when you hit it for the horn, increasing the chance of accidentally setting off the horn, which I do frequently when parking.
__________________
-Thanks
ASE Master Tech
thewalrus is offline   Reply With Quote
Unread 01-06-2013, 06:16 PM   #8
t_w_m2003
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: scipio, IN
Posts: 1
Quote:
Originally Posted by Texas WJ View Post
Does the steering wheel click when you're turning?
yes mine does. when i bought the jeep it didnt have the horn relay in it, so the horn didnt work at all. i bought a relay and the horn works on the locking of doors and the panic. sometimes it also stays on. ive checked all fuses and even dug into the steering wheel to check the horn button. the button works fine, just not when its hooked up.
t_w_m2003 is offline   Reply With Quote
Unread 01-06-2013, 09:27 PM   #9
92JEEPWRANGLERY
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2009
Location: Chattanooga, Tennessee
Posts: 81
I had posted that same problem with my wife's 05. It will start blowing randomly for no reason. Even if you are not in the Jeep. It's not the alarm going off. It was suggested that it could be the clockspring but I don't know how to test that piece.
Thanks in advance for the help/suggestions.
92JEEPWRANGLERY is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.