high voltage o2 sensor/bad coolant sensor - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > high voltage o2 sensor/bad coolant sensor

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsDual Color LED Light Bars White/Amber

Reply
Unread 01-24-2010, 10:36 AM   #1
Jh24k
Registered User
1998 WJ 
 
Join Date: Jan 2010
Location: Mi
Posts: 3
high voltage o2 sensor/bad coolant sensor

I have a 98 grand cherokee 5.9. Recently my check engine light turned on. I had I checked. It said high voltage 02 sensor bank 1 sensor 1(been running choppy and flooding out or gas starved). So I decided to replace both since the truck has 200k on it. To my dismay it did not solve the problem(I did reset code). I also had bad coolant sensor reading on dash(changed and still did not remove error mess). Could the two issues have something to do with the other? Please help(would be greatly appreciated) before I decide to get medival on it.

sorry bout multiple post (new guy to any forum)

Jh24k is offline   Reply With Quote
Unread 07-19-2013, 10:22 AM   #2
diejeep
Registered User
2008 WK 
 
Join Date: Nov 2012
Location: georgetown, ontario/canada
Posts: 3
o2 sensors

hi did you unfasten your ground cable for about 10 mins after replacement?
diejeep is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.