high voltage o2 sensor/bad coolant sensor - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 01-24-2010, 10:36 AM Thread Starter
Jh24k
Registered User
1998 WJ 
 
Join Date: Jan 2010
Location: Mi
Posts: 3
high voltage o2 sensor/bad coolant sensor

I have a 98 grand cherokee 5.9. Recently my check engine light turned on. I had I checked. It said high voltage 02 sensor bank 1 sensor 1(been running choppy and flooding out or gas starved). So I decided to replace both since the truck has 200k on it. To my dismay it did not solve the problem(I did reset code). I also had bad coolant sensor reading on dash(changed and still did not remove error mess). Could the two issues have something to do with the other? Please help(would be greatly appreciated) before I decide to get medival on it.

sorry bout multiple post (new guy to any forum)

Jh24k is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-19-2013, 10:22 AM
diejeep
Registered User
2008 WK 
 
Join Date: Nov 2012
Location: georgetown
Posts: 3
o2 sensors

hi did you unfasten your ground cable for about 10 mins after replacement?
diejeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
hogh voltage 02 sensor/bad cool sensor Jh24k ZJ Grand Cherokee Forum 0 01-24-2010 10:33 AM
Crankshaft position sensor & coolant temperature sensor getting replaced in my 95 GC Keith1975 ZJ Grand Cherokee Forum 3 12-14-2006 03:52 PM
Error P0122: Throttle Position Sensor Voltage Low. TimeOut ZJ Grand Cherokee Forum 4 11-06-2005 08:28 AM
low coolant sensor bigben9664 ZJ Grand Cherokee Forum 2 08-25-2004 03:10 PM
coolant sensor ? gerbort ZJ Grand Cherokee Forum 1 07-21-2004 02:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome