Help, NAG1 Transmission Lead Frame Assembly code P2784 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Help, NAG1 Transmission Lead Frame Assembly code P2784

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits~Artec JK 1 TON SWAP~

Reply
Unread 08-27-2013, 04:48 PM   #1
bull_blaster
Registered User
2005 WK 
 
Join Date: Apr 2007
Location: Hillsboro, Oregon, USA
Posts: 287
Help, NAG1 Transmission Lead Frame Assembly code P2784

Hello Guys,

05 WK Grand Cherokee
Miles: 99789
3.7L V6 4x4 with NAG1 Transmission.

A few weeks ago my transmission made a loud pop and went into limp mode, stuck in 2nd or 3rd gear. If I stop and turn the jeep off and On, it drives normal for a few miles then does all again. Long story short, I thought It might be time for a fluid change. The dealer replaced the fluid and ran a TCM scan and pulled the following codes :

P0710 - Transmission Fluid Temperature Sensor Circuit
P0714 - Transmission Fluid Temperature Sensor Circuit Intermittent
P2784 - INPUT SPEED SENSOR 1/2 CORRELATION
P2769 - P2769 Torque Convertor Clutch Circuit Low
U11CB - ???? have no idea :'(

I was told I need to replace the Conductor plate which contains the Speed I/O sensor and the 6 other solenoids. However, the Mechanic said that he will transfer the old solenoids to the new plate which already comes with a built in speed sensor.... all for $800.00.

I Found an OEM Plate on Ebay for $190, I will be trying to do it my self, the only thing is, can I reuse the same fluid and filter since it was all replaced a couple of weeks ago? Anybody else done this before...Replacing Conductor plate? I know I will need to pull the whole Body Valve out :'(

Thank you

bull_blaster is offline   Reply With Quote
Unread 08-28-2013, 04:20 AM   #2
caulk04
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: Greenville, Pennsylvania
Posts: 854
So long as you use a clean drain pan and don't contaminate it with anything, the current fluid should be just fine. Filter is fine as well.
__________________
Tint, Superchips, SRT intake tube, Gibson catback, catch can. One hardcore DD/kid hauler...yeah.
caulk04 is offline   Reply With Quote
Unread 09-03-2014, 06:33 PM   #3
ksteve
Registered User
2009 WK 
 
Join Date: Feb 2014
Location: Kitchener, Ontario
Posts: 47
Hey,

Did changing the conductor plate end up solving your issues? I am having a very similar issue with my 09 3.7 WK and its making me go nuts. I have been troubleshooting all possibilities and this Conductor Plate seems to be the only last option. What ATF fluid did you recall topping it up with? How long of a job was this for your to do?
ksteve is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.