HELP! Loud whine, cant firgure it out - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 09-16-2015, 12:46 PM Thread Starter
Friendly_Cactus
Registered User
2008 WK 
 
Join Date: Aug 2015
Location: Burlington
Posts: 73
HELP! Loud whine, cant firgure it out

2008 HEMI Wk has a loud whine coming from the front of the engine. Already replaced the power steering pump. I suspect it's the water pump but that was replaced less than 50,000 miles ago. I'm at a loss to what it could be. Any help is appreciated.


2008 WK HEMI. JBA/OME/Bilstine Lift. 17x9 Addicts, 285/70r17 Duratracs
Friendly_Cactus is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 09-16-2015, 12:48 PM
duneslider
Registered User
2007 JK Wrangler 
 
Join Date: Jun 2013
Location: Riverton
Posts: 1,857
It could be the water pump again. I have had bad luck with part store pumps going bad early. I always get them from the dealer now, quality is better.
duneslider is offline  
post #3 of 7 Old 09-16-2015, 12:58 PM
monkey6
Registered User
2009 WK 
 
Join Date: Jan 2014
Location: Augusta
Posts: 42
If it is a high pitch noise almost like a supercharger, it could be the alternator. Happened to me twice.

2009 WK 3.7. 2" RC, 1.5" spacers, 265/70/17 BFG KM2's
monkey6 is offline  
post #4 of 7 Old 09-16-2015, 12:58 PM Thread Starter
Friendly_Cactus
Registered User
2008 WK 
 
Join Date: Aug 2015
Location: Burlington
Posts: 73
Thank you! I guess I'll pull that off and check it.

2008 WK HEMI. JBA/OME/Bilstine Lift. 17x9 Addicts, 285/70r17 Duratracs
Friendly_Cactus is offline  
post #5 of 7 Old 09-16-2015, 01:13 PM
whitejc4
Registered User
2006 WK 
 
Join Date: Apr 2012
Location: Spartanburg
Posts: 117
I agree with monkey... mine was the alternator.
whitejc4 is offline  
post #6 of 7 Old 09-16-2015, 05:13 PM Thread Starter
Friendly_Cactus
Registered User
2008 WK 
 
Join Date: Aug 2015
Location: Burlington
Posts: 73
My alternator has almost 200,000 miles. So that sounds like it could be whats causing the whining.

2008 WK HEMI. JBA/OME/Bilstine Lift. 17x9 Addicts, 285/70r17 Duratracs
Friendly_Cactus is offline  
post #7 of 7 Old 09-16-2015, 05:44 PM
sheepdog918
Registered User
2007 WK 
 
Join Date: May 2014
Location: Russell Springs
Posts: 801
If it's whining in harmony with the rpm's it is almost certainly the alternator. Mine when out at 115k miles so if you achieved 200k bravo lol

There are the wolves, there are the sheep, but then, there are the Sheepdog's
sheepdog918 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome