Help Cruise control won't work - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Help Cruise control won't work

Attention to the TJ owners 1996-2006 NEW LED LIGHT OPTIONSOPTIC ARMOR WINDOWS all sale now !!!!!!!!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 04-05-2012, 07:57 PM   #1
72cj5er
Registered User
1972 CJ5 
 
Join Date: Aug 2004
Location: Hampton,Tn
Posts: 573
Help Cruise control won't work

My cruise control on our 2006 Grand will come on when you press the on/off switch on the steering wheel, however, as soon as you press "set" it goes off and won't come on again until you have shut the Jeep off and restart it.

You can have the thing on forever, longest I went was 10 miles before pressing set when the cruise dash light simply turns off and you can't get it to turn back on without a power cycle.

No idea, Ive checked all connections, tried the key trick to get codes, won't work either, and all vacuum hoses are accounted for. I tried getting auto zone to pull the codes but they said their scanner only pulls codes when the engine light is on, which it isn't on.

Im at a loss, everything works great BUT this and its confused me big time.

__________________
72 CJ5 Renegade
86 MJ Pickup W/Tilt bed
94 YJ Wrangler
04 LJ Unlimited Wrangler
never far from a good trail http://scott.arrington-family.us
Growing old is mandatory; growing up is optional!!
72cj5er is offline   Reply With Quote
Unread 04-05-2012, 09:08 PM   #2
Beezy03
Registered User
2006 WK 
 
Join Date: Apr 2012
Location: pueblo, co
Posts: 1
Had this happen in our 06 WK and it ended up being the steering wheel control module. $1100 later and its works great. Might also try replacing the actual switches first, Have herd that is a common problem as well.
Beezy03 is offline   Reply With Quote
Unread 04-06-2012, 03:45 AM   #3
lbdyll
Registered User
2006 WK 
 
Join Date: May 2008
Location: Mountain Home, ID
Posts: 191
My 06 actually turned out to be the brake switch. Pretty cheap and easy to change.
__________________
2006 Jeep Grand Cherokee Laredo 2" RC lift, 245/75/17 Goodyear Authority, 1.25" Wheel Spacers, Home-made Grill, Custom Scratchs and dents
lbdyll is offline   Reply With Quote
Unread 05-13-2012, 02:30 AM   #4
justinmiller930
Registered User
2005 WK 
 
Join Date: May 2011
Location: Brookville, PA
Posts: 247
I've been having this same problem and have no idea what is going on with it. When I press the on/off on the steering wheel, the indicator shows that it is activated, but when I press set, most of the time nothing happens. Then all of the sudden it will work. Since this problem is intermittent it is hard to diagnose. This has been going on for quite sometime. I took it to the dealership where I bought it and let them know about. I told them about what has been going on. They looked at it and discovered that the cancellation wire was corroded, so they replaced it.

The dealership claimed that they fixed it, but it still keeps doing this same problem that it did before. Not sure what is going on.

Any help with this same issue would be greatly appreciated.
justinmiller930 is offline   Reply With Quote
Unread 05-13-2012, 06:25 AM   #5
croth
Registered User
2005 WK 
 
Join Date: Mar 2012
Location: Fillmore, New York
Posts: 150
Clock spring behind the steering wheel? Just a thought!
__________________
Craig
croth is offline   Reply With Quote
Unread 05-13-2012, 08:45 AM   #6
modernblueWK
Registered User
 
Join Date: Jan 2010
Location: Gunnison, CO
Posts: 1,676
The actual stalk /switch went bad on mine. It would work intermittent then stopped working alltogether.
__________________
2008 wk 4.7 v8 Laredo X QTII - 245/70-17 at2 - Magnflow 13742
Blue WK club #4
2013 HEMI Durango Awd Crew. All stock
modernblueWK is offline   Reply With Quote
Unread 05-13-2012, 11:04 AM   #7
72cj5er
Registered User
1972 CJ5 
 
Join Date: Aug 2004
Location: Hampton,Tn
Posts: 573
Is the cancellation wire something we can check and see? I'm open to try anything now
__________________
72 CJ5 Renegade
86 MJ Pickup W/Tilt bed
94 YJ Wrangler
04 LJ Unlimited Wrangler
never far from a good trail http://scott.arrington-family.us
Growing old is mandatory; growing up is optional!!
72cj5er is offline   Reply With Quote
Unread 05-13-2012, 12:23 PM   #8
mykdee311
Registered User
2005 WK 
 
Join Date: Sep 2011
Location: Salt Lake City, Utah
Posts: 158
On other vehicles I've had similar issues, been solved a few times by replacing a fuse. This may not apply on our jeeps.
__________________
05 WK Limited, QDII, Hemi, Superchip, OME HD Lift, JBA UCA & disconnects, 4xGuard (Belly, Sliders, Rear Sliders, Diff), 255/75R17 on Moab's w/ 1.5" Spacer, Thule M.O.A.B. Basket
03 3500 Cummins, 79 Mustang 2.5T Stroker, 63 F250 428 4x4
mykdee311 is offline   Reply With Quote
Unread 05-13-2012, 03:35 PM   #9
w1pf
Who, me?
 
w1pf's Avatar
2007 WK 
 
Join Date: Aug 2008
Location: Amherst, MA
Posts: 754
Also make sure your 'cancel' button isn't sticking.

Mine does, and if I don't notice it the cruise control does all kinds of wonky things (generally requiring a key-off-key-on to reset).
__________________
2014 WK2 Overland 5.9L
2007 WK Limited 5.7L
And some past Durangos
Red WK #19, Hemi #68.. I think..
Durango Owners Club DOTY 2011
-------
"Must have been that yesterday was the day that I was born"
w1pf is offline   Reply With Quote
Unread 08-17-2012, 07:19 PM   #10
AlsJeep1
Registered User
 
Join Date: Sep 2009
Location: Raleigh
Posts: 14
72cj5er, you ever find a fix? Mine is doing the same exact thing!
AlsJeep1 is offline   Reply With Quote
Unread 08-18-2012, 12:55 AM   #11
lbdyll
Registered User
2006 WK 
 
Join Date: May 2008
Location: Mountain Home, ID
Posts: 191
Like I said in my previous post try the brake light switch. Mine did the exact same thing as the op's. Cheap and easy fix.
__________________
2006 Jeep Grand Cherokee Laredo 2" RC lift, 245/75/17 Goodyear Authority, 1.25" Wheel Spacers, Home-made Grill, Custom Scratchs and dents
lbdyll is offline   Reply With Quote
Unread 08-18-2012, 03:42 PM   #12
justinmiller930
Registered User
2005 WK 
 
Join Date: May 2011
Location: Brookville, PA
Posts: 247
I was having the same exact problem with mine. It would show on the dash that it was working, but wouldn't set.

The dealership said that the cancellation wire was corroded and was most likely the root of the problem.

Needless to say, it didn't fix the problem. I haven't had any problems with it lately, but haven't been using it that much.
justinmiller930 is offline   Reply With Quote
Unread 12-07-2013, 12:15 AM   #13
justinmiller930
Registered User
2005 WK 
 
Join Date: May 2011
Location: Brookville, PA
Posts: 247
I'm having the same problem as before (again). Still not sure what's going on. It quit, and now a year later, it's doing it again.
It's only doing it intermittently.
justinmiller930 is offline   Reply With Quote
Unread 12-30-2013, 01:28 PM   #14
AlsJeep1
Registered User
 
Join Date: Sep 2009
Location: Raleigh
Posts: 14
I replaced the brake light switch, didn't do anything to help mine.
__________________
1984 Cherokee
1886 CJ-7
2004 Wrangler
2006 Grand Cherokee
AlsJeep1 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.