H.I.D. issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 01-07-2013, 12:39 PM Thread Starter
adamf12
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: Milledgeville
Posts: 29
H.I.D. issue

so i put hid's in my cherokee and the fog lights work great. however the head lights didn't. they fire up just fine but when i turn the lights off they turn into strobe lights for about a minute or so. I thought it was a bad kit so i had the company send me another one. only this one does it too. so now i am thinking it has something to do with the vehicle. anyone know whats going on or have solution?

adamf12 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 01-07-2013, 01:56 PM
IowaJeepNewbie
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: Cedar Rapdis
Posts: 81
Have you contacted the company about this issue? What about googling it?

2005 Jeep Grand Cherokee Laredo, Red WK Club #31, Daystar 2" BB lift with bilstein struts. Rigid LED Dually
IowaJeepNewbie is offline  
post #3 of 8 Old 01-07-2013, 02:03 PM Thread Starter
adamf12
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: Milledgeville
Posts: 29
Yes. Company has not sent a response and all I have found through google were questions and complaints about the same thing but no answers. I was hoping someone here has experienced the same and was able to come up with a solution

2005 Grand Cherokee Limited, 5.7L 4x4
adamf12 is offline  
post #4 of 8 Old 01-07-2013, 02:29 PM
jeffjs
Registered User
 
Join Date: Apr 2008
Posts: 131
Relay

Google HID relay kit. Sounds like you need one.
jeffjs is offline  
post #5 of 8 Old 01-07-2013, 10:32 PM
thedude411
Registered User
2008 WK 
 
Join Date: Oct 2012
Location: Canmore
Posts: 73
Deleted post
thedude411 is offline  
post #6 of 8 Old 01-07-2013, 10:33 PM
thedude411
Registered User
2008 WK 
 
Join Date: Oct 2012
Location: Canmore
Posts: 73
Deleted post
thedude411 is offline  
post #7 of 8 Old 01-07-2013, 10:42 PM
Houston910
Registered User
 
Join Date: Jun 2012
Location: Rockingham
Posts: 16
I agree with Jeff. Sounds like you need a relay for your HID's
Houston910 is offline  
post #8 of 8 Old 01-08-2013, 10:04 AM Thread Starter
adamf12
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: Milledgeville
Posts: 29
I have ordered a relay kit and will let yall know how it turns out!

2005 Grand Cherokee Limited, 5.7L 4x4
adamf12 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome