Grand Cherokee CRD Start Issue - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Grand Cherokee CRD Start Issue

Dan's Old as Dirt Birthday Sale!GEARSHADE Pocket Tops in stock and available at ROCKRIDGE Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 03-12-2013, 02:12 PM   #16
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,809
Quote:
Originally Posted by Radcrd View Post
I went with the cheap Everstart Maxx H8 battery from Walmart for $117 CDN. And has been great so far. Only been 4 months however but started fine at almost 30 below not plugged.

More info here: http://www.jeepforum.com/forum/f67/w...temps-1437118/
I bought this battery on Friday. My battery kept losing charge after a few days. This new battery seems very good in our CRDs.

__________________
2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline   Reply With Quote
Unread 10-17-2013, 12:55 PM   #17
r_unda
Member
 
r_unda's Avatar
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Corpus Christi, TX
Posts: 347
I bought the Everstart Maxx H8 yesterday. Received a Walmart gift card for $100 yesterday and the battery only cost $120 so it was a no brainer for me.

I believe the old battery was original unless previous owner replaced it with a Mopar battery. If original it lasted a little over 100,000 miles. Actually it was still cranking just taking a little longer in the morning to start and for some reason this week the service 4wd message was poping up during cold cranks (the real reason I desided to get a new battery since I knew it was related). Oh and good thing I replace it because the battery had a small hole next to the negative terminal.

Anyways the WK starts right up with new battery and no service 4wd message. So far so good. We will see how long this one last.
__________________
My Jeep isn't getting older, it's getting newer part by part

2011 WK2 HEMI 4x4 Overland
2007 WK CRD 4x4 Limited GDE Tuned
1998 TJ SE
1973 CJ5 - YJ OME 2.5" lift, 33" tires
1951 Willys truck
r_unda is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.