glow plug issue not solved - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 10-02-2008, 08:16 AM Thread Starter
roadman
Registered User
 
Join Date: Apr 2008
Location: Garland
Posts: 129
glow plug issue not solved

Dealer replaced one glow plug, then next day check engine light comes on again (today). Have to bring the jeep back in tomorrow, said it was pulling the same code again, so they think something else is wrong other than the glow plug.


2007 WK Limited CRD Quadra-Drive II

Μολὼν λάβε
roadman is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 10-02-2008, 10:42 AM
merlinTec
Registered User
 
merlinTec's Avatar
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
The fault will clear and not come back up again till they are used hence the next day. With star scan you can actuate the plugs and if there is a fault it will *** back up. I wouldn't be suprized if it has failed another plug or infact they replaced the incorrect one as the plugs run 1 to 3 on the right 4 to 6 left not 1 3 5 right 2 4 6 left like petrols.
Regards,
Merlin

UK Chrysler Jeep Master Tec.
merlinTec is offline  
post #3 of 9 Old 10-02-2008, 11:33 AM Thread Starter
roadman
Registered User
 
Join Date: Apr 2008
Location: Garland
Posts: 129
Thanks, Merlin.
I'll let them know.

2007 WK Limited CRD Quadra-Drive II

Μολὼν λάβε
roadman is offline  
post #4 of 9 Old 10-03-2008, 11:29 AM Thread Starter
roadman
Registered User
 
Join Date: Apr 2008
Location: Garland
Posts: 129
Brought it in this morning, that was the first thing the tec thought was he replaced the wrong plug, but they checked it and he did replace the correct one. They think it might be a bad sensor or wiring.

2007 WK Limited CRD Quadra-Drive II

Μολὼν λάβε
roadman is offline  
post #5 of 9 Old 10-03-2008, 02:35 PM Thread Starter
roadman
Registered User
 
Join Date: Apr 2008
Location: Garland
Posts: 129
Glow Plug module was out. New one ordered. Will be in next week.

2007 WK Limited CRD Quadra-Drive II

Μολὼν λάβε
roadman is offline  
post #6 of 9 Old 10-08-2008, 09:27 PM Thread Starter
roadman
Registered User
 
Join Date: Apr 2008
Location: Garland
Posts: 129
Well,they put in the module and drove it and the light went out. They then washed the truck and the light came back on. Pulled the same code. They have checked all the wiring and it works. Still showing the same plug. They are going to go over it again tomorrow.

2007 WK Limited CRD Quadra-Drive II

Μολὼν λάβε
roadman is offline  
post #7 of 9 Old 10-09-2008, 01:27 PM Thread Starter
roadman
Registered User
 
Join Date: Apr 2008
Location: Garland
Posts: 129
OK, this is funny. The new plug they put in was shot.
He ordered a case this time.

2007 WK Limited CRD Quadra-Drive II

Μολὼν λάβε
roadman is offline  
post #8 of 9 Old 10-09-2008, 03:30 PM
merlinTec
Registered User
 
merlinTec's Avatar
 
Join Date: Jul 2007
Location: England
Posts: 2,944
lol
Now was it shot or did he change the wrong one?

UK Chrysler Jeep Master Tec.
merlinTec is offline  
post #9 of 9 Old 10-09-2008, 03:58 PM Thread Starter
roadman
Registered User
 
Join Date: Apr 2008
Location: Garland
Posts: 129
no, the new one was shot. believe me, they have really checked out this truck.

2007 WK Limited CRD Quadra-Drive II

Μολὼν λάβε
roadman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Glow Plug life roadman WK Grand Cherokee & XK Commander Forum 59 03-24-2016 11:17 PM
CRD #6 Glow Plug Circuit Error tallguy6464 WK Grand Cherokee & XK Commander Forum 26 01-07-2014 04:26 PM
why canīt find glow/reverse glow gauges overlays for 2000 GC ? eschapiro ZJ Grand Cherokee Forum 0 02-14-2007 01:32 PM
Glow gauges Guumba ZJ Grand Cherokee Forum 15 01-24-2005 06:36 AM
Glow Guages snipr22 ZJ Grand Cherokee Forum 4 10-21-2004 02:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome