Glow Plug - JeepForum.com

 
LinkBack Thread Tools
post #1 of 14 Old 10-11-2014, 09:37 PM Thread Starter
Zbigniew1954
Registered User
 
Join Date: Nov 2013
Location: Port Coquitlam
Posts: 5
Glow Plug

Hi Jeep CRD Guys,

Does anyone have an experience with a broken glow plug?
As this coming winter will be for me the first winter with my new 2008 Jeep Grand Cherokee 3.0 CRD, I wanted to check itís glow plugs before temperatures drop. I wasnít getting any OBD Trouble Cods yet but I wanted to check their resistance (Ohm) and make sure that I know how and that I can get each plug easily out. Better to be prepared now than to fight with them in winter conditions. I was able to get five glow plugs out, check their resistance and, after applying an anti-seize compound, put them back. Except the one. I tried everything: I flooded it with WD-40, left overnight, wormed up the engine, tried gently counter-clockwise and clockwise, back and forth, tapping at the same time. And at one moment it let go. But after one turn I realized that something went terribly wrong. The glow plug was turning but not coming out. I was trying gently to tighten it back. It turned but wasnít getting tight.

Has anyone had that experience?
The engine starts and runs normally. OBD reader does not give any Trouble Cods. So I assume that I didnít break the plug itself, as it is electronically OK. Am I correct assuming that I stripped a thread in a glow plug opening? If so, has anyone any suggestions how to deal with that?

Zbigniew

Zbigniew1954 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 10-11-2014, 11:20 PM
safe+fit
Registered User
 
Join Date: May 2014
Posts: 115
I also have recently done exactly as you described. I changed out the bad control module and bought all six plugs in case any failed. After the module swap number two gave a code and I replaced it easily. No more codes but I had the other five plugs and lacked time to do them. So they sat until I had the time, and eventually I did right before a long trip. Well Number five and six were stuck like you said yours were and here we are in the same boat. I am asking all sorts of people and old mechanics for advice and I will sure let you know anything I find.
safe+fit is offline  
post #3 of 14 Old 10-12-2014, 12:11 PM
TurboDiesel
Registered User
2008 WK 
 
Join Date: Apr 2011
Location: langley
Posts: 2,382
looks like u need a kit like this
http://www.ebay.ca/itm/Damaged-Glow-...item3f3cef68e6


scary hahaha
now i dont wanna do mine if i ever need too lol

2008 CRD // GDE Eco // DPF delete // 3" intercooler // OME HD // 265 dirtytracs etc.
TurboDiesel is offline  
 
post #4 of 14 Old 10-12-2014, 01:21 PM
BAH101
Registered User
2008 WK 
 
Join Date: Jan 2009
Location: Thunder Bay
Posts: 889
You live in Po-Co, it never gets cold there!

2008 CRD QDII, OME HD, Pintlers wheels with 265/70/17 Goodyear Silent Armour's, Jeepinbyal UCA's. 4XGuard Front guard, Side Guard, belly guard, Matrix HC. GDE ECO Tune w/ delete.
BAH101 is offline  
post #5 of 14 Old 10-12-2014, 04:39 PM
TurboDiesel
Registered User
2008 WK 
 
Join Date: Apr 2011
Location: langley
Posts: 2,382
unless he lives in Burke Mountain LOL then its probably snowing there right now

2008 CRD // GDE Eco // DPF delete // 3" intercooler // OME HD // 265 dirtytracs etc.
TurboDiesel is offline  
post #6 of 14 Old 10-12-2014, 09:33 PM
Drudgery1971
Registered User
2007 WK 
 
Join Date: Mar 2009
Location: Ohio
Posts: 436
Just want to make one comment, I have owned my 07 CRD since early 09 and have 116k miles on it since and people buying all 6 glow plugs are wasting their money because I have had 3 go out over 5 years and the others are all still fine and they are not in short supply or back ordered like other parts. Some say once one goes they all go or the control module and that is contrary to what I have experienced. Just saying. Sorry about your strip out issue OP out or break off. Mine have all come out remarkably easy. Knock on wood.

2007 WK Limited 3.0 CRD - Stock (Mine)
2010 XK Sport 5.7 Hemi - Stock (Wife)
Drudgery1971 is offline  
post #7 of 14 Old 10-13-2014, 06:31 AM
chrali
Registered User
2006 XK Commander 
 
Join Date: Jul 2012
Location: Great Yarmouth
Posts: 302
I totally agree! My glow module has always thrown a code from about 20,000 miles ago and only glow plug number 5 needed replacing about 10,000 miles ago.

Sent from my C6833 using JeepForum

Encourage alternative fuels - use all the petrol!
GDE HOT Tune
chrali is offline  
post #8 of 14 Old 10-13-2014, 07:48 AM
BAH101
Registered User
2008 WK 
 
Join Date: Jan 2009
Location: Thunder Bay
Posts: 889
110000 miles so far, haven't had to change a plug yet.

2008 CRD QDII, OME HD, Pintlers wheels with 265/70/17 Goodyear Silent Armour's, Jeepinbyal UCA's. 4XGuard Front guard, Side Guard, belly guard, Matrix HC. GDE ECO Tune w/ delete.
BAH101 is offline  
post #9 of 14 Old 10-14-2014, 06:12 PM
TurboDiesel
Registered User
2008 WK 
 
Join Date: Apr 2011
Location: langley
Posts: 2,382
97000 miles and i personally havent in the 3.5 years ive owned it

that being said i bough 6 as a just in case lol
seems to take alittle extra to start in the mornings so id rather just be safe

2008 CRD // GDE Eco // DPF delete // 3" intercooler // OME HD // 265 dirtytracs etc.
TurboDiesel is offline  
post #10 of 14 Old 12-28-2014, 12:57 PM
Tuco
Registered User
 
Tuco's Avatar
2007 WK 
 
Join Date: May 2007
Location: Pacific Northwest
Posts: 550
Im in the same boat here. #5 is really tight. I dont think I have broke it yet. Any suggegstions? Would it be better to do this in warm weather or with engine warm? Penetrating oil? Its starting ok with 5 working so Im fine waiting if needed.

07 WK CRD Limited
Tuco is offline  
post #11 of 14 Old 12-28-2014, 01:49 PM
Tuco
Registered User
 
Tuco's Avatar
2007 WK 
 
Join Date: May 2007
Location: Pacific Northwest
Posts: 550
never mind, I found the thread with instructions. Hoping I dont break one!

1. Heat up engine
2. apply pb blaster or equiv. wait several minutes (Im going to run jeep and let sit for a day)
3. with engine warm try to remove, do not exceed 20 ft lbs, repeat steps.

07 WK CRD Limited
Tuco is offline  
post #12 of 14 Old 12-28-2014, 02:09 PM
TurboDiesel
Registered User
2008 WK 
 
Join Date: Apr 2011
Location: langley
Posts: 2,382
its 20nm of force, 14.7 ft/lbs i believe

2008 CRD // GDE Eco // DPF delete // 3" intercooler // OME HD // 265 dirtytracs etc.
TurboDiesel is offline  
post #13 of 14 Old 12-28-2014, 06:36 PM
mathetes
Registered User
2007 WK 
 
Join Date: Feb 2013
Location: Benton
Posts: 57
I had # 1, 4, & 5 go out with a little over 100,000 miles. So I did then replace the rest of them - guilty

cgkoon
2007 WK 3.0L CRD, Quadradrive II, GDE EcoTune, DPF-Delete,
EHM MOD,
mathetes is offline  
post #14 of 14 Old 03-20-2017, 09:18 PM
RixCRD
Registered User
 
Join Date: Jul 2016
Location: Newport, RI
Posts: 16
Hi all.
Sorry to resurrect an old thread, but it looks like I stripped out one of my glow plug sockets on my '07 WK CRD.

Anyone have the numbers for the repair kits and instructions?

'07 WK Limited CRD
GDE ECO Tune
241 HP, 440 TQ, 23.5 average mpg
RixCRD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome