GC replaced water pump - now over heating... please help! I'm clueless - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 10-22-2011, 04:16 PM Thread Starter
karillian
Registered User
2005 WK 
 
Join Date: Oct 2011
Location: Fresno
Posts: 2
GC replaced water pump - now over heating... please help! I'm clueless

So yesterday...
It sounded like my belt went... then I pulled over and steam started spewing out. Radiator fluid leaking (pouring) everywhere.
I had a mech look at it, they said it was the water pump... it looked like it to me, but I know nothing about engines. SO, he replaced the pump today. He let it run to get it to burp, for a LONG time. It seemed like it didn't want to, so he drained everything again, added the coolant and water, let it run. Said it was good. I drove it 2 blocks and my temp gauge went to H, it said over heating on my readings, I tried to turn on the heater to pull heat away and my heater wouldn't get hot. So it sounds like there's air blocking or something. So... is it that little screw in the line that needs to be loosened to air out?? Nothing else seemed to work. Please help me!! Thank you!!

karillian is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 10-22-2011, 06:05 PM
06WKLaredo
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: Ypsilanti
Posts: 45
Hope it's not a blown head gasket...
06WKLaredo is offline  
post #3 of 7 Old 10-22-2011, 06:14 PM
brenden15s
Registered User
2005 WK 
 
Join Date: Dec 2009
Location: Harvest, AL
Posts: 108
Yes its that little screw take it out and use a funnel to pour coolant in there it will vent air and pull in coolant needed

R.I.P. CW3 Windorski, CW2 Tillery, CW2 Kelley, and CW2 Todd. KIA 25 January 2009 CW3 White and CW2 Gaudet. KIA 5 June 2011. See you on the green... AIR CAV!
brenden15s is offline  
post #4 of 7 Old 10-23-2011, 12:35 AM Thread Starter
karillian
Registered User
2005 WK 
 
Join Date: Oct 2011
Location: Fresno
Posts: 2
Thanks... Ill try that tomorrow
karillian is offline  
post #5 of 7 Old 12-24-2011, 08:44 AM
jmolli
Registered User
 
Join Date: Aug 2005
Location: New Jersey
Posts: 15
Quote:
Originally Posted by karillian View Post
Thanks... Ill try that tomorrow
Replaced the water pump at 70,000 miles on my 2005 3.7L WK. It had a diesil like sound at idle, it was the bearings failing on the pump. I could shake the pulley easily with my hands. The job is very easy, only took 1.5 hours. Be sure to remove the vent plug where the upper radiator hose goes into the front engine cover and fill the block SLOWLY through the upper hose until you get fluid out of the plug hole.

If you don't do this, you will overheat due to no water in the block. Not a good thing!

P.S. Find yourself a new mechanic!
jmolli is offline  
post #6 of 7 Old 12-24-2011, 09:11 AM
brentwoodkris
Registered User
2005 WK 
 
Join Date: Jun 2009
Location: Columbia
Posts: 179
Hopefully he put the thermostat in the right way around...
brentwoodkris is offline  
post #7 of 7 Old 12-26-2011, 12:20 PM
BlueSteelJP
Registered User
2005 WK 
 
Join Date: Apr 2009
Location: Maine
Posts: 272
Also check the radiater isn't plugged at the bottom because of debree from gaskety material etc.

Blue WK Club Member #10


2005 Jeep Grand Cherokee Limited, 5.7 Liter Hemi no Mods So Far.
BlueSteelJP is offline  
Reply

Tags
laredo , overheating , radiator help needed , water pump failure

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
water pump + power steering pump z rated ZJ Grand Cherokee Forum 3 09-16-2014 05:50 AM
Replaced water pump- still leaking coolant Blaze45 ZJ Grand Cherokee Forum 7 08-26-2011 02:36 PM
zj over heating after instaling high flow watter pump and thermostat and radiator dlvsdh ZJ Grand Cherokee Forum 12 12-21-2010 12:33 PM
cooling system problems , water pump and thermostat replaced . no heat. natesxj ZJ Grand Cherokee Forum 4 10-25-2009 09:49 AM
Replaced water pump but still leaking flyboy14295 ZJ Grand Cherokee Forum 6 10-15-2008 07:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome