Funky head light problem... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 04-25-2012, 02:31 AM Thread Starter
talkboxier
Registered User
2006 WK 
 
Join Date: Apr 2012
Location: Kailua-Kona
Posts: 16
Funky head light problem...

I have had this headlight problem for a couple weeks now and its driving me crazy. Let me try and describe some of the symptoms I am having.

My right head light seems to flicker on and off while driving my car. Sometimes it stays on and sometimes its just stays off. When it goes off, the whole light assembly stops working. I don't have the side makers, turn signal, or highs. everything is out.

A couple other scenarios are: the headlight comes on but the blinker doesn't work, when I unlock my doors only the side marker and turn signal comes on, or the whole assembly comes on but it is really dim....

So I thought it was a connectivity issue or a fuse. Tried pulling fuses to see if any lights came off, got nothing. Don't know if I was looking in the right places. Went to check the voltage supply to the lights with my multimeter. So I put the ground probe to the ground on the headlight connector, and the positive to the positive, but nothing. So I tried to put the ground probe on the engine, and got 12 volts from the positive. So I thought that was strange. So then, for some reason, I put the positive probe on the ground on the light connector, and IT ALSO WAS 12 VOLTS!!! is this normal?

Has anyone got any advice for this problem?

This is for a 2006 WK Grand Cherokee Laredo

talkboxier is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 04-25-2012, 06:14 AM
TurboDiesel
Registered User
2008 WK 
 
Join Date: Apr 2011
Location: langley
Posts: 2,236
maybe its the whole light wand that comes off the steering column?

2008 CRD // GDE Eco // DPF delete // 3" intercooler // OME HD // 265 dirtytracs etc.
TurboDiesel is offline  
post #3 of 7 Old 04-26-2012, 12:21 AM Thread Starter
talkboxier
Registered User
2006 WK 
 
Join Date: Apr 2012
Location: Kailua-Kona
Posts: 16
Ok, so I messed around with some wires and some fuses, still got nothing. The only thing that seemed to make the assembly light up again is by pounding on the side marker light. Any ideas?
talkboxier is offline  
post #4 of 7 Old 04-26-2012, 01:16 AM
kllshadow
Registered User
2006 WK 
 
Join Date: May 2011
Location: Altoona
Posts: 366
sounds like a wiring problem or bad bulb ballast

Black WK Club Member #61
kllshadow is offline  
post #5 of 7 Old 04-26-2012, 02:49 AM Thread Starter
talkboxier
Registered User
2006 WK 
 
Join Date: Apr 2012
Location: Kailua-Kona
Posts: 16
Well just took the light assembly apart. checked all the wiring on the assembly itself. everything checks out fine. Now I am thinking it might be the light switch... but where could I find the light ballast?
talkboxier is offline  
post #6 of 7 Old 04-28-2012, 01:52 AM Thread Starter
talkboxier
Registered User
2006 WK 
 
Join Date: Apr 2012
Location: Kailua-Kona
Posts: 16
Quick update, found out what the problem was. It was a bad ground. All cleared up now.
.
talkboxier is offline  
post #7 of 7 Old 04-18-2013, 12:33 PM
cwinse
Registered User
 
Join Date: Nov 2007
Location: townsend, De
Posts: 1
bad ground?

i have almost the same problem except mine is passenger side and headlights are out all the time, tho the park light does come on once in a while. did some quick checking online and thought it was the front control module as it controls both power and ground, but that stupid thing is $484 from my local dealer. where did you find this "bad" ground located within the vehicle?
cwinse is offline  
Reply

Tags
2006 , cherokee , grand , laredo , light

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
No driver's side tail light, brake light or blinker when head lights on LuauFish WK Grand Cherokee & XK Commander Forum 2 07-02-2011 08:01 AM
Funky Steering problem! MyZJ98 ZJ Grand Cherokee Forum 0 05-11-2011 07:04 AM
head light problem Irish_Assassin ZJ Grand Cherokee Forum 8 03-23-2010 12:29 AM
head light problem... need help pacman13 WK Grand Cherokee & XK Commander Forum 0 12-30-2009 09:51 AM
Problem with the wheel staus lights on dash and head light switch problem jeep2dmax ZJ Grand Cherokee Forum 0 12-21-2007 07:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome