post #1 of Old 02-07-2014, 05:21 PM Thread Starter
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
Fuel Level sensor reads low

Hey Guys,
My fuel sensor reads about an eighth of a tank low even though the tank is full. My guess its going bad (or dirty) Has anyone changed it or found any cleaner to put in the gas tank to (clean) fix the problem?? I know it is attached to the fuel pump and probably can not be changed on its own. Where did you get a new one at a good price?





Thanks!!


Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
post #2 of Old 02-13-2014, 12:28 PM Thread Starter
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
Bump

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
post #3 of Old 02-14-2014, 02:32 PM Thread Starter
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
Bump

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
post #4 of Old 02-16-2014, 07:48 AM
10Xk
Registered User
2014 WK 
 
Join Date: Apr 2012
Posts: 1,092
Quote:
Originally Posted by tom19511
Hey Guys, My fuel sensor reads about an eighth of a tank low even though the tank is full. My guess its going bad (or dirty) Has anyone changed it or found any cleaner to put in the gas tank to (clean) fix the problem?? I know it is attached to the fuel pump and probably can not be changed on its own. Where did you get a new one at a good price? Thanks!!
What engine? Chevron fuel system cleaner with techron
10Xk is offline  
post #5 of Old 02-16-2014, 12:20 PM Thread Starter
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
3.7 So, that will maybe fix it?
THX

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
post #6 of Old 02-16-2014, 02:57 PM
mattWK
Registered User
2007 WK 
 
Join Date: Oct 2012
Location: Minneapolis
Posts: 68
Quote:
Originally Posted by 10Xk View Post
What engine? Chevron fuel system cleaner with techron
I've used this 3 times and it's worked like a charm.

Advance Auto Parts has 2 for $10 at the moment.
mattWK is offline  
post #7 of Old 02-16-2014, 03:47 PM
james_2k
Registered User
2003 WJ 
 
Join Date: Feb 2013
Location: Aberfoyle
Posts: 852
could also use premium gas for a while too. (over in the uk at least) it has a much better detergent package
james_2k is offline  
post #8 of Old 02-16-2014, 04:19 PM
10Xk
Registered User
2014 WK 
 
Join Date: Apr 2012
Posts: 1,092
Quote:
Originally Posted by tom19511
3.7 So, that will maybe fix it? THX
It will fix it if there are deposits on the sending unit. I believe some manufactures state to use it in TSB's to correct this problem.
10Xk is offline  
post #9 of Old 02-16-2014, 04:52 PM Thread Starter
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
great, I will try it tomorrow..

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
post #10 of Old 02-17-2014, 11:22 AM Thread Starter
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
Put it in today. Will update when I know something happens.. Thanks!!

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
post #11 of Old 03-28-2014, 06:45 PM Thread Starter
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
Tried Chevron fuel system cleaner with techro. Still reas low by 1/8th tank

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
post #12 of Old 05-26-2014, 10:39 AM Thread Starter
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
any one else?

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
post #13 of Old 09-28-2014, 11:37 AM Thread Starter
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
bump

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome