Front R/H Wheel Speed Sensor always stuffs up - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Front R/H Wheel Speed Sensor always stuffs up

ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail Lights

Reply
Unread 11-06-2014, 02:40 PM   #1
multihulls
Registered User
2006 XK Commander 
 
Join Date: Feb 2009
Location: Brisbane, Queensland
Posts: 24
Front R/H Wheel Speed Sensor always stuffs up

I keep on getting a fault with my R/H front wheel speed sensor (WSS). I have the standard fault code come up along with the Dash warning lights and the brake pedal does the usual rattle noise and pedal pump. I then change the sensor and then all is good for about 6 months and then it happens again. I had replaced my front wheel bearing for some Chinese ones and though this was the issue so I bought original Mopar bearing and sensors and guess what the problem is back again after 6 months.
Is there's a central WSS module that may be at fault?
Or any other item that could be making the R/H sensor stuff up?

multihulls is offline   Reply With Quote Quick reply to this message
Unread 11-08-2014, 02:21 PM   #2
multihulls
Registered User
2006 XK Commander 
 
Join Date: Feb 2009
Location: Brisbane, Queensland
Posts: 24
Bump, any answers to this problem? I could just change the sensor again but I'll be back doing it again in 6 months so I'd like to find the route of the problem.
Any help or thoughts please.
multihulls is offline   Reply With Quote Quick reply to this message
Unread 11-16-2014, 05:55 AM   #3
multihulls
Registered User
2006 XK Commander 
 
Join Date: Feb 2009
Location: Brisbane, Queensland
Posts: 24
That's a pity, not one reply.
multihulls is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.