Factory navigation screen blank - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 04-20-2013, 01:01 AM Thread Starter
whitetj0525
Registered User
2002 TJ Wrangler 
 
Join Date: Jan 2008
Location: Andersen AFB Guam
Posts: 11
Factory navigation screen blank

Yesterday I began having a problem with my wife's 2006 GC limited. It has the stock nav unit installed. The unit will not come on(only comes on to eject a disk), not play any music and no buttons will work except for the disk eject. Any help would be apperciated. Also I already tried disconnecting the battery.

whitetj0525 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 04-20-2013, 06:27 PM
WmassWK
Registered User
2006 WK 
 
Join Date: Aug 2010
Location: Western, MA
Posts: 41
Mine completely crapped out 3 weeks ago. After it heated up the screen would die and the right side and bottom buttons would not work. The radio did play but only the presets would function. I managed to get the discs out out and ordered a used one from ebay. I got the used one in like new condition for cheaper than going aftermarket. The original was then brought to the range to help ease my nerves through proper therapy. I did save the nav disc.
WmassWK is offline  
post #3 of 7 Old 04-21-2013, 06:48 AM
darot
Registered User
 
Join Date: Mar 2006
Posts: 53
your looking at 4 to 500 to replace with a reman one, hardly worth the money. Just junk it and get an aftermarket (cruchfield). Its a bummer loosing the factory phone but I got over it. I got the sony all touch screen. I would get one that has knobs for radio, the touch is a pain for the radio. I do love the tom tom nav though.

BTW i went through 2 factory nav radios, trust me and just junk it.
darot is offline  
post #4 of 7 Old 04-22-2013, 05:02 AM Thread Starter
whitetj0525
Registered User
2002 TJ Wrangler 
 
Join Date: Jan 2008
Location: Andersen AFB Guam
Posts: 11
Well I would like to get an after-market unit, but my wife doesn't want to lose the ability to play the rear DVD sound for my kids. So it looks like I will have to replace the factory one. Does anyone know of a good site I can get one for cheap? Also is there any newer chrysler units the will let me retain the ability to have the DVD volume play through my speakers?

Thanks for the input,
Mike
whitetj0525 is offline  
post #5 of 7 Old 04-24-2013, 09:37 AM
stpmnwkjeep
Registered User
2005 WK 
 
Join Date: May 2012
Location: St Paul
Posts: 13
Quote:
Originally Posted by whitetj0525 View Post
Well I would like to get an after-market unit, but my wife doesn't want to lose the ability to play the rear DVD sound for my kids. So it looks like I will have to replace the factory one. Does anyone know of a good site I can get one for cheap? Also is there any newer chrysler units the will let me retain the ability to have the DVD volume play through my speakers?

Thanks for the input,
Mike
If you get an aftermarket one like I did the rear DVD will still work with the headphones. If you don't have a set you can pick them up on eBay for around $50. Plus then you can listen to whatever you want and the kids can hear their program -a win win!
stpmnwkjeep is offline  
post #6 of 7 Old 11-29-2013, 02:00 PM
kielg
Registered User
2005 WK 
 
Join Date: Nov 2013
Location: St. Paul
Posts: 1
Fixed same issue

I recently had the same issue in my 2005 WK Limited with the factory REC navigation screen only working in the cold and then powering down the screen leaving only the radio preset buttons working. I was able to remove the stereo and take the face off, remove the control board and resolder the resistors below the video controller on the backside and use alcohol to clean all the grounding pads. 1 week so far and the screen hasn't failed yet so hopefully this is the fix.
kielg is offline  
post #7 of 7 Old 11-29-2013, 06:25 PM
94jeepman
Registered User
2005 WK 
 
Join Date: Apr 2011
Location: rapid city
Posts: 778
They are crap you'd be better off going out and buying one that you like for $300+ depending on what you would go with. I have read somewhere on what might fix it but it requires good soldering
94jeepman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome