Excessive smoke on tickover - JeepForum.com
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Excessive smoke on tickover

6th annual beat your wife to the credit cards sale!!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectRugged Ridge Products Promo Calendar - Promo Code 2016CAL

Unread Yesterday, 08:44 AM   #1
Registered User
2006 WK 
Join Date: Nov 2015
Location: Wrexham, Wales
Posts: 1
Excessive smoke on tickover

Hi all, new to the forum so please bear with me. I have a 2006 WK Grand Cherokee 3.0 CRD that is my pride and joy. Pulls like a train and goes anywhere. Problem I have is that on tickover after a couple of minutes there is a lot of blue/grey smoke from the exhaust with an awful smell that i cannot describe but it stinks. After moving off and driving a couple of miles it clears but returns again when stuck in traffic jams etc and left to idle for more than a couple of minutes. It does not use any oil or water at all, drives and starts perfectly, pulls like a train, has no miss-fire and does not smoke at any other time. Some people have said it could be valve stem oil seals but it doesn't use any oil and the smell does not seem like burning oil.

Any help greatly appreciated as it can be embarrassing when in a traffic jam or like last night when we were stuck in a multi storey car park queuing to get out, everyone was staring and pointing to the back of my Jeep. As if i didn't know, how could i not see it lol.

Wrexham9761 is offline   Reply With Quote Quick reply to this message
Unread Today, 07:16 AM   #2
Registered User
2005 WK 
Join Date: Oct 2014
Location: Limoges, France
Posts: 64
You are not alone, read my thread : http://www.jeepforum.com/forum/f67/s...lease-3220946/

Sorry don't have an answer yet, and please, if you get a solution please post the detail.
davids0865 is offline   Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.