EVIC not working - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 07-09-2009, 05:31 AM Thread Starter
ccchris
Registered User
2014 JK Wrangler 
 
Join Date: Nov 2006
Location: Toronto, Canada
Posts: 25
EVIC not working

2005 Grand Cherokee 3.7L.
At some point this morning my EVIC stopped displaying all information? It was working last night as it indicated that a rear door was not closed on my way home.
Anyone have this issue? I can not figure out if it is on its own fuse and I have tried to search the forum looking for similar problems but had no luck.
Any suggestions would be appreciated.

Chris

ccchris is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-09-2009, 08:55 AM
Texas WJ
Web Wheeler
 
Texas WJ's Avatar
2005 WK 
 
Join Date: Mar 2006
Location: San Antonio
Posts: 2,101
I know this sounds stupid and I don't mean to insult you're intelligence, but you got to start with the simple stuff, have you tried flipping through the info readouts with the "step" button? I ask 'cause there's a setting on there that shuts off the display. Maybe you hit it by accident?
Texas WJ is offline  
post #3 of 5 Old 07-09-2009, 10:24 AM Thread Starter
ccchris
Registered User
2014 JK Wrangler 
 
Join Date: Nov 2006
Location: Toronto, Canada
Posts: 25
Not insulted at all, i use the evic frequently (L / 100km and trip) and checked the obvious. At first I thought I must have dimmed the cluster but the odometer shines brightly and the evic side is blank. Pushing the step etc does not do anything.
Any other ideas?
ccchris is offline  
post #4 of 5 Old 07-19-2009, 07:54 PM Thread Starter
ccchris
Registered User
2014 JK Wrangler 
 
Join Date: Nov 2006
Location: Toronto, Canada
Posts: 25
Seems like the evic is not serviceable and the only solution once it fails is to replace the entire cluster?
If any know this the be true please let me know.
thanks
ccchris is offline  
post #5 of 5 Old 07-20-2009, 11:48 AM
colinzj
Registered User
2006 WK 
 
Join Date: Mar 2005
Location: Chandler, AZ
Posts: 1,685
If it's a bad connector or solder joint, it can be repaired (although a dealer may not feel like it). Beyond that, yeah, the cluster board's replaced as an assembly.

2006 WK Laredo 4x4 4.7L
1993 ZJ Laredo 4x4 4.0L Dead, sold, and rolling again
colinzj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Need help with Evic. kiesha WK Grand Cherokee & XK Commander Forum 6 02-14-2010 01:04 PM
EVIC Check Gas Cap vanmak52290 WK Grand Cherokee & XK Commander Forum 4 02-11-2009 04:36 PM
EVIC question JPK ZJ Grand Cherokee Forum 3 03-24-2008 02:11 PM
evic naeem ZJ Grand Cherokee Forum 7 12-11-2005 11:56 AM
Avg MPG / EVIC question HemimanNYC ZJ Grand Cherokee Forum 1 07-12-2005 10:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome