ESP/BAS light on - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > ESP/BAS light on

Alloy USA and Posi-Lok Cable Axle Disconnect Kits Dana 30 Stainless Steel Door Hinge PinsPoly Door Hinge Bushings

Reply
Unread 04-07-2009, 08:52 AM   #1
campijr
Registered User
 
Join Date: Apr 2009
Location: Mass
Posts: 1
ESP/BAS light on

Hi All, I have a 2006 Jeep Commander 4.7 litre with the ESP/BAS light on. Checked OBDII for codes. All I found was C0077 Low tire pressure. Thought I found problem when the low tire light ws on too. Tires were all low. Didn't put out ESP/BAS light I checked wheel sensors and all are reading the same going done road. I looked for damage to undercarriage (none) The steering wheel is straight. Anyone have same problem? Any help would be great

campijr is offline   Reply With Quote
Unread 04-07-2009, 10:08 AM   #2
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
I can’t see why you don’t have any codes if the light is on. All I can think is your scanner can’t read the codes. Even if the ABS module went down you would get a loss of comms DTC set against it from other module. Suggest try another code reader.
Regards,
Merlin
__________________
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote
Unread 04-07-2009, 01:13 PM   #3
WSPJeep
Registered User
1988 YJ Wrangler 
 
Join Date: Oct 2008
Location: San Diego
Posts: 468
I had the same problem, just go and get your PCM reflashed, im pretty sure thats what fixed mine or it may have been a TSB. check out wkjeeps.com and look for that TSB.
__________________
Matt
'90 YJ- 4 bangin on 32's
'72 Dodge Dart 318 V8, 2 door
WSPJeep is offline   Reply With Quote
Unread 05-03-2009, 06:47 PM   #4
CreepCommander
Registered User
 
Join Date: May 2009
Location: St. Charles, MO
Posts: 1
I just had brand new tires put on my 2006 Jeep Commander a couple of days ago. Immediately after I drove away from the tire place the low tire pressure light came on even though the tires were not low. The light went off after I turned the Jeep off then back on again. Today when I got into my Jeep, the "ESP BAS" light and the "Traction Symbol" light came on and stayed on. When I turned the Jeep off and then back on again the lights were gone. Does anybody have any clue what this means? Do you think it has something to do with me putting new tires on it?
CreepCommander is offline   Reply With Quote
Unread 05-03-2009, 07:39 PM   #5
WSPJeep
Registered User
1988 YJ Wrangler 
 
Join Date: Oct 2008
Location: San Diego
Posts: 468
Have you had your PCM reflashed at the dealer?
__________________
Matt
'90 YJ- 4 bangin on 32's
'72 Dodge Dart 318 V8, 2 door
WSPJeep is offline   Reply With Quote
Unread 05-03-2009, 07:56 PM   #6
JeepGuy026
Registered User
2011 WK 
 
Join Date: Jan 2008
Location: Long Island
Posts: 12
I put new wheels on my Jeep Soon After somehow i broke a wheel speed sensor so it could be a problem with one of them too possibly. I had the Same Issues a WK of Course.
__________________
2006 Jeep WK Grand Cherokee Limited 5.7
( Midnight Blue Pearl Coat)

Leather, Nav, 4x4 Package, Khaki Interior
JeepGuy026 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.