Engine problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Engine problems

ANOTHER Rockridge4wd Creation!! Spare Tire Carrier Delete ROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail Engo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 08-08-2013, 11:59 AM   #1
slickdevil08
Registered User
2005 WK 
 
Join Date: Jul 2013
Location: Chambersburg, Pennsylvania
Posts: 47
Engine problems

Engine is not displaying any codes. Had the dealership check it 4 times and they keep saying the car runs fine . However it has stalled on me while driving today and I feel the whole jeep slightly shaking . Also looking at the engine it's almost as its twitching . It seems to be getting worse . Please help


Sent from AutoGuide.com App

__________________
2005 Grand Cherokee Limited
Blacked Out Emblems
slickdevil08 is offline   Reply With Quote Quick reply to this message
Unread 08-08-2013, 03:28 PM   #2
scott02ws6
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: Virginia Beach, VA
Posts: 155
It's kinda hard to say but start off with the small things since there are no codes. When was the last time the plugs were changed, air filter, egr could also be a culprit.
__________________
05 WK-HEMI-QDII-flowmaster-intake-RC 2" BB-F150 MLL-mesh grill mod-grill mounted LED drive lights-LED cargo mod-Brush/push bar
02 Trans Am WS6 - 482 rwhp (motor) 642 rwhp (N2O wet) AIR ASSAULT!
scott02ws6 is offline   Reply With Quote Quick reply to this message
Unread 08-08-2013, 03:39 PM   #3
slickdevil08
Registered User
2005 WK 
 
Join Date: Jul 2013
Location: Chambersburg, Pennsylvania
Posts: 47
I have no record of any of that but the car has 60k miles. And you can really see the engine twitching at idle . Also if you slightly let off the brake pedal to get moving. You can really feel a stutter there as well. Also one time I had a hell of a time starting it after I was driving it and it was stuttering bad had to give gas and tried the key twice and then the third it fired up still no codes ugh


Sent from AutoGuide.com App
__________________
2005 Grand Cherokee Limited
Blacked Out Emblems
slickdevil08 is offline   Reply With Quote Quick reply to this message
Unread 08-08-2013, 03:55 PM   #4
yzjwk
Registered User
2005 WK 
 
Join Date: Apr 2011
Location: Lac du Bonnet, manitoba, Can
Posts: 1,101
Pull one of the plugs and take a look . at 60k ,the plugs were probably never changed and are in bad shape .
__________________
Proud owner : 05 WK Ltd 5.7 HEMI
90 YJ Islander 4.2 Cam'd & Decked
94 ZJ Ltd 5.2
00 WJ 4.0
yzjwk is offline   Reply With Quote Quick reply to this message
Unread 08-08-2013, 04:09 PM   #5
scott02ws6
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: Virginia Beach, VA
Posts: 155
Quote:
Originally Posted by yzjwk View Post
Pull one of the plugs and take a look . at 60k ,the plugs were probably never changed and are in bad shape .
Agreed, best to start out with a full tune up and go from there.
__________________
05 WK-HEMI-QDII-flowmaster-intake-RC 2" BB-F150 MLL-mesh grill mod-grill mounted LED drive lights-LED cargo mod-Brush/push bar
02 Trans Am WS6 - 482 rwhp (motor) 642 rwhp (N2O wet) AIR ASSAULT!
scott02ws6 is offline   Reply With Quote Quick reply to this message
Unread 08-08-2013, 05:35 PM   #6
slickdevil08
Registered User
2005 WK 
 
Join Date: Jul 2013
Location: Chambersburg, Pennsylvania
Posts: 47
Well dealer owner just called and said he's gunna check all the plugs and wires. So ill let ya know what the dealer comes back with


Sent from AutoGuide.com App
__________________
2005 Grand Cherokee Limited
Blacked Out Emblems
slickdevil08 is offline   Reply With Quote Quick reply to this message
Unread 08-08-2013, 06:15 PM   #7
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland, MI
Posts: 1,527
Quote:
Originally Posted by slickdevil08 View Post
Engine is not displaying any codes. Had the dealership check it 4 times and they keep saying the car runs fine . However it has stalled on me while driving today and I feel the whole jeep slightly shaking . Also looking at the engine it's almost as its twitching . It seems to be getting worse . Please help


Sent from AutoGuide.com App
If it were mine, I would do the following:
  1. Spark plugs (16 @ Champion 570 copper core with black top electrode, NOT silver)
  2. Check plug wires for resistance and cross-talk
  3. EGR valve - these can be erratic, but still within error-code limits. Mine went at 45K miles.
  4. PCV valve - due at 60K miles anyway
  5. Clean throttle body.
  6. Check coil primary resistance.

This is a good weekend's work once you have all of the parts. I would do all of the ignition-related items at the same time if you have to break up the tasks.

Making the assumption you know the oil change history, the xmission fluid is at the correct level (warm), and the air filter element is not dirty.
__________________
HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline   Reply With Quote Quick reply to this message
Unread 08-08-2013, 09:20 PM   #8
audiophonicz
Registered User
2007 WK 
 
Join Date: Nov 2010
Location: Monroeville, Pa
Posts: 224
x2

Make sure they use the correct plugs and gap. I had the same issue less than 30 days after I bought mine. Dealer said the plugs were fine. Issue persisted for months until I finally pulled the plugs myself to see they were 3570s not just 570s. Switched em out to the ones Walt said and haven't had a stall since.
audiophonicz is offline   Reply With Quote Quick reply to this message
Unread 08-08-2013, 09:21 PM   #9
DRCracker
Registered User
2006 WK 
 
Join Date: Apr 2012
Location: Somerset, PA
Posts: 378
Quote:
Originally Posted by slickdevil08 View Post
Engine is not displaying any codes. Had the dealership check it 4 times and they keep saying the car runs fine . However it has stalled on me while driving today and I feel the whole jeep slightly shaking . Also looking at the engine it's almost as its twitching . It seems to be getting worse . Please help


Sent from AutoGuide.com App
Are there any real mechanics anymore, or are they just computer techs?

Get a mechanic who can work on a car that doesn't have a computer, he'll figure out the problem.

My guess, fire, air, or fuel; one of those is screwed up.

TC
__________________
MOLON LABE: 2006 WK Limited, Dark Khaki Pearl, 5.7 HEMI, QDII,
Console XDs-45acp, Billet Catch Can, Airaid CAI Tube,
1" Spacers, Steel Armadillo Sliders, Dark Khaki 4xGuard Front Skid,
Dark Khaki 2011 #9104 Wheels, Firestone Destination A/T 265/70/17's.
OME HD lift. Dark Khaki Matrix Brush Guard, Dark Khaki Painted Headlight Bezels.
Hemi Club #65 // Khaki WK Club #40
DRCracker is offline   Reply With Quote Quick reply to this message
Unread 08-08-2013, 09:55 PM   #10
scott02ws6
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: Virginia Beach, VA
Posts: 155
Quote:
Originally Posted by DRCracker View Post

Are there any real mechanics anymore, or are they just computer techs?

Get a mechanic who can work on a car that doesn't have a computer, he'll figure out the problem.

My guess, fire, air, or fuel; one of those is screwed up.

TC
The basics are fuel, air and spark that's why we recommended stating of with a simple tune up.
__________________
05 WK-HEMI-QDII-flowmaster-intake-RC 2" BB-F150 MLL-mesh grill mod-grill mounted LED drive lights-LED cargo mod-Brush/push bar
02 Trans Am WS6 - 482 rwhp (motor) 642 rwhp (N2O wet) AIR ASSAULT!
scott02ws6 is offline   Reply With Quote Quick reply to this message
Unread 08-09-2013, 07:27 AM   #11
slickdevil08
Registered User
2005 WK 
 
Join Date: Jul 2013
Location: Chambersburg, Pennsylvania
Posts: 47
This is all good knowledge thank you and I will let you guys know what happens


Sent from AutoGuide.com App
__________________
2005 Grand Cherokee Limited
Blacked Out Emblems
slickdevil08 is offline   Reply With Quote Quick reply to this message
Unread 08-09-2013, 07:54 PM   #12
DRCracker
Registered User
2006 WK 
 
Join Date: Apr 2012
Location: Somerset, PA
Posts: 378
Quote:
Originally Posted by scott02ws6 View Post
The basics are fuel, air and spark that's why we recommended stating of with a simple tune up.
And I agree!

TC
__________________
MOLON LABE: 2006 WK Limited, Dark Khaki Pearl, 5.7 HEMI, QDII,
Console XDs-45acp, Billet Catch Can, Airaid CAI Tube,
1" Spacers, Steel Armadillo Sliders, Dark Khaki 4xGuard Front Skid,
Dark Khaki 2011 #9104 Wheels, Firestone Destination A/T 265/70/17's.
OME HD lift. Dark Khaki Matrix Brush Guard, Dark Khaki Painted Headlight Bezels.
Hemi Club #65 // Khaki WK Club #40
DRCracker is offline   Reply With Quote Quick reply to this message
Unread 08-11-2013, 08:38 PM   #13
audiophonicz
Registered User
2007 WK 
 
Join Date: Nov 2010
Location: Monroeville, Pa
Posts: 224
Quote:
Originally Posted by DRCracker View Post
Are there any real mechanics anymore, or are they just computer techs?

TC
He took it to a stealership. Remember if StarScan doesn't say there's a problem, there isn't a problem.
audiophonicz is offline   Reply With Quote Quick reply to this message
Unread 08-12-2013, 07:32 AM   #14
slickdevil08
Registered User
2005 WK 
 
Join Date: Jul 2013
Location: Chambersburg, Pennsylvania
Posts: 47
Quote:
Originally Posted by audiophonicz View Post
He took it to a stealership. Remember if StarScan doesn't say there's a problem, there isn't a problem.
Oh they already tried that with me


Sent from AutoGuide.com App
__________________
2005 Grand Cherokee Limited
Blacked Out Emblems
slickdevil08 is offline   Reply With Quote Quick reply to this message
Unread 08-15-2013, 06:56 AM   #15
slickdevil08
Registered User
2005 WK 
 
Join Date: Jul 2013
Location: Chambersburg, Pennsylvania
Posts: 47
Update: the dealership could not find the issue and returned the car to me . After speaking with the owner they have advised me that they are going to find me another jeep just like it and trade me


Sent from AutoGuide.com App
__________________
2005 Grand Cherokee Limited
Blacked Out Emblems
slickdevil08 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.