Cruise control problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Cruise control problems

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineToxic Brakes - 3000 PSI Braided Stainless Steel Brake LineCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD

Reply
Unread 02-15-2010, 11:20 AM   #1
eking511
Registered User
2005 WK 
 
Join Date: Jan 2008
Location: Massachusetts
Posts: 18
Cruise control problems

Hey guys, I've been having some problems with my cruise control on my 05 hemi. I'll hit the button on the steering wheel and it often won't turn on, the light on the dashboard doesn't show up...nothing. Other times I'll be able to get the cruise light to turn on for a second and for the cruise to engage, only for it to shut off a few seconds later... was wondering if anybody had any insight on this, as to what it could be?

appreciate the help
thanks guys

__________________
First Car, First Jeep:
2005 Jeep Grand Cherokee Limited Hemi


HEMI Club Member #15
eking511 is offline   Reply With Quote
Unread 02-27-2010, 05:37 PM   #2
Jeepskate06
Registered User
2006 WK 
 
Join Date: Feb 2010
Location: ypsilanti, mi
Posts: 13
almost same issue but mine will not turn on at all. its probally something really dumb like a broken wire but thats jeep electronics!
Jeepskate06 is offline   Reply With Quote
Unread 02-27-2010, 11:47 PM   #3
Texas WJ
Web Wheeler
 
Texas WJ's Avatar
2005 WK 
 
Join Date: Mar 2006
Location: San Antonio
Posts: 2,050
This will sound incredibly stupid... very incredibly stupid, but check your brake fluid level.

I had my Cruise Control take a dump half way through a 4,100 mile trip a couple of months ago and I went through everything I thought it could be... rebooted the computer, checked the fuses, etc... and found my brake fluid extremely low. I didn't think anything of it, and topped it off just to do it before taking off again and the Cruise Control started working again. I haven't had a problem with it since.

Like I said, I seriously doubt this was the cause of my problem and I'm embarrassed to offer it as a possible solution, but it can't hurt to check. I can't possibly imagine how the two systems are related... at all.
__________________
255/75-17 BF Goodrich Mud Terrain TA KMs, 2" lift, JK Wrangler Moab wheels, Spidertrax Spacers, Rola Roof Rack.
Texas WJ is offline   Reply With Quote
Unread 02-28-2010, 11:51 AM   #4
Jeepskate06
Registered User
2006 WK 
 
Join Date: Feb 2010
Location: ypsilanti, mi
Posts: 13
ok so did some investigating last night. mine will turn on when the vehicle is not running, but if i start the engine and go to drive the cruise light turns off and will not turn back on. really puzzled as to what the dealio is. will check brake fluid level, maybe thats the mystery fixer.....?
Jeepskate06 is offline   Reply With Quote
Unread 08-06-2011, 11:59 AM   #5
TheDentist
Registered User
2006 WK 
 
Join Date: Oct 2010
Location: Las Vegas
Posts: 31
Did you ever find out what the issue was? My 06 is doing the exact same thing. The cruise control light turns on and the cruise will set. After a random amount of time (sometimes almost instantly, sometimes after quite a few miles) the cruise control light turns off and will not turn back on. Restarting the vehicle will get it to turn on, but then it just turns off again. I tried disconnecting the battery for a while... still the same issue with the cruise control. I've been searching forums, but can't find out what the issue is.
TheDentist is offline   Reply With Quote
Unread 08-06-2011, 12:40 PM   #6
TheDentist
Registered User
2006 WK 
 
Join Date: Oct 2010
Location: Las Vegas
Posts: 31
After checking for codes by turning my ignition off and on 3 times I found these three codes: p0592, p0591, p0585. I did a quick google search and found this info from http://engine-codes.com

P0592 - Speed Control Switch 2 Circuit Low
Share 0 Comments | Add Comment

Symptoms
- Engine Light ON (or Service Engine Soon Warning Light)
Possible causes
- Short to ground speed control switch circuit
- Faulty Clockspring assembly
- Faulty speed control switch
When is the code detected?
The ECM has detected that the speed control switch 2 is below minimum voltage range
P0592 Information for specific makes
P0592 CHRYSLER

P0591 CHRYSLER - Speed Control Multiplexed Switch Performance
Share 0 Comments | Add Comment

Symptoms
- Engine Light ON (or Service Engine Soon Warning Light)
Possible causes
- Open or short speed control switch circuit condition
- Poor speed control switch electrical connection
- Faulty speed control switch
- Failed SCCM
When is the code detected?
The Steering Column Control Module (SCCM) has detected that the Speed Control Switch 2 is not operating correctly

P0585 JEEP - Speed Control Switch Correlation Error
Share 0 Comments | Add Comment

Symptoms
- Engine Light ON (or Service Engine Soon Warning Light)
- Cruise control system inoperative
Possible causes
- Clock spring circuit is open or short
- Clock spring poor electrical connection
- Faulty clock spring
Tech notes
This code can be set if two different control buttons in the cruise control system are press at the same time for more than 450 milliseconds. Since it is a logical problem and not a mechanical problem, try resetting the light first before replacing any parts.
When is the code detected?
The ECM compares the cruise control switch 1 to switch 2- A signal error was recognized
TheDentist is offline   Reply With Quote
Unread 08-17-2012, 07:25 PM   #7
AlsJeep1
Registered User
 
Join Date: Sep 2009
Location: Raleigh
Posts: 14
The Dentist, did you ever find a fix?
__________________
1984 Cherokee
1886 CJ-7
2004 Wrangler
2006 Grand Cherokee
AlsJeep1 is offline   Reply With Quote
Unread 08-20-2012, 07:19 AM   #8
shudog
Registered User
2012 WK 
 
Join Date: Nov 2004
Posts: 324
My 06 WK Limited has a problem with the cruise as well, just quit working last week, switch appears to be shot, pushing the button does nothing.
__________________
Previously owned jeeps:
'06 Grand Cherokee Limited w/4.7L V8 & QD2
'98 Grand Cherokee Limited w/5.2L V8 & Quadra Trac - sold at 230k miles
shudog is offline   Reply With Quote
Unread 06-20-2013, 07:58 AM   #9
faja2008
Registered User
 
Join Date: Sep 2012
Location: Chesterton, IN
Posts: 6
Resurrecting this old thread. I bought an 05 hemi last fall. Everything about the vehicle is perfect, but the cruise has never worked. The seller told me the Hemi has a feature where it kicks down to 4 cylinders while on cruise control on the highway, and I imagine that would save me quite a bit on fuel when I take the Jeep on long trips. Definitely want to get to the bottom of this. Anyone ever solve it?

Edit: Did some tooling around this morning on this one. If you google for solutions, you'll find a lot of folks talking about issues with vacuum hoses. I think it's safe to ignore those, as you'll notice all of those complaints are for the preceding design of the Jeep GC. Ours appears to be a unique animal.

Cheers

Last edited by faja2008; 06-20-2013 at 10:17 AM..
faja2008 is offline   Reply With Quote
Unread 07-05-2013, 10:59 PM   #10
Marksikern
Registered User
 
Join Date: Jun 2013
Posts: 50
There is a vacuum tube that runs along the top of the firewall to somewhere around the throttle body, I never followed it all the way out but if this vacuum tube is screwed up and leaking your cruise control will not work. Voice of experience on my 99.

Sent from my iPhone using JeepForum
Marksikern is offline   Reply With Quote
Unread 07-31-2013, 04:35 PM   #11
taylorxj
Registered User
 
Join Date: Sep 2010
Location: arab
Posts: 1
Ok so I've read every thread on this fourm and talked to 2 jeep dealer service dept. I just bought the wife an 06 wk and the cruise doesn't work or even display also I've tried pulling codes by turning ign from off to on 3x and no codes all vacuum is good I found somewhere that fixed it by changing the break light switch. I talk to guy at the dealer ship he told me that the cruise and break light are not on the same circuit and that would have no effect and it must be a fault in one of the components I'm all out of ideas I even topped off the break fluid so please HELP ME !!thnks
taylorxj is offline   Reply With Quote
Unread 06-02-2014, 10:29 AM   #12
DavidGT650R
Registered User
 
Join Date: May 2014
Location: Amarillo, Texas
Posts: 2
Any fixes for this yet guys? My cruise light will come on, but will not set the speed. I've already replaced the brake light switch and adjusted it, but I'm still cruise-less. Am I correct in thinking that this is all electronic? No vac lines controlling cruise control anymore?
DavidGT650R is offline   Reply With Quote
Unread 06-07-2014, 02:37 PM   #13
BlackPrintz
Registered User
2005 WK 
 
Join Date: Jan 2013
Location: Weymouth, NS
Posts: 43
The only time I've encountered this issue was when my ABS sensor was acting up. This would also deactivate the ESP. Once I replaced the sensor in the wheel bearing, everything was fine.
__________________
Black WK #139
05 WK, 5.7 Hemi, 2" R.C. lift, 32s, K&N, MagnaFlow, 4xGuard Skids, Custom Rock Rails
BlackPrintz is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.