cruise control issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 06-18-2010, 08:12 PM Thread Starter
gulfgirl
Registered User
2005 FSJ Cherokee 
 
Join Date: May 2010
Location: nc
Posts: 1
cruise control issues

The cruise control on my 2005 jeep grand cherokee works at times and not others. Sometimes you can press the button to engage the cruise control and the "cruise" light will come on for a second and then go back off, thus not allowing you set the speed. At other times the light may not come on at all, and then at others time it may work as it is supposed to. There seems to be no pattern, although the times it actually works seems to be less frequent. I took it to my local jeep dealer who "fixed" it by repairing a "poor connection from brake control function module" but the next day the cruise was not working once again. Due to many issues that I will not go into here, I don't have much confidence in their work and would rather not go back to them. I have been told that it could possibly be a bad brake sensor. Has anyone had any experience with this type of problem? Any ideas would be appreciated.

gulfgirl is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-18-2010, 10:54 PM
89yj2010
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2010
Location: north carolina
Posts: 118
Sounds like its probably a leak in a vaccum hose, since I believe that is how the cruise control is operated. Im not totally sure on those.

USN JEEP CLUB HULL #107

ENC JEEP BROTHERHOOD #3
89yj2010 is offline  
post #3 of 4 Old 12-30-2013, 01:35 PM
AlsJeep1
Registered User
 
Join Date: Sep 2009
Location: Raleigh
Posts: 17
Ever get a fix for this gulfgirl?

1981 CJ-7 & 2006 Grand Cherokee
1984 Cherokee (sold)
1986 CJ-7 (sold)
2004 Wrangler (sold)
AlsJeep1 is offline  
post #4 of 4 Old 12-31-2013, 09:41 PM
justinmiller930
Registered User
2011 WK 
 
Join Date: May 2011
Location: Brookville
Posts: 294
I've been having the same problem with mine working intermittently. I'm going to have it looked at when I get it inspected in a few months. It worked all summer, but now that the weather is getting colder it's starting to do it again.

I'll be keeping tabs on this post to see how it is fixed.
justinmiller930 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Cruise Control issues...again comishcraig ZJ Grand Cherokee Forum 20 04-02-2014 06:53 PM
Alarm and Cruise control issues toto8 ZJ Grand Cherokee Forum 5 09-12-2008 02:13 AM
WJ: Cruise control issues JayJEEPguy ZJ Grand Cherokee Forum 3 02-28-2008 07:00 AM
Cruise Control tirus89 ZJ Grand Cherokee Forum 1 11-04-2007 10:43 AM
'96 - Cruise Control Issues muzicman82 ZJ Grand Cherokee Forum 2 09-04-2007 07:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome