cruise control issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > cruise control issues

Rockridge 4WD IS Taking Zone Offroad Suspension Lift Kits BLACK FRIDAY SPECIALS!! You asked, we deliver!Rough Country Lift Kits and Parts!

Reply
Unread 06-18-2010, 09:12 PM   #1
gulfgirl
Registered User
2005 FSJ Cherokee 
 
Join Date: May 2010
Location: nc
Posts: 1
cruise control issues

The cruise control on my 2005 jeep grand cherokee works at times and not others. Sometimes you can press the button to engage the cruise control and the "cruise" light will come on for a second and then go back off, thus not allowing you set the speed. At other times the light may not come on at all, and then at others time it may work as it is supposed to. There seems to be no pattern, although the times it actually works seems to be less frequent. I took it to my local jeep dealer who "fixed" it by repairing a "poor connection from brake control function module" but the next day the cruise was not working once again. Due to many issues that I will not go into here, I don't have much confidence in their work and would rather not go back to them. I have been told that it could possibly be a bad brake sensor. Has anyone had any experience with this type of problem? Any ideas would be appreciated.

gulfgirl is offline   Reply With Quote Quick reply to this message
Unread 06-18-2010, 11:54 PM   #2
89yj2010
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2010
Location: north carolina
Posts: 118
Sounds like its probably a leak in a vaccum hose, since I believe that is how the cruise control is operated. Im not totally sure on those.
__________________
USN JEEP CLUB HULL #107

ENC JEEP BROTHERHOOD #3
89yj2010 is offline   Reply With Quote Quick reply to this message
Unread 12-30-2013, 02:35 PM   #3
AlsJeep1
Registered User
 
Join Date: Sep 2009
Location: Raleigh
Posts: 14
Ever get a fix for this gulfgirl?
__________________
1984 Cherokee
1886 CJ-7
2004 Wrangler
2006 Grand Cherokee
AlsJeep1 is offline   Reply With Quote Quick reply to this message
Unread 12-31-2013, 10:41 PM   #4
justinmiller930
Registered User
2005 WK 
 
Join Date: May 2011
Location: Brookville, PA
Posts: 263
I've been having the same problem with mine working intermittently. I'm going to have it looked at when I get it inspected in a few months. It worked all summer, but now that the weather is getting colder it's starting to do it again.

I'll be keeping tabs on this post to see how it is fixed.
justinmiller930 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.