CRD Glow Plug issue - Page 9 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #121 of 285 Old 08-19-2012, 11:33 AM
baggee
Registered User
2007 WK 
 
Join Date: May 2012
Location: Bihać
Posts: 90
Quote:
Originally Posted by copterdoc View Post
I fixed my glow plug issue, my dpf issue, my wheel speed sensor issue, my black seal, orange seal issue, my swirl motor issue, and my pro vent mod issue. I Sold the damn thing. actually I loved it and it was bitter sweet to see it go, but leave it to jeep to wrap an excellent little motor up in a horrible, poorly designed emissions system and sub par wiring.
Hehehehhh nice fix man...

baggee is offline  
Sponsored Links
Advertisement
 
post #122 of 285 Old 08-20-2012, 11:43 AM
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal
Posts: 647
Quote:
Originally Posted by jiggadog View Post
try a local auto parts store..shouldnt take long to find someone who sells bosch or beru.
Right ... the plug #3 is now of the engine head and will be ending byuing one at Merc dealer for 31 $. Took 30 minutes to do ... man working on this engine is like doing a surgery ... you need white gloves and need to have had a good sleep.

At the merc dealer, I've been told that it's not necessary to change all the GP at the same time. It all depends on the mileage of the vehicle ... which kinda make sense. However I've been told that it can not be tested independetly with a ohm meter like it will be for a normal resistor. It need to be tested with the vehicle on with the ECU. Any thoughts on this ? I'd like to avoid changing a glow plug for nothing and playing the musical chair with the rest of the GPs ... I'm worried that it could also be a fault from the GP module
... how can I confirm that ? My fault code was a single P0673 code.

2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is offline  
post #123 of 285 Old 08-20-2012, 07:25 PM
jiggadog
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Hamilton
Posts: 94
Quote:
Originally Posted by jediknight View Post
Right ... the plug #3 is now of the engine head and will be ending byuing one at Merc dealer for 31 $. Took 30 minutes to do ... man working on this engine is like doing a surgery ... you need white gloves and need to have had a good sleep.

At the merc dealer, I've been told that it's not necessary to change all the GP at the same time. It all depends on the mileage of the vehicle ... which kinda make sense. However I've been told that it can not be tested independetly with a ohm meter like it will be for a normal resistor. It need to be tested with the vehicle on with the ECU. Any thoughts on this ? I'd like to avoid changing a glow plug for nothing and playing the musical chair with the rest of the GPs ... I'm worried that it could also be a fault from the GP module
... how can I confirm that ? My fault code was a single P0673 code.
only reason i changed all of mine out is i was replacing berus with bosch..probably wouldnt have mattered if i only changed one, but i figured i'd do them all at once.

if you change all the glow plugs and still get the code, then you can be pretty sure it's the module. actually my uncles module just failed last weekend. they aren't that expensive and pretty easy to change.

on a side note, my uncle has a subscription to alldata which from what i understand is used by a lot of shops and is pretty expensive for a license. anyway, my uncle printed out a page showing fuel system. check out the numbering of the glow plugs..this isn't consistent with what has been agreed to in this thread..very confusing.
Attached Thumbnails
glowplug.jpg  

2008 WK CRD Limited 4x4. Every available option package
jiggadog is offline  
post #124 of 285 Old 08-20-2012, 08:13 PM
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal
Posts: 647
Quote:
Originally Posted by jiggadog

only reason i changed all of mine out is i was replacing berus with bosch..probably wouldnt have mattered if i only changed one, but i figured i'd do them all at once.

if you change all the glow plugs and still get the code, then you can be pretty sure it's the module. actually my uncles module just failed last weekend. they aren't that expensive and pretty easy to change.

on a side note, my uncle has a subscription to alldata which from what i understand is used by a lot of shops and is pretty expensive for a license. anyway, my uncle printed out a page showing fuel system. check out the numbering of the glow plugs..this isn't consistent with what has been agreed to in this thread..very confusing.
Yeah I've seen that printout somewhere on the forum, but it seems to be wrong as it looks like, by looking at the numbering, to represent the firing sequence and not the glow plug numbers.

2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is offline  
post #125 of 285 Old 08-21-2012, 04:04 PM
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal
Posts: 647
Changed gp #3 and now she's runing fine ... Seems that p0673 code is accurate.

2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is offline  
post #126 of 285 Old 08-21-2012, 05:02 PM
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,857
Quote:
Originally Posted by jediknight View Post
Yeah I've seen that printout somewhere on the forum, but it seems to be wrong as it looks like, by looking at the numbering, to represent the firing sequence and not the glow plug numbers.
yup, the picture was called out already as being incorrect.

2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline  
post #127 of 285 Old 08-21-2012, 06:11 PM
jiggadog
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Hamilton
Posts: 94
Quote:
Originally Posted by suzieque View Post
yup, the picture was called out already as being incorrect.
ok thanks for the heads-up..didn't realize that.

jedi..that's great, glad it wasn't the module.

2008 WK CRD Limited 4x4. Every available option package
jiggadog is offline  
post #128 of 285 Old 08-21-2012, 09:39 PM
YB Normyl
Registered User
 
YB Normyl's Avatar
2016 JK Wrangler 
 
Join Date: Nov 2006
Location: Canada
Posts: 479
Got a code for glow plug #2, no check engine light just an active fault code.
YB Normyl is offline  
post #129 of 285 Old 08-22-2012, 05:01 AM
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal
Posts: 647
Quote:
Originally Posted by YB Normyl
Got a code for glow plug #2, no check engine light just an active fault code.
Weird... Do you have a tune on ?

I had a code and a mil ...

2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is offline  
post #130 of 285 Old 08-22-2012, 08:37 AM
YB Normyl
Registered User
 
YB Normyl's Avatar
2016 JK Wrangler 
 
Join Date: Nov 2006
Location: Canada
Posts: 479
Quote:
Originally Posted by jediknight View Post
Weird... Do you have a tune on ?

I had a code and a mil ...
No tune, but the mil light just came on this morning while idling.
YB Normyl is offline  
post #131 of 285 Old 08-23-2012, 08:32 PM
r_unda
Registered User
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Corpus Christi, TX
Posts: 384
Got code for #1 glow plug (@ 78,000 miles) , just replaced it with a BERU plug. Battery was disconnected for more than 10 minutes but still have check engine light on. Does this mean that the module is bad or the codes don't clear when disconnecting the battery like other cars do?

Thanks!

My Jeep isn't getting older, it's getting newer part by part

2011 WK2 HEMI 4x4 Overland
2007 WK CRD 4x4 Limited GDE Tuned
1998 TJ SE
1973 CJ5 - YJ OME 2.5" lift, 33" tires
1951 Willys truck
r_unda is offline  
post #132 of 285 Old 08-23-2012, 08:40 PM
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal
Posts: 647
Quote:
Originally Posted by r_unda
Got code for #1 glow plug, just replaced it. Battery was disconnected for more than 10 minutes but still have check engine light on. Does this mean that the module is bad or the codes don't clear when disconnecting the battery like other cars do?

Thanks!
Yep disconecting the batery will not ease all the DTC... Some can remain in the ecu and after a few driving cycle it will go if problem is solved OR erase the code a obd tool if you got one ...

2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is offline  
post #133 of 285 Old 08-23-2012, 08:43 PM
r_unda
Registered User
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Corpus Christi, TX
Posts: 384
Quote:
Originally Posted by jediknight View Post
Yep disconecting the batery will not ease all the DTC... Some can remain in the ecu and after a few driving cycle it will go if problem is solved OR erase the code a obd tool if you got one ...
Ok Thanks! Don't have OBD tool so I guess I will have to wait and see.

My Jeep isn't getting older, it's getting newer part by part

2011 WK2 HEMI 4x4 Overland
2007 WK CRD 4x4 Limited GDE Tuned
1998 TJ SE
1973 CJ5 - YJ OME 2.5" lift, 33" tires
1951 Willys truck
r_unda is offline  
post #134 of 285 Old 08-23-2012, 08:45 PM
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal
Posts: 647
Quote:
Originally Posted by r_unda

Ok Thanks! Don't have OBD tool so I guess I will have to wait and see.
... But how did you get the code for gp #1 then??

2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is offline  
post #135 of 285 Old 08-23-2012, 08:49 PM
r_unda
Registered User
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Corpus Christi, TX
Posts: 384
Quote:
Originally Posted by jediknight View Post
... But how did you get the code for gp #1 then??
The parts store read me the code

My Jeep isn't getting older, it's getting newer part by part

2011 WK2 HEMI 4x4 Overland
2007 WK CRD 4x4 Limited GDE Tuned
1998 TJ SE
1973 CJ5 - YJ OME 2.5" lift, 33" tires
1951 Willys truck
r_unda is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Glow Plug life roadman WK Grand Cherokee & XK Commander Forum 59 03-24-2016 11:17 PM
CRD #6 Glow Plug Circuit Error tallguy6464 WK Grand Cherokee & XK Commander Forum 26 01-07-2014 04:26 PM
Glow plug burnout smitheeee WK Grand Cherokee & XK Commander Forum 5 10-04-2012 01:14 PM
glow plug issue not solved roadman WK Grand Cherokee & XK Commander Forum 8 10-09-2008 03:58 PM
why cant find glow/reverse glow gauges overlays for 2000 GC ? eschapiro ZJ Grand Cherokee Forum 0 02-14-2007 01:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome