CRD Glow Plug issue - Page 9 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > CRD Glow Plug issue

JKS Products @ Oconee Off-Road! 706-534-9955Rubicon Express Suspensions from CCOR 706-207-4140Oconee Off-Road Free Shipping Lifts Tires Bumpers Tops and

Reply
Unread 08-19-2012, 11:33 AM   #121
baggee
Registered User
2007 WK 
 
Join Date: May 2012
Location: Bihać, Bosnia & Herzegovina
Posts: 68
Quote:
Originally Posted by copterdoc View Post
I fixed my glow plug issue, my dpf issue, my wheel speed sensor issue, my black seal, orange seal issue, my swirl motor issue, and my pro vent mod issue. I Sold the damn thing. actually I loved it and it was bitter sweet to see it go, but leave it to jeep to wrap an excellent little motor up in a horrible, poorly designed emissions system and sub par wiring.
Hehehehhh nice fix man...

baggee is offline   Reply With Quote Quick reply to this message
Unread 08-20-2012, 11:43 AM   #122
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal, Qc
Posts: 437
Quote:
Originally Posted by jiggadog View Post
try a local auto parts store..shouldnt take long to find someone who sells bosch or beru.
Right ... the plug #3 is now of the engine head and will be ending byuing one at Merc dealer for 31 $. Took 30 minutes to do ... man working on this engine is like doing a surgery ... you need white gloves and need to have had a good sleep.

At the merc dealer, I've been told that it's not necessary to change all the GP at the same time. It all depends on the mileage of the vehicle ... which kinda make sense. However I've been told that it can not be tested independetly with a ohm meter like it will be for a normal resistor. It need to be tested with the vehicle on with the ECU. Any thoughts on this ? I'd like to avoid changing a glow plug for nothing and playing the musical chair with the rest of the GPs ... I'm worried that it could also be a fault from the GP module
... how can I confirm that ? My fault code was a single P0673 code.
__________________
2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is online now   Reply With Quote Quick reply to this message
Unread 08-20-2012, 07:25 PM   #123
jiggadog
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Hamilton, ON
Posts: 94
Quote:
Originally Posted by jediknight View Post
Right ... the plug #3 is now of the engine head and will be ending byuing one at Merc dealer for 31 $. Took 30 minutes to do ... man working on this engine is like doing a surgery ... you need white gloves and need to have had a good sleep.

At the merc dealer, I've been told that it's not necessary to change all the GP at the same time. It all depends on the mileage of the vehicle ... which kinda make sense. However I've been told that it can not be tested independetly with a ohm meter like it will be for a normal resistor. It need to be tested with the vehicle on with the ECU. Any thoughts on this ? I'd like to avoid changing a glow plug for nothing and playing the musical chair with the rest of the GPs ... I'm worried that it could also be a fault from the GP module
... how can I confirm that ? My fault code was a single P0673 code.
only reason i changed all of mine out is i was replacing berus with bosch..probably wouldnt have mattered if i only changed one, but i figured i'd do them all at once.

if you change all the glow plugs and still get the code, then you can be pretty sure it's the module. actually my uncles module just failed last weekend. they aren't that expensive and pretty easy to change.

on a side note, my uncle has a subscription to alldata which from what i understand is used by a lot of shops and is pretty expensive for a license. anyway, my uncle printed out a page showing fuel system. check out the numbering of the glow plugs..this isn't consistent with what has been agreed to in this thread..very confusing.
glowplug.jpg  
__________________
2008 WK CRD Limited 4x4. Every available option package
jiggadog is offline   Reply With Quote Quick reply to this message
Unread 08-20-2012, 08:13 PM   #124
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal, Qc
Posts: 437
Quote:
Originally Posted by jiggadog

only reason i changed all of mine out is i was replacing berus with bosch..probably wouldnt have mattered if i only changed one, but i figured i'd do them all at once.

if you change all the glow plugs and still get the code, then you can be pretty sure it's the module. actually my uncles module just failed last weekend. they aren't that expensive and pretty easy to change.

on a side note, my uncle has a subscription to alldata which from what i understand is used by a lot of shops and is pretty expensive for a license. anyway, my uncle printed out a page showing fuel system. check out the numbering of the glow plugs..this isn't consistent with what has been agreed to in this thread..very confusing.
Yeah I've seen that printout somewhere on the forum, but it seems to be wrong as it looks like, by looking at the numbering, to represent the firing sequence and not the glow plug numbers.
__________________
2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is online now   Reply With Quote Quick reply to this message
Unread 08-21-2012, 04:04 PM   #125
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal, Qc
Posts: 437
Changed gp #3 and now she's runing fine ... Seems that p0673 code is accurate.
__________________
2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is online now   Reply With Quote Quick reply to this message
Unread 08-21-2012, 05:02 PM   #126
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,809
Quote:
Originally Posted by jediknight View Post
Yeah I've seen that printout somewhere on the forum, but it seems to be wrong as it looks like, by looking at the numbering, to represent the firing sequence and not the glow plug numbers.
yup, the picture was called out already as being incorrect.
__________________
2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline   Reply With Quote Quick reply to this message
Unread 08-21-2012, 06:11 PM   #127
jiggadog
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Hamilton, ON
Posts: 94
Quote:
Originally Posted by suzieque View Post
yup, the picture was called out already as being incorrect.
ok thanks for the heads-up..didn't realize that.

jedi..that's great, glad it wasn't the module.
__________________
2008 WK CRD Limited 4x4. Every available option package
jiggadog is offline   Reply With Quote Quick reply to this message
Unread 08-21-2012, 09:39 PM   #128
YB Normyl
Registered User
2008 WK 
 
Join Date: Nov 2006
Location: Canada
Posts: 450
Got a code for glow plug #2, no check engine light just an active fault code.
YB Normyl is offline   Reply With Quote Quick reply to this message
Unread 08-22-2012, 05:01 AM   #129
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal, Qc
Posts: 437
Quote:
Originally Posted by YB Normyl
Got a code for glow plug #2, no check engine light just an active fault code.
Weird... Do you have a tune on ?

I had a code and a mil ...
__________________
2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is online now   Reply With Quote Quick reply to this message
Unread 08-22-2012, 08:37 AM   #130
YB Normyl
Registered User
2008 WK 
 
Join Date: Nov 2006
Location: Canada
Posts: 450
Quote:
Originally Posted by jediknight View Post
Weird... Do you have a tune on ?

I had a code and a mil ...
No tune, but the mil light just came on this morning while idling.
YB Normyl is offline   Reply With Quote Quick reply to this message
Unread 08-23-2012, 08:32 PM   #131
r_unda
Member
 
r_unda's Avatar
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Corpus Christi, TX
Posts: 349
Got code for #1 glow plug (@ 78,000 miles) , just replaced it with a BERU plug. Battery was disconnected for more than 10 minutes but still have check engine light on. Does this mean that the module is bad or the codes don't clear when disconnecting the battery like other cars do?

Thanks!
__________________
My Jeep isn't getting older, it's getting newer part by part

2011 WK2 HEMI 4x4 Overland
2007 WK CRD 4x4 Limited GDE Tuned
1998 TJ SE
1973 CJ5 - YJ OME 2.5" lift, 33" tires
1951 Willys truck
r_unda is offline   Reply With Quote Quick reply to this message
Unread 08-23-2012, 08:40 PM   #132
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal, Qc
Posts: 437
Quote:
Originally Posted by r_unda
Got code for #1 glow plug, just replaced it. Battery was disconnected for more than 10 minutes but still have check engine light on. Does this mean that the module is bad or the codes don't clear when disconnecting the battery like other cars do?

Thanks!
Yep disconecting the batery will not ease all the DTC... Some can remain in the ecu and after a few driving cycle it will go if problem is solved OR erase the code a obd tool if you got one ...
__________________
2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is online now   Reply With Quote Quick reply to this message
Unread 08-23-2012, 08:43 PM   #133
r_unda
Member
 
r_unda's Avatar
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Corpus Christi, TX
Posts: 349
Quote:
Originally Posted by jediknight View Post
Yep disconecting the batery will not ease all the DTC... Some can remain in the ecu and after a few driving cycle it will go if problem is solved OR erase the code a obd tool if you got one ...
Ok Thanks! Don't have OBD tool so I guess I will have to wait and see.
__________________
My Jeep isn't getting older, it's getting newer part by part

2011 WK2 HEMI 4x4 Overland
2007 WK CRD 4x4 Limited GDE Tuned
1998 TJ SE
1973 CJ5 - YJ OME 2.5" lift, 33" tires
1951 Willys truck
r_unda is offline   Reply With Quote Quick reply to this message
Unread 08-23-2012, 08:45 PM   #134
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal, Qc
Posts: 437
Quote:
Originally Posted by r_unda

Ok Thanks! Don't have OBD tool so I guess I will have to wait and see.
... But how did you get the code for gp #1 then??
__________________
2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is online now   Reply With Quote Quick reply to this message
Unread 08-23-2012, 08:49 PM   #135
r_unda
Member
 
r_unda's Avatar
1998 TJ Wrangler 
 
Join Date: Jun 2009
Location: Corpus Christi, TX
Posts: 349
Quote:
Originally Posted by jediknight View Post
... But how did you get the code for gp #1 then??
The parts store read me the code
__________________
My Jeep isn't getting older, it's getting newer part by part

2011 WK2 HEMI 4x4 Overland
2007 WK CRD 4x4 Limited GDE Tuned
1998 TJ SE
1973 CJ5 - YJ OME 2.5" lift, 33" tires
1951 Willys truck
r_unda is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.