CRD Glow Plug issue - Page 14 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #196 of 301 Old 04-05-2013, 05:59 AM
LJS8510
Web Wheeler
 
LJS8510's Avatar
2015 WK 
 
Join Date: Oct 2007
Location: Chicago Il
Posts: 1,522
zedtechus;15248537]I bought it from here:

http://www.factorymoparparts.com/642-900-28-00.html

They actually shipped the newer model: A-642-900-58-01

Thanks



jjt250

Check out post #159. I included where I got it (which was the best price we could find - $144) and a YouTube video of how to do it.

Thanks



2015 WK II 5.7 Overland, Offroad Group II,- 2008 WK Limited 3.0 CRD, - 2003 WJ Laredo 4.7, - 2001 WJ Laredo 4.0, - 1999 WJ Limited 4.7-
LJS8510 is offline  
Sponsored Links
Advertisement
 
post #197 of 301 Old 04-05-2013, 06:35 PM
zedtechus
Registered User
2008 WK 
 
Join Date: Mar 2008
Location: Canada
Posts: 66
Quote:
Originally Posted by jjt250 View Post
Check out post #159. I included where I got it (which was the best price we could find - $144) and a YouTube video of how to do it.
I actually paid 132USD but + canada shipping it went up to 168CAD.. still a very good price compared with the stealer

2008 GC CRD Laredo - QT II - Jeep Black with 18" chrome wheels
zedtechus is offline  
post #198 of 301 Old 04-06-2013, 06:49 AM
LJS8510
Web Wheeler
 
LJS8510's Avatar
2015 WK 
 
Join Date: Oct 2007
Location: Chicago Il
Posts: 1,522
Mine was 144.32 shipped Thanks Guys



Subtotal 132.30
Shipping 12.02
Tax 0.00
Total 144.32


2015 WK II 5.7 Overland, Offroad Group II,- 2008 WK Limited 3.0 CRD, - 2003 WJ Laredo 4.7, - 2001 WJ Laredo 4.0, - 1999 WJ Limited 4.7-
LJS8510 is offline  
post #199 of 301 Old 04-16-2013, 11:17 AM
Dusan
Registered User
 
Join Date: Aug 2010
Location: Ontario
Posts: 80
Quote:
Originally Posted by Drudgery1971 View Post
On the glow plug issue - I was coming back from a fairly long (500 mi each way) and after filling up jumped in the CRD and brain faded and started it without waiting for the glow plug light to go out. It flashed the GP light for about 3 seconds and then went out but it tripped the CEL about 10 seconds later and has been on since.

Not starting harder, not running odd in any way. 2007 with 66k miles on it. Having normal maintenance done at dealership tomorrow because we're headed on vacation (driving 1000 each way) next weekend so to prepare I plugged in the OBD reader and had 1 code P0671 - glow plug heater cyl 1. I cleared the code and drove it about 10 miles - no CEL, re-checked and still no codes after restarting a couple more times just in the driveway.

I am thinking the my dumb### move with starting before GP light went out tripped it but I have also seen others with real issue with GP's so I am just going to wait but I am having the dealership actually test them to be sure it's not something that just needs the right condition to trip it (hot/cold) and I just hide the issue. Is it just a simple resistance test (infinite resistance is toast?) across each of the 6 plugs to determine if good? If that is the case then it wouldn't make sense that after I cleared the code it wouldn't come back immediately????? Any thoughts on what I am thinking are appreciated.
Hi Drudgery1971, my Jeep is doing exactly the same, code P0671, CEL, I deleted the code and it run ok for 3-4 start-ups and the code reappeared; Is it the gp or the module?
Dusan is offline  
post #200 of 301 Old 06-21-2013, 06:35 PM
PDXCHRIS
Registered User
 
Join Date: Nov 2010
Location: Portland
Posts: 3
Our 2008 WK CRD 3.0 3500K went to the dealer with the check engine light on and a short glow plug light after startup, just as the comments have stated above. When the service writer called with the report that the replacement of two glow plugs # 1 and # 3 as well as the glow plug module was needed and the car would be read, Parts & Labor coming to $ 736.02. a fuel-flush for $ 158.00 and a new fuel filter in stalled for $ 228.41 plus the Electronic Engine Control Diagnosis II All another $ 112.00 coming to a grand total of $ 1211.38 DOLLARS! Now hearing this from the enthusiastic service writer at the crack of dawn, after dropping the vehicle off the afternoon before and having extended GOLD Plus Plus Jeep Chrysler warranty, was a bit of a shock to say the least!

At this point I requested that the truck be pulled out of the service bay and parked for me to retrieve costing us $110.00 for the diagnosis. Next stop was JeepForum.com and this thread to get to the bottom of this. Armed with the information from this thread, I set out to find the parts and tackle the job myself. Checking online I came up with the parts needed and was ready to hit the check-out button, when my better half asked if i would check locally for the parts that were needed were available at a comparable price. Again thanks to posted information I went to the brand new Mercedes-Benz dealer just down the street from our home and placed a order for 6 glow plugs and a module grand total of $ 330.00 the cost of the module being $ 180.00 and $ 150.00 for the six glow plugs witch retailed for $ 32.00 discounting the price $ 7.00 dollars each as to me more competitive with the internet pricing.

Next we receive the email from the dealer asking if we were pleased with the service performed, or should i say my wife received. Having excellent customer service skills she sends a reply to the Service Manager listing our concerns, to her surprise the reply to her message was return quickly. The tone of this email was we want to make this right.

Bottom line is that Northwest Jeep Inc. Portland, Oregon installed all six glow plugs and the module and replaced the broken key with programing for what we had paid for the diagnosis $ 110.00 dollars. The service manger and general manger met my wife and delivered the car personally.

Now That's service



Thanks Jeep Northwest for making it right

Maria & Christopher

P.S. I do my own oil and filter service at home.
PDXCHRIS is offline  
post #201 of 301 Old 06-21-2013, 09:28 PM
SSF556
Registered User
2008 WK 
 
Join Date: Jan 2008
Location: SC
Posts: 3,398
Awesome story.....thanks for sharing it.

Silver WK Club Member #1
2008 CRD QT2
SSF556 is offline  
post #202 of 301 Old 06-21-2013, 09:54 PM
Chirpz
Registered User
2007 WK 
 
Join Date: Aug 2009
Location: Battle Ground
Posts: 1,445
Quote:
Originally Posted by PDXCHRIS View Post
Our 2008 WK CRD 3.0 3500K went to the dealer with the check engine light
Hey PDX.... nice to hear a dealer story that turned out good. It does happen at times.
Also nice to know there is another CRD person not too far away.... I see so few of them in these parts.

I am a little confused about your mileage.

3500K could be 3,500 Kilometers.... so its brand new.... doesn't sound right.
or
maybe you meant 350,000 miles (350K) , or 35,000 miles (35K)
or
maybe you have 3,500,000 miles (3500K) which seems high for an 08.
or
maybe I just don't get it. I though 1K was 1,000.

Chirpz
2007 WK 3.0L CRD, Quadradrive II, GDE EcoTune, DPF-Delete
4xGuard Front, Rear, Belly, & Side Rails, Factory Skids
EHM MOD, Garmin Mechanic EcoHD, K&N Filter (Deleted)
Chirpz is offline  
post #203 of 301 Old 07-16-2013, 03:09 PM
rolls101
Registered User
2008 WK 
 
Join Date: Jun 2007
Location: canada
Posts: 14
Changed GP #4 and 6

Changed GP #4 and #6 today with bosch units. It took 1/2 hour thanks to all the information on this thread...........Thanks
rolls101 is offline  
post #204 of 301 Old 07-16-2013, 03:10 PM
rolls101
Registered User
2008 WK 
 
Join Date: Jun 2007
Location: canada
Posts: 14
Changed GP #4 and 6

Changed GP #4 and #6 today with bosch units. It took 1/2 hour thanks to all the information on this thread...........Thanks

Cleared the codes with my code reader to finish the job.
rolls101 is offline  
post #205 of 301 Old 07-16-2013, 03:28 PM
CRD Dawg
Registered User
2008 WK 
 
Join Date: Nov 2008
Location: Savannah, GA
Posts: 276
How did you pop off the cap on the glow plug without chewing it up with regular needle nose pliers? I can't get the cap off. I have a bad #4. Thx.

Sent from my iPhone using JeepForum

2008 Grand Cherokee Limited 2wd CRD-InMotion Stage 2 Tune, K&N Air Filter, Elephant Hose CCV Mod, Gutted Turbo Resonator, MBRP Pro Series Exhaust
CRD Dawg is offline  
post #206 of 301 Old 07-16-2013, 03:54 PM
rolls101
Registered User
2008 WK 
 
Join Date: Jun 2007
Location: canada
Posts: 14
Quote:
Originally Posted by CRD Dawg View Post
How did you pop off the cap on the glow plug without chewing it up with regular needle nose pliers? I can't get the cap off. I have a bad #4. Thx.

Sent from my iPhone using JeepForum
Used needle nose offset pliers , slight squeeze and pull straight up with a little wiggle movement. I had no issues at all.
rolls101 is offline  
post #207 of 301 Old 09-13-2013, 04:52 PM
miles85
Registered User
2008 WK 
 
Join Date: Jun 2013
Location: milton
Posts: 37
Today I replaced #4 in less than 20 mins which included stopping after I took the engine cover off to come re-read this thread.

Easy out, easy in.

total cost 62$ with tax (Beru part purchased at Napa in Milton ON. - dealer wanted 70 or 80 something plus tax)

no more CEL!!! well at least for the glow plug.)
miles85 is offline  
post #208 of 301 Old 09-25-2013, 05:47 PM
miles85
Registered User
2008 WK 
 
Join Date: Jun 2013
Location: milton
Posts: 37
update***

Now glow plug #6 is apparently having issues.

Is there a chance there is something causing the fault?
miles85 is offline  
post #209 of 301 Old 09-25-2013, 05:52 PM
jjt250
Registered User
2007 WK 
 
Join Date: Sep 2011
Location: Omaha
Posts: 717
Garage
Quote:
Originally Posted by miles85 View Post
update***

Now glow plug #6 is apparently having issues.

Is there a chance there is something causing the fault?
Glow plug module maybe? I have one in the mail because I still have glow plug faults even after replacing the ones that it said were bad.

2007 Grand Cherokee Limited | QDII | 3.0L Diesel | S4xC Shackles Mounts | Goodyear Duratracs
Bilstein HD Front/Rear | Rusty's 1/2" Strut Spacer | Hemi XK Front/Rear Coils | HID Projectors
jjt250 is offline  
post #210 of 301 Old 09-25-2013, 10:25 PM
zc911
Registered User
 
Join Date: Jun 2013
Location: brampton
Posts: 256
i had #4 and 6 go within a few days of each other as well.
NAPA near me charged me $33 each !
zc911 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Glow Plug life roadman WK Grand Cherokee & XK Commander Forum 59 03-25-2016 12:17 AM
CRD #6 Glow Plug Circuit Error tallguy6464 WK Grand Cherokee & XK Commander Forum 26 01-07-2014 05:26 PM
Glow plug burnout smitheeee WK Grand Cherokee & XK Commander Forum 5 10-04-2012 02:14 PM
glow plug issue not solved roadman WK Grand Cherokee & XK Commander Forum 8 10-09-2008 04:58 PM
why canīt find glow/reverse glow gauges overlays for 2000 GC ? eschapiro ZJ Grand Cherokee Forum 0 02-14-2007 02:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome