CRD Glow Plug issue - Page 13 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #181 of 285 Old 02-14-2013, 10:16 AM
flacrd
Registered User
2007 WK 
 
Join Date: May 2007
Location: CENTRAL WEST COAST
Posts: 31
Quote:
Originally Posted by Radcrd View Post
It is a type of muffler to muffle the airflow noise. Its a pain to remove due to space. Search around, some of the guys removed them and took the baffles out to increase airflow (myself included) Not sure it made any difference and would not bother doing it again.
So the fix is to replace the resonator? It gets clogged up? This will be a pain to deal with.

Anyone got a part number and/or source by chance?

flacrd is offline  
Sponsored Links
Advertisement
 
post #182 of 285 Old 02-14-2013, 10:27 AM
flacrd
Registered User
2007 WK 
 
Join Date: May 2007
Location: CENTRAL WEST COAST
Posts: 31
Quote:
Originally Posted by Zlartibartfast View Post
are you referring to the "resonator" described in this thread?

http://www.jeepforum.com/forum/f67/w...-pipe-1403115/
Thank you for the link. What I could not determine was what was thier problem with it (resonator) to start with? Oil leak or some other problem. How did you resolve it?
flacrd is offline  
post #183 of 285 Old 02-16-2013, 05:09 AM
brew1
Registered User
2008  
 
Join Date: Dec 2009
Location: Wisconsin
Posts: 43
Quote:
Originally Posted by flacrd View Post
Thanks for the replies CRDers. Yes it is tight even to look at. Do you think this is were the oil leak is coming from? Since there was oil present in the turbo openings during the glow plug change out that I saw it would stand to reason that it would be under pressure and leak from the resonator, Its irritating that I cannot see exactly were its coming from. It is the obvious culprit.
Did you already replace the orange turbo intake seal with the revised black one? This is a known area for oil leakage, thus the revised seal from Chrysler. Using a Provent or a tune such as GDE to disable the EGR should also help.

08 GC CRD, GDE
04 Audi A4 Wag 3.0, JHM, Revmax
03 Jetta Wag TDI, RC5, 17/22 turbo
brew1 is offline  
post #184 of 285 Old 02-16-2013, 05:34 AM
brew1
Registered User
2008  
 
Join Date: Dec 2009
Location: Wisconsin
Posts: 43
Quote:
Originally Posted by flacrd View Post
Were they ceramic or steel? Yes, I will probably stay at 7500 intervals for changes and yes I only have used Mobile 1 Turbo Diesel Oil 5w-30. I was more than pleased when Walmart started carrying this oil, by the gallon for around $29.00.
I prefer using AMSOIL 15W-40 Premium Heavy Duty Diesel & Marine Synthetic with 12 TBN in the VW TDI and Liberty CRD and will be switching the GC CRD over to it this weekend. Recommend for MB 228.1/228.3/229.1. My local Farm Supply store stocks it in gallon containers but it is a bit more expensive than the Mobile 1 Turbo Diesel.

I have used the 5W-30 Mobile 1 Turbo Diesel and 5W-30 Shell Rotella synthetic in the past with good results in all my diesel vehicles. However, I'm more comfortable with the AMSOIL for extended drain periods, 8,000+ miles.

Glad to hear you worked out your glow plug issues.

08 GC CRD, GDE
04 Audi A4 Wag 3.0, JHM, Revmax
03 Jetta Wag TDI, RC5, 17/22 turbo
brew1 is offline  
post #185 of 285 Old 02-16-2013, 11:39 AM
flacrd
Registered User
2007 WK 
 
Join Date: May 2007
Location: CENTRAL WEST COAST
Posts: 31
Quote:
Originally Posted by brew1 View Post
I prefer using AMSOIL 15W-40 Premium Heavy Duty Diesel & Marine Synthetic with 12 TBN in the VW TDI and Liberty CRD and will be switching the GC CRD over to it this weekend. Recommend for MB 228.1/228.3/229.1. My local Farm Supply store stocks it in gallon containers but it is a bit more expensive than the Mobile 1 Turbo Diesel.

I have used the 5W-30 Mobile 1 Turbo Diesel and 5W-30 Shell Rotella synthetic in the past with good results in all my diesel vehicles. However, I'm more comfortable with the AMSOIL for extended drain periods, 8,000+ miles.

Glad to hear you worked out your glow plug issues.
After learning or should I say re-learning how important quality oil is for a turbo and a diesel it looks like Amsoil for me in the future.

Thanks go to you and others on this site for the glow plugs and the 2008 tsb for the SQUEAK/RATTLE/VIBRATION under hood that has irritated the crap out of me for years. Yes, I have the documentation from the dealer to show that this was reported and written up on the service order 4 times since 2007 and never fixed. Just venting, I paid cash for the last time this written up, to bad the dealer lost their franchise during the recession? I had forgotten what this engine really sounded like without the extra noise.

2007 GRAND CHEROKEE LTD Q2 CRD GREYSTONE/L GREYSTONE
2006 MAGNUM HEMI COOL VANILLA
2006 JETTA TDI
2005 LIBERTY LTD CRD (LEMON LAWED)
flacrd is offline  
post #186 of 285 Old 02-18-2013, 11:03 AM
terrasmak
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: Sin City
Posts: 591
Swapped plugs around, kinda looking like the new Bosch glow plug is bad.

"Racing makes Heroin addiction look like a vague wish for something salty." -- Peter Egan
terrasmak is offline  
post #187 of 285 Old 03-14-2013, 09:58 AM
zedtechus
Registered User
2008 WK 
 
Join Date: Mar 2008
Location: Canada
Posts: 66
Quote:
Originally Posted by terrasmak View Post
Swapped plugs around, kinda looking like the new Bosch glow plug is bad.
My dealer replaced glow plug #2 with BOSH new version 80050 (I bought myself the glow plugs) and code still on along with check engine. Dealer told me is the fault of GP control unit and I need to replace it but scanning with my OBD2 I dont get any other code than P0672 for GP #2.

Im thinking that could be because of mixed glow plugs (5 BERU and 1 BOSH) or maybe a new faulty BOSH glow plug?

How did you fix your problem?

Thanks
Adrian

PS: I tried to reset the code but it came back after a few engine starts.

2008 GC CRD Laredo - QT II - Jeep Black with 18" chrome wheels
zedtechus is offline  
post #188 of 285 Old 03-14-2013, 10:15 AM
jiggadog
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Hamilton
Posts: 94
Quote:
Originally Posted by zedtechus View Post
My dealer replaced glow plug #2 with BOSH new version 80050 (I bought myself the glow plugs) and code still on along with check engine. Dealer told me is the fault of GP control unit and I need to replace it but scanning with my OBD2 I dont get any other code than P0672 for GP #2.

Im thinking that could be because of mixed glow plugs (5 BERU and 1 BOSH) or maybe a new faulty BOSH glow plug?

How did you fix your problem?

Thanks
Adrian

PS: I tried to reset the code but it came back after a few engine starts.
same thing with my uncles jeep. replaced #2 but still got same code. had to change the module.

2008 WK CRD Limited 4x4. Every available option package
jiggadog is offline  
post #189 of 285 Old 03-14-2013, 06:17 PM
flacrd
Registered User
2007 WK 
 
Join Date: May 2007
Location: CENTRAL WEST COAST
Posts: 31
Yes, unfortunately it seems either problem can cause the same code.

2007 GRAND CHEROKEE LTD Q2 CRD GREYSTONE/L GREYSTONE
2006 MAGNUM HEMI COOL VANILLA
2006 JETTA TDI
2005 LIBERTY LTD CRD (LEMON LAWED)
flacrd is offline  
post #190 of 285 Old 04-03-2013, 01:32 PM
jugganator
Registered User
2006 WK 
 
Join Date: Sep 2010
Location: london
Posts: 1
i been trying to replace the glow plug 1 for a while now, but i cannot see the grey clip thats shown in pictures on page 6/7. all i see is 6 black connectors, which if unplugged reveal 2 very thin metal connectors on the inside.

near them are a star shaped nut again 6, 3 of them each side, can these be the actual glow plugs? can someone maybe send me a picture and show me the where these things are?

3.0 crd 2006 WH model
jugganator is offline  
post #191 of 285 Old 04-04-2013, 12:44 PM
zedtechus
Registered User
2008 WK 
 
Join Date: Mar 2008
Location: Canada
Posts: 66
Quote:
Originally Posted by jiggadog View Post
same thing with my uncles jeep. replaced #2 but still got same code. had to change the module.
I finally received and replaced my Glow Plug unit. Before installing the new one I delete the check engine code and since 2 days no more glow plug error codes So finally I got it fixed.

It feels so good especially that I was able to get the unit for 168$ and installed it myself when the dealer was asking 360$ for the control unit plus 30 min labor time!

Thanks everybody for the valuable help.

2008 GC CRD Laredo - QT II - Jeep Black with 18" chrome wheels
zedtechus is offline  
post #192 of 285 Old 04-04-2013, 02:01 PM
LJS8510
Web Wheeler
 
LJS8510's Avatar
2015 WK 
 
Join Date: Oct 2007
Location: Chicago Il
Posts: 1,520
Quote:
Originally Posted by zedtechus View Post
I finally received and replaced my Glow Plug unit. Before installing the new one I delete the check engine code and since 2 days no more glow plug error codes So finally I got it fixed.

It feels so good especially that I was able to get the unit for 168$ and installed it myself when the dealer was asking 360$ for the control unit plus 30 min labor time!

Thanks everybody for the valuable help.
Glad to hear it worked, I may have same issue where did you get the control unit?


2015 WK II 5.7 Overland, Offroad Group II,- 2008 WK Limited 3.0 CRD, - 2003 WJ Laredo 4.7, - 2001 WJ Laredo 4.0, - 1999 WJ Limited 4.7-
LJS8510 is offline  
post #193 of 285 Old 04-04-2013, 07:59 PM
zedtechus
Registered User
2008 WK 
 
Join Date: Mar 2008
Location: Canada
Posts: 66
Quote:
Originally Posted by LJS8510 View Post
Glad to hear it worked, I may have same issue where did you get the control unit?
I bought it from here:

http://www.factorymoparparts.com/642-900-28-00.html

They actually shipped the newer model: A-642-900-58-01

2008 GC CRD Laredo - QT II - Jeep Black with 18" chrome wheels
zedtechus is offline  
post #194 of 285 Old 04-04-2013, 08:46 PM
jjt250
Registered User
2007 WK 
 
Join Date: Sep 2011
Location: Omaha
Posts: 717
Quote:
Originally Posted by LJS8510 View Post
Glad to hear it worked, I may have same issue where did you get the control unit?
Check out post #159. I included where I got it (which was the best price we could find - $144) and a YouTube video of how to do it.

2007 Grand Cherokee Limited | QDII | 3.0L Diesel | S4xC Shackles Mounts | Goodyear Duratracs
Bilstein HD Front/Rear | Rusty's 1/2" Strut Spacer | Hemi XK Front/Rear Coils | HID Projectors
jjt250 is offline  
post #195 of 285 Old 04-04-2013, 10:20 PM
terrasmak
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: Sin City
Posts: 591
Quote:
Originally Posted by zedtechus View Post
I bought it from here:

http://www.factorymoparparts.com/642-900-28-00.html

They actually shipped the newer model: A-642-900-58-01
Looks like I need one, and grab a few extra glow plugs. Just no need till the CEL has to be out for smog check in Dec.

"Racing makes Heroin addiction look like a vague wish for something salty." -- Peter Egan
terrasmak is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Glow Plug life roadman WK Grand Cherokee & XK Commander Forum 59 03-24-2016 11:17 PM
CRD #6 Glow Plug Circuit Error tallguy6464 WK Grand Cherokee & XK Commander Forum 26 01-07-2014 04:26 PM
Glow plug burnout smitheeee WK Grand Cherokee & XK Commander Forum 5 10-04-2012 01:14 PM
glow plug issue not solved roadman WK Grand Cherokee & XK Commander Forum 8 10-09-2008 03:58 PM
why cant find glow/reverse glow gauges overlays for 2000 GC ? eschapiro ZJ Grand Cherokee Forum 0 02-14-2007 01:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome