Code P0430 - Help me please!!! - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 18 Old 05-11-2009, 09:45 AM Thread Starter
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
Code P0430 - Help me please!!!

In the ongoing Jeep Saga, Code P0430 has showed up again. It goes away for a while, then my wife or I will hit a large bump in the road - and it's back again. I know it's supposed to be for a Oxygen Sensor, but they have all been replaced once before (less than 6 months ago - and it came back on within a month of being replaced). In addition, I don't know which one it is - there are 4 under there. If I can find out which one it is, I'll crawl under there myself, root around and see if I've got a loose wire, or a short, etc...

Anyone know which oxygen sensor this is, or have an idea of what else it could be?

My check engine light comes on, but doesn't flash. When I do the key-check thing, it flashes that code.

Dealer didn't see it. Even though it was there for two weeks.

All the best,
Glenn

cajuntec is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 05-11-2009, 10:09 AM
Icer
Registered User
 
Icer's Avatar
 
Join Date: Jun 2004
Posts: 16
Does this help at all?

P0430 ‐ Catalyst Efficiency (bank 2)

06 WK Limited 5.7 HEMI -|- Bright Silver Metallic -|- Limited 25K Package -|- Trailer Tow Group IV -|- NAV/6 CD, Parksense, Uconnect, SIRIUS, Smartbeam -|- Skid Plate Group W/Tow Hooks -|- Bridgestone Dueler A/T Revo 265/65/17 -|- Mods = Bilstein Rear Shocks, SRT8 Rear Swaybar, Superchips Tuner, Magnaflow, AIRAID Tube, & K&N Airfilter.
Icer is offline  
post #3 of 18 Old 05-11-2009, 12:17 PM Thread Starter
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
Thanks for trying - but not really. I'm guessing that since it's "Catalyst Efficiency" that it's one of the two behind the Catalytic converter, but I have no idea what Bank 2 is - left or right. I'm still guessing. Best assumption at this time - after the converter on the passenger side (assuming driver is 1, passenger is 2). I'll just have to get under there and root around I guess.

Thanks for trying to help. I appreciate it.
All the best,
Glenn
cajuntec is offline  
post #4 of 18 Old 05-11-2009, 12:25 PM
Nate97xj
Registered User
1997 XJ Cherokee 
 
Join Date: Nov 2008
Location: Seattle, Wa
Posts: 185
Because it is throwing a code for the catalyst, your O2 sensor is working just fine... It is telling you that your catalytic converter is not working properly. If you needed to replace it, the code would say "oxygen sensor malfunction". That code is P-0310, 0316, etc depending on which one it is.

http://www.troublecodes.net/OBD2/Pcodes.shtml < that is a list of all of the trouble codes

I would suspect that your Catalytic convertor is starting to get clogged, which would explain the effeciency problem. First, check for exhaust leaks. If there are none, then try running sea-foam through your engine to clean out the Cat, or if you have the money, you may need to replace the cat.

Green Jeep Club member #242
Nate97xj is offline  
post #5 of 18 Old 05-11-2009, 01:04 PM
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,533
Quote:
Originally Posted by Nate97xj View Post
Because it is throwing a code for the catalyst, your O2 sensor is working just fine... It is telling you that your catalytic converter is not working properly. If you needed to replace it, the code would say "oxygen sensor malfunction". That code is P-0310, 0316, etc depending on which one it is.

http://www.troublecodes.net/OBD2/Pcodes.shtml < that is a list of all of the trouble codes

I would suspect that your Catalytic convertor is starting to get clogged, which would explain the effeciency problem. First, check for exhaust leaks. If there are none, then try running sea-foam through your engine to clean out the Cat, or if you have the money, you may need to replace the cat.
Unless he has i think what over 80k miles i think Chrysler has to replace it. something to do with a federal warrant or something

Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2 sold
2012 WK2 SRT8 - Current
99 WJ Limited Lifted.
2001 WJ stock 4.0 304k miles
xJoshxx is offline  
post #6 of 18 Old 05-12-2009, 08:47 AM Thread Starter
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
I just replaced the cat under warranty about 6 months ago. It was throwing that same code then too. It's periodic. Fill up with gas, and it sometimes comes up. Other times, hit a bump and it comes up. Drive it for a few days and it goes away again.
All the best,
Glenn
cajuntec is offline  
post #7 of 18 Old 05-12-2009, 08:51 AM Thread Starter
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
How do I check for an exhaust leak? That might be it.
All the best,
Glenn
cajuntec is offline  
post #8 of 18 Old 05-12-2009, 09:05 AM
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,533
Quote:
Originally Posted by cajuntec View Post
How do I check for an exhaust leak? That might be it.
All the best,
Glenn
seafoam it and then look for the smoke.

Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2 sold
2012 WK2 SRT8 - Current
99 WJ Limited Lifted.
2001 WJ stock 4.0 304k miles
xJoshxx is offline  
post #9 of 18 Old 05-12-2009, 12:15 PM Thread Starter
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
So just putting Seafoam in your tank makes your exhaust smoke?
All the best,
Glenn
cajuntec is offline  
post #10 of 18 Old 05-12-2009, 12:21 PM
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,533
Quote:
Originally Posted by cajuntec View Post
So just putting Seafoam in your tank makes your exhaust smoke?
All the best,
Glenn
no u have to pour it throw the throttle body turn it off let it sit 20minutes start it up idle and watch for smoke it will show leaks

Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2 sold
2012 WK2 SRT8 - Current
99 WJ Limited Lifted.
2001 WJ stock 4.0 304k miles
xJoshxx is offline  
post #11 of 18 Old 05-12-2009, 12:58 PM
merlinTec
Registered User
 
merlinTec's Avatar
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
Has the dealer flashed it or even checked for TSB before the cat was replaced? http://www.wkjeeps.com/tsb/tsb_wk_1803405.pdf
Regards,
Merlin

UK Chrysler Jeep Master Tec.
merlinTec is offline  
post #12 of 18 Old 05-13-2009, 07:18 AM Thread Starter
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
Probably not. They replaced several things that didn't solve any problems.
All the best,
Glenn
cajuntec is offline  
post #13 of 18 Old 05-13-2009, 07:49 AM Thread Starter
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
Thank you for that TSB. I'll be looking at a new dealership soon.
All the best,
Glenn
cajuntec is offline  
post #14 of 18 Old 10-21-2009, 09:57 AM
derrick_lui
Registered User
 
Join Date: Feb 2009
Location: Boston
Posts: 1
Guys I have the same code P0430. I had my right Cat replaced with a Magnaflow TWICE and the code is still back on. Is there any chance that it would be the Oxygen sensor that needs to be replaced? that is what the exhaust shop guy told me when I had him redo my cat the second time...
derrick_lui is offline  
post #15 of 18 Old 06-26-2015, 09:53 AM
MadnessFL
Registered User
 
Join Date: Jun 2015
Posts: 1
Here is what I found...

Catalyst System Efficiency Below Threshold (Bank 2)
Basically this means that the oxygen sensor downstream of the catalytic converter on bank 2 is detecting that the converter is not working as efficiently as it should be (according to specs). It is part of the vehicle emissions system.
Symptoms
You will likely not notice any drivability problems, although there may be symptoms such as a rough/hard idle when cold.
Causes
A code P0430 may mean that one or more of the following has happened:
• The catalytic converter is no longer functioning properly
• An oxygen sensor is not reading (functioning) properly
• There is an exhaust leak
Possible Solutions
First, inspect for exhaust leaks.
Next step is to measure the voltage at the oxygen sensor on Bank 2. In fact, it would be a good idea to test each oxygen O2 sensor while you're at it.
MadnessFL is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
05 WK w/ P0430 Right Bank Cat code Last Boyscout WK Grand Cherokee & XK Commander Forum 8 08-30-2013 06:08 PM
Engine Code help- Code 11 athomas08 ZJ Grand Cherokee Forum 3 05-06-2009 11:56 PM
Code Crookster777 WK Grand Cherokee & XK Commander Forum 10 01-18-2008 09:31 AM
code 11 and 14 bigtopjeep94 ZJ Grand Cherokee Forum 8 04-15-2007 09:34 AM
Got Code 32 CaliforniaJeep ZJ Grand Cherokee Forum 3 02-14-2005 10:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome