Code P0430 - Help me please!!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Code P0430 - Help me please!!!

Engo winches available at www.rockridge4wd.com! Free shippFS: Wranger BRIGHT License Plate LED! Just $3! Great valuePremium LED Lighting by VISION X, Proudly sold at ROCKRIDG

Reply
Unread 05-11-2009, 09:45 AM   #1
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
Code P0430 - Help me please!!!

In the ongoing Jeep Saga, Code P0430 has showed up again. It goes away for a while, then my wife or I will hit a large bump in the road - and it's back again. I know it's supposed to be for a Oxygen Sensor, but they have all been replaced once before (less than 6 months ago - and it came back on within a month of being replaced). In addition, I don't know which one it is - there are 4 under there. If I can find out which one it is, I'll crawl under there myself, root around and see if I've got a loose wire, or a short, etc...

Anyone know which oxygen sensor this is, or have an idea of what else it could be?

My check engine light comes on, but doesn't flash. When I do the key-check thing, it flashes that code.

Dealer didn't see it. Even though it was there for two weeks.

All the best,
Glenn

cajuntec is offline   Reply With Quote
Unread 05-11-2009, 10:09 AM   #2
Icer
Registered User
 
Join Date: Jun 2004
Posts: 16
Does this help at all?

P0430 ‐ Catalyst Efficiency (bank 2)
__________________
06 WK Limited 5.7 HEMI -|- Bright Silver Metallic -|- Limited 25K Package -|- Trailer Tow Group IV -|- NAV/6 CD, Parksense, Uconnect, SIRIUS, Smartbeam -|- Skid Plate Group W/Tow Hooks -|- Bridgestone Dueler A/T Revo 265/65/17 -|- Mods = Bilstein Rear Shocks, SRT8 Rear Swaybar, Superchips Tuner, Magnaflow, AIRAID Tube, & K&N Airfilter.
Icer is offline   Reply With Quote
Unread 05-11-2009, 12:17 PM   #3
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
Thanks for trying - but not really. I'm guessing that since it's "Catalyst Efficiency" that it's one of the two behind the Catalytic converter, but I have no idea what Bank 2 is - left or right. I'm still guessing. Best assumption at this time - after the converter on the passenger side (assuming driver is 1, passenger is 2). I'll just have to get under there and root around I guess.

Thanks for trying to help. I appreciate it.
All the best,
Glenn
cajuntec is offline   Reply With Quote
Unread 05-11-2009, 12:25 PM   #4
Nate97xj
Registered User
1997 XJ Cherokee 
 
Join Date: Nov 2008
Location: Seattle, Wa
Posts: 185
Because it is throwing a code for the catalyst, your O2 sensor is working just fine... It is telling you that your catalytic converter is not working properly. If you needed to replace it, the code would say "oxygen sensor malfunction". That code is P-0310, 0316, etc depending on which one it is.

http://www.troublecodes.net/OBD2/Pcodes.shtml < that is a list of all of the trouble codes

I would suspect that your Catalytic convertor is starting to get clogged, which would explain the effeciency problem. First, check for exhaust leaks. If there are none, then try running sea-foam through your engine to clean out the Cat, or if you have the money, you may need to replace the cat.
__________________
Green Jeep Club member #242
Nate97xj is offline   Reply With Quote
Unread 05-11-2009, 01:04 PM   #5
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,500
Quote:
Originally Posted by Nate97xj View Post
Because it is throwing a code for the catalyst, your O2 sensor is working just fine... It is telling you that your catalytic converter is not working properly. If you needed to replace it, the code would say "oxygen sensor malfunction". That code is P-0310, 0316, etc depending on which one it is.

http://www.troublecodes.net/OBD2/Pcodes.shtml < that is a list of all of the trouble codes

I would suspect that your Catalytic convertor is starting to get clogged, which would explain the effeciency problem. First, check for exhaust leaks. If there are none, then try running sea-foam through your engine to clean out the Cat, or if you have the money, you may need to replace the cat.
Unless he has i think what over 80k miles i think Chrysler has to replace it. something to do with a federal warrant or something
__________________
Interested in Amsoil? Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2
2012 WK2 SRT8
xJoshxx is offline   Reply With Quote
Unread 05-12-2009, 08:47 AM   #6
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
I just replaced the cat under warranty about 6 months ago. It was throwing that same code then too. It's periodic. Fill up with gas, and it sometimes comes up. Other times, hit a bump and it comes up. Drive it for a few days and it goes away again.
All the best,
Glenn
cajuntec is offline   Reply With Quote
Unread 05-12-2009, 08:51 AM   #7
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
How do I check for an exhaust leak? That might be it.
All the best,
Glenn
cajuntec is offline   Reply With Quote
Unread 05-12-2009, 09:05 AM   #8
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,500
Quote:
Originally Posted by cajuntec View Post
How do I check for an exhaust leak? That might be it.
All the best,
Glenn
seafoam it and then look for the smoke.
__________________
Interested in Amsoil? Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2
2012 WK2 SRT8
xJoshxx is offline   Reply With Quote
Unread 05-12-2009, 12:15 PM   #9
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
So just putting Seafoam in your tank makes your exhaust smoke?
All the best,
Glenn
cajuntec is offline   Reply With Quote
Unread 05-12-2009, 12:21 PM   #10
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,500
Quote:
Originally Posted by cajuntec View Post
So just putting Seafoam in your tank makes your exhaust smoke?
All the best,
Glenn
no u have to pour it throw the throttle body turn it off let it sit 20minutes start it up idle and watch for smoke it will show leaks
__________________
Interested in Amsoil? Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2
2012 WK2 SRT8
xJoshxx is offline   Reply With Quote
Unread 05-12-2009, 12:58 PM   #11
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
Has the dealer flashed it or even checked for TSB before the cat was replaced? http://www.wkjeeps.com/tsb/tsb_wk_1803405.pdf
Regards,
Merlin
__________________
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote
Unread 05-13-2009, 07:18 AM   #12
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
Probably not. They replaced several things that didn't solve any problems.
All the best,
Glenn
cajuntec is offline   Reply With Quote
Unread 05-13-2009, 07:49 AM   #13
cajuntec
Registered User
2011 WK 
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 39
Thank you for that TSB. I'll be looking at a new dealership soon.
All the best,
Glenn
cajuntec is offline   Reply With Quote
Unread 10-21-2009, 09:57 AM   #14
derrick_lui
Registered User
 
Join Date: Feb 2009
Location: Boston
Posts: 1
Guys I have the same code P0430. I had my right Cat replaced with a Magnaflow TWICE and the code is still back on. Is there any chance that it would be the Oxygen sensor that needs to be replaced? that is what the exhaust shop guy told me when I had him redo my cat the second time...
derrick_lui is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.