Checking fuel pressure??? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Checking fuel pressure???

Poison spyder items @ oconee off road 706 534 9955FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 10-23-2013, 04:08 PM   #1
goflick
Registered User
2005 WK 
 
Join Date: Jul 2012
Location: Cape May, NJ
Posts: 35
Checking fuel pressure???

I believe that I may be having some fuel pump issues and want to check my fuel pressure. I'm trying to figure out where the schrader value for the fuel line is on a 05 GC WK 4.7L V8?

goflick is offline   Reply With Quote
Unread 10-23-2013, 05:01 PM   #2
WieSeL
Registered User
 
Join Date: Mar 2013
Posts: 472
Quote:
Originally Posted by goflick View Post
I believe that I may be having some fuel pump issues and want to check my fuel pressure. I'm trying to figure out where the schrader value for the fuel line is on a 05 GC WK 4.7L V8?
There isn't one. You have to test in series with the line to the rail. Why do you think you have a pump issue?
WieSeL is offline   Reply With Quote
Unread 10-23-2013, 10:48 PM   #3
goflick
Registered User
2005 WK 
 
Join Date: Jul 2012
Location: Cape May, NJ
Posts: 35
For the last 3-4 months my 2005 GC WK 4.7L(132K miles) has had some issued at start up. At first I thought it was the transmission slipping, I did a tranny filter and fluid change at 100K). The vehicle starts with no issues but when I put it in drive or reverse there is a delay before the vehicle will actually move. After the initial hesitation there are no issues until the last week. It seems that when I park in my driveway, which has a slight incline, I have the initial hesitation but then when I get to the stop sign at the end of my block the vehicle stalls. Start it back up and drive with no issues. When I park in the street I have yet to have the vehicle stall after initial start up. I've never had a fuel pump issue with any of my other vehicles and don't have any experience with fp issues. Anyone with any fp experience that could confirm my concerns???
goflick is offline   Reply With Quote
Unread 10-24-2013, 06:41 AM   #4
caulk04
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: Greenville, Pennsylvania
Posts: 794
Doesn't sound like any fuel pump issue I've ever heard of.

Sounds like a fairly normal priming issue with the 545RFE for the delay. The stalling issue could be a dirty TB and/or failing TPS or IAC valve or it could be a transmission issue. The subtle nuances of how it's stalling could tell whether to think trans or engine, but that's about impossible to troubleshoot with a keyboard.
__________________
Tint, Superchips, SRT intake tube, Gibson catback, catch can. One hardcore DD/kid hauler...yeah.
caulk04 is offline   Reply With Quote
Unread 10-24-2013, 06:54 AM   #5
WieSeL
Registered User
 
Join Date: Mar 2013
Posts: 472
Quote:
Originally Posted by caulk04 View Post
doesn't sound like any fuel pump issue i've ever heard of.

Sounds like a fairly normal priming issue with the 545rfe for the delay. The stalling issue could be a dirty tb and/or failing tps or iac valve or it could be a transmission issue. The subtle nuances of how it's stalling could tell whether to think trans or engine, but that's about impossible to troubleshoot with a keyboard.
x2
WieSeL is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.