CEL, shudder, exhaust cloud - JeepForum.com
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > CEL, shudder, exhaust cloud

50" LED CREE Light Bar Pair With Wiring KitHigh Quality Light Bars at a Lower Price!!!!Jeep Wrangler Bushwacker Flat Fender Flare Sale at Baselin

Unread 08-19-2014, 02:33 PM   #1
Registered User
1994 YJ Wrangler 
Join Date: Apr 2011
Location: Madison, WI
Posts: 24
CEL, shudder, exhaust cloud

Hey Guys -

Tried to post this earlier, but it doesn't look like it posted. 2005 Grand Cherokee ~116,000, started this morning and got a flashing CEL and shuddering. Turned it off, waited a bit and started it up again - no CEL or shudder, but saw a plume of exhaust smoke. Drove it about 5 miles and turned it off for a minutes, started it again and no problems.

Any thoughts on what might have caused this? I've read through the threads and saw IAC, EGR, etc etc..

All and any help is greatly appreciated - driving up into the north woods in Wisconsin next week and don't want to find ourselves stranded in the middle of nowhere.

ethansco is offline   Reply With Quote Quick reply to this message
Unread 08-25-2014, 07:02 AM   #2
Registered User
Join Date: Jun 2006
Location: Lincoln, NE
Posts: 626
Which engine does your 2005 have? Might want to update your profile.
The CEL code would provide a clue where the problem is. It might still be stored in the ECM if you get it checked. Any recent maintenance, air filter, plugs, TB cleaning?
06 Laredo - 4x4 V6 - Stone White - Custom LED Cargo Area Lights, Lighted Visors Added - now at 49k miles

97 Laredo - 4.0 4x4 Daily driver for 8 years then relocated to Arizona for 6 more years with the relatives
Nejeep is online now   Reply With Quote Quick reply to this message
Unread 08-25-2014, 09:17 AM   #3
Registered User
2006 WK 
Join Date: Mar 2009
Location: Sheffield Lake, OH
Posts: 709
Check the codes that are stored. My guess would be a stuck open injector.
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is online now   Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.