post #1 of Old 08-19-2014, 02:33 PM Thread Starter
ethansco
Registered User
1994 YJ Wrangler 
 
Join Date: Apr 2011
Location: Madison
Posts: 24
CEL, shudder, exhaust cloud

Hey Guys -

Tried to post this earlier, but it doesn't look like it posted. 2005 Grand Cherokee ~116,000, started this morning and got a flashing CEL and shuddering. Turned it off, waited a bit and started it up again - no CEL or shudder, but saw a plume of exhaust smoke. Drove it about 5 miles and turned it off for a minutes, started it again and no problems.

Any thoughts on what might have caused this? I've read through the threads and saw IAC, EGR, etc etc..

All and any help is greatly appreciated - driving up into the north woods in Wisconsin next week and don't want to find ourselves stranded in the middle of nowhere.

ethansco is offline  
post #2 of Old 08-25-2014, 07:02 AM
Nejeep
Registered User
 
Join Date: Jun 2006
Location: Lincoln, NE
Posts: 798
Which engine does your 2005 have? Might want to update your profile.
The CEL code would provide a clue where the problem is. It might still be stored in the ECM if you get it checked. Any recent maintenance, air filter, plugs, TB cleaning?

06 Laredo - 4x4 V6 - Stone White - Custom LED Cargo Area Lights, Lighted Visors Added - now at 49k miles

97 Laredo - 4.0 4x4 Daily driver for 8 years then relocated to Arizona for 6 more years with the relatives
Nejeep is online now  
post #3 of Old 08-25-2014, 09:17 AM
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 852
Check the codes that are stored. My guess would be a stuck open injector.

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome